Learn about Centmin Mod LEMP Stack today
Become a Member

Wordpress How to install a Wordpress with forced SSL?

Discussion in 'Blogs & CMS usage' started by sfs00784, Oct 10, 2018.

  1. sfs00784

    sfs00784 Member

    35
    4
    8
    Nov 8, 2017
    Ratings:
    +13
    Local Time:
    12:05 PM
    Since all sites are using SSL now. How could I install a new wordpress and force everything into SSL? thanks
     
  2. eva2000

    eva2000 Administrator Staff Member

    37,214
    8,128
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,514
    Local Time:
    2:05 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    In Centmin Mod 123.09beta01 and newer, for wordpress install + HTTPS with SSL certificate, you actually need to
    1. Make sure intended site domain name/subdomain DNS A records point to the Centmin Mod server. For main domain.com need also www version of the domain having updated and valid DNS A records first
    2. Enable and set in persistent config file at /etc/centminmod/custom_config.inc the following variable LETSENCRYPT_DETECT='y' (create /etc/centminmod/custom_config.inc if it doesn't exist).
    3. Then run centmin.sh menu option 22 which will detect letsencrypt support and display the additional letsencrypt prompts required to issue free letsencrypt ssl certificates for wordpress auto installer. You'd want to select the option for live cert with HTTPS default (trusted) and proceed to install wordpress via the installer's question prompts.
    FYI, for non-wordpress sites you can just use same first 2 steps above but run centmin.sh menu option 2 or nv command as outlined in method 2 or 3 here.
     
  3. sfs00784

    sfs00784 Member

    35
    4
    8
    Nov 8, 2017
    Ratings:
    +13
    Local Time:
    12:05 PM
    Working now! Thanks Eva!
     
  4. bruno

    bruno Member

    70
    6
    8
    Oct 14, 2016
    Ratings:
    +12
    Local Time:
    4:05 AM
    @eva2000 i followed those instructions and still have an SSL error after installing WordPress (https://xn--foh.ws)

    any ideas?
     
  5. eva2000

    eva2000 Administrator Staff Member

    37,214
    8,128
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,514
    Local Time:
    2:05 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
  6. bruno

    bruno Member

    70
    6
    8
    Oct 14, 2016
    Ratings:
    +12
    Local Time:
    4:05 AM
    Managed to fix this. On the server's firewall I had to enable http traffic (was previously set to only https)

    Thanks!
     
    • Informative Informative x 1
  7. eva2000

    eva2000 Administrator Staff Member

    37,214
    8,128
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,514
    Local Time:
    2:05 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    Ah yes HTTP port 80 and HTTPS port 443 are needed
     
..