Want more timely Centmin Mod News Updates?
Become a Member

How to increase WP Memory Limit?

Discussion in 'Install & Upgrades or Pre-Install Questions' started by coldice, Dec 10, 2017.

  1. coldice

    coldice Member

    35
    1
    8
    Nov 27, 2017
    India
    Ratings:
    +2
    Local Time:
    5:24 AM
    1.13.7
    10.1.29
    I have newspaper8 theme installed and it shows 40MB as WP Memory Limit.
    I did added define( 'WP_MEMORY_LIMIT', '256M' ); in wp-config but still the memory is not increased.
     
  2. eva2000

    eva2000 Administrator Staff Member

    37,214
    8,127
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,513
    Local Time:
    9:54 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    did you restart php-fpm services after changing could be zend opcache caching ?

    what's output for command
    Code (Text):
    php -i | grep memory_limi
    


    to edit php.ini settings you need to customise centmin mod way too

    For custom php settings read centminmod.com/phpfpm.html#customphpini. You might want to create /etc/centminmod/php.d/b_customphp.ini to override centmin mod defaults at /etc/centminmod/php.d/a_customphp.ini and restart PHP-FPM.

    Also outlined in Getting Started Guide Step 17
     
  3. coldice

    coldice Member

    35
    1
    8
    Nov 27, 2017
    India
    Ratings:
    +2
    Local Time:
    5:24 AM
    1.13.7
    10.1.29
    php -i | grep memory_limi:
    Code:
    Failed loading /usr/local/lib/php/extensions/no-debug-non-zts-20170718/ioncube.so:  /usr/local/lib/php/extensions/no-debug-non-zts-20170718/ioncube.so: cannot open shared object file: No such file or directory
    memory_limit => 1536M => 1536M
    
    
    I got the same error when I run fpmrestart
    Code:
    Gracefully shutting down php-fpm . done
    Starting php-fpm Failed loading /usr/local/lib/php/extensions/no-debug-non-zts-20170718/ioncube.so:  /usr/local/lib/php/extensions/no-debug-non-zts-20170718/ioncube.so: cannot open shared object file: No such file or directory
     done
    However my new setting in /etc/centminmod/php.d/b_customphp.ini were successfuly applied
     
    Last edited: Dec 10, 2017
  4. eva2000

    eva2000 Administrator Staff Member

    37,214
    8,127
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,513
    Local Time:
    9:54 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    ioncube php extension needs reinstalling using addons/ioncube.sh
     
  5. coldice

    coldice Member

    35
    1
    8
    Nov 27, 2017
    India
    Ratings:
    +2
    Local Time:
    5:24 AM
    1.13.7
    10.1.29
    I upgraded my PHP 5 to 7 and still got this error when installing ioncube loader.
     
  6. coldice

    coldice Member

    35
    1
    8
    Nov 27, 2017
    India
    Ratings:
    +2
    Local Time:
    5:24 AM
    1.13.7
    10.1.29
    If this won't be an issue with my server and website then I can skip this warning.
     
  7. pamamolf

    pamamolf Well-Known Member

    3,119
    295
    83
    May 31, 2014
    Ratings:
    +531
    Local Time:
    1:54 AM
    Nginx-1.13.x
    MariaDB 10.1.x
    For me upgrade or downgrade the ioncube if it is enabled the routine taking care of it automatically.

    Never had to re install it ....
     
  8. eva2000

    eva2000 Administrator Staff Member

    37,214
    8,127
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,513
    Local Time:
    9:54 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    yes like @pamamolf if you set in persistent config file /etc/centminmod/custom_config.inc (create it if doesn't exist) the following variable
    Code (Text):
    PHPIONCUBE='y'
    

    then everytime you upgrade or downgrade PHP, ioncube php extension automatically gets installed
     
..