Join the community today
Register Now

how to ensure ngx-pagespeed is not running?

Discussion in 'Install & Upgrades or Pre-Install Questions' started by tonmo, Jan 1, 2020.

  1. tonmo

    tonmo Member

    36
    1
    8
    Jul 20, 2019
    Ratings:
    +5
    Local Time:
    10:55 AM
    1.17.1
    5.5.5 (10.3.16-MariaDB)
    Hi, how can I best uninstall or ensure ngx-pagespeed is not running? I think I installed it some months back but I'm now on cloudflare and would like to ensure it's disabled on my server.

    Please fill in any relevant information that applies to you:
    • CentOS Version: CentOS 7.7
    • Centmin Mod Version Installed: 123.09beta01
    • Nginx Version Installed: 1.17.7
    • PHP Version Installed: 7.4.1
    • MariaDB MySQL Version Installed: 10.3.21
    • When was last time updated Centmin Mod code base ? : yesterday
    • Persistent Config: Do you have any persistent config file options set in /etc/centminmod/custom_config.inc ? You can check via this command:
      Code (Text):
      cat /etc/centminmod/custom_config.inc
      

      Post output in CODE tags.
    LOL i think step above told me what I need to do

    LETSENCRYPT_DETECT='y'
    NGINX_PAGESPEED=y


     
  2. pamamolf

    pamamolf Premium Member Premium Member

    3,826
    370
    83
    May 31, 2014
    Ratings:
    +712
    Local Time:
    5:55 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    Hello tonmo :)

    Happy new year :)

    To disable it you can run from ssh:
    Code:
    pscontrol off
    At your custom config you can remove that line or set it to "n" :
    Code:
    NGINX_PAGESPEED=n
    Also check at your domain config file:
    Code:
    /usr/local/nginx/conf/conf.d/yourdomain.com.conf
    for any pagespeed include files and if yes then comment them as:
    Code:
    #include /usr/local/nginx/conf/pagespeed.conf;
    #include /usr/local/nginx/conf/pagespeedhandler.conf;
    #include /usr/local/nginx/conf/pagespeedstatslog.conf;
    Then restart nginx and php:
    Code:
    nprestart
     
  3. eva2000

    eva2000 Administrator Staff Member

    44,743
    10,201
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,810
    Local Time:
    12:55 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    ngx_pagespeed isn't enabled by default unless you recompiled Nginx with it enabled as outlined at https://centminmod.com/nginx_ngx_pagespeed.html with NGINX_PAGESPEED='y' enabled in persistent config file at /etc/centminmod/custom_config.inc

    what's output of
    Code (Text):
    nginx -V
     
  4. Nik

    Nik Member

    67
    2
    8
    Dec 7, 2015
    Ratings:
    +9
    Local Time:
    10:55 AM
    Fresh 7 day old centmin install using beta-latest.sh and seems like nginx_pagespeed is set to y by default.

    Just FYI.
     
  5. eva2000

    eva2000 Administrator Staff Member

    44,743
    10,201
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,810
    Local Time:
    12:55 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    yes betainstaller-latest.sh enables ngx_pagespeed by default as intended = latest

    if you don't want ngx_pagespeed use betainstaller.sh or betainstaller73.sh for php 7.3