Join the community today
Register Now

Install Gutenberg or Classic Editor : Comments disabled

Discussion in 'Install & Upgrades or Pre-Install Questions' started by EckyBrazzz, Jun 11, 2019 at 10:30 AM.

  1. EckyBrazzz

    EckyBrazzz Active Member

    378
    71
    28
    Mar 28, 2018
    Brazil
    Ratings:
    +139
    Local Time:
    4:51 AM
    1.17.x
    10.3.x
    When setting up several new domains with the Centmin 22 option I noticed that in my posts and pages the comments disappeared. First I thought, well it's my theme again, will resolve this issue later. But after a while, I tested it with a different theme and still the comments where missing.

    After disabling the Classic Editor Plugin they appeared again. I don't know if this is a new bug or an issue with WordPress, but I'm curious if someone noticed the same.

    Comments are vital on my sites to keep the written posts alive, and Google likes this.
     
  2. fabianski

    fabianski Member

    68
    4
    8
    Feb 20, 2019
    Brazil
    Ratings:
    +17
    Local Time:
    4:51 AM
    I also used the Classic Editor plugin and I had some similar problems, I switched to Disable Gutenberg
     
    • Informative Informative x 1
  3. EckyBrazzz

    EckyBrazzz Active Member

    378
    71
    28
    Mar 28, 2018
    Brazil
    Ratings:
    +139
    Local Time:
    4:51 AM
    1.17.x
    10.3.x
    Will give it a try, because even with the Classic Editor plugin I got Blank pages when editing my child-theme. And changing the edit back to the old value did not resolve it. I make a lot of backup, so repleaced a backup to get things working again.
     
  4. EckyBrazzz

    EckyBrazzz Active Member

    378
    71
    28
    Mar 28, 2018
    Brazil
    Ratings:
    +139
    Local Time:
    4:51 AM
    1.17.x
    10.3.x
    Tested it and it worked but found even a more lightweight solution. As I work with a heavily modified theme I have a child theme I added this to my funcion.php.
    Code (Text):
    /* Disable the Gutenberg editor. */
    add_filter('use_block_editor_for_post', '__return_false');
    

    Already have a lot of plugins, so keeping this number low is better. You never know if there is a weak security spot in the plugin.
    For me, this worked perfectly!

    EDIT: Also my newsletter form popup started to work again:)
     
    Last edited: Jun 11, 2019 at 11:08 AM
  5. eva2000

    eva2000 Administrator Staff Member

    40,188
    8,888
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,697
    Local Time:
    5:51 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    thanks for heads up which full page cache method selection did you choose for centmin.sh menu option 4 wordpress install ?

    might need to report the bug to classic editor folks at [Classic Editor] Support | WordPress.org

    oh they have a sticky for blank pages Common classic editor errors and how to fix them | WordPress.org

     
  6. EckyBrazzz

    EckyBrazzz Active Member

    378
    71
    28
    Mar 28, 2018
    Brazil
    Ratings:
    +139
    Local Time:
    4:51 AM
    1.17.x
    10.3.x
    Haha, no went back to 22-1. And had too many problems with editing PHP when the classic editor was activated. Same as @fabianski reported, trouble with this plugin.
    Removed the plugin and add the code to my function.php made me happy again! Even other plugins started to work again. The sticky page has nothing to do with the blank page.

    domain.com just got blank after changing a simple line in PHP, and reverting it back to the old code still gave a blank page. Only replacing a backup resolved the issue.
     
    • Informative Informative x 1
  7. eva2000

    eva2000 Administrator Staff Member

    40,188
    8,888
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,697
    Local Time:
    5:51 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    just tested centmin.sh menu option 22 and no problems with comments myself they show up

    tested centmin.sh menu option and wp super cache and did get a 500 error and seems for that routine wp-config.php ended up with incorrect user permission which i fixed on 123.09beta01 update I just committed to ensure it's owned by nginx user. That could one thing to check for incorrect permissions and ensure all files are owned by nginx user/group via command below changing ${vhostname} to your domain name
    Code (Text):
    chown -R nginx:nginx /home/nginx/domains/${vhostname}/public
     
..