Welcome to Centmin Mod Community
Become a Member

Google reCAPTCHA v2 and v3 give problems

Discussion in 'Install & Upgrades or Pre-Install Questions' started by EckyBrazzz, May 22, 2019.

  1. EckyBrazzz

    EckyBrazzz Active Member

    783
    155
    43
    Mar 28, 2018
    >>>>Click here<<<< i'm nearby......
    Ratings:
    +287
    Local Time:
    3:38 PM
    1.17.x Cluster
    10.3.x Cluster & Redis
    Hi Folks,

    Just tried some plugins to get rid of spam and protect our sites even more.
    Created the correct keys for v2 and v3 version of the Google reCAPTCHA, but non of them work correctly. v2 does not show up on the comment form, but seems to work on the login for. If I use v3 suddenly my login credentials are invalid. The v3 hidden is below on the right side. What is correct. I made sure to empty the cache before switching plugins.

    When a user wants to place comment on v2 the place comment is gone, when I use v3 they can place comments and the invisible reCAPTCHA is present, but for some reason the comment does not appear (not for approval, nor on the site)

    As mentioned before, I tested several plugins, and they all gave me the same result. So for some reason it has to do with our installation of CMM
     
  2. EckyBrazzz

    EckyBrazzz Active Member

    783
    155
    43
    Mar 28, 2018
    >>>>Click here<<<< i'm nearby......
    Ratings:
    +287
    Local Time:
    3:38 PM
    1.17.x Cluster
    10.3.x Cluster & Redis
    As an example an uploaded image with v3, the reCAPTCHA is present in the corner, but my pw is not accepted. The pw in the field is NOT THE REAL password, I changed it before making a screenshot ;)
    recaptcha4.png
     
  3. EckyBrazzz

    EckyBrazzz Active Member

    783
    155
    43
    Mar 28, 2018
    >>>>Click here<<<< i'm nearby......
    Ratings:
    +287
    Local Time:
    3:38 PM
    1.17.x Cluster
    10.3.x Cluster & Redis
    Resolved with new keys for v3. Forgot to wait for 30 minutes as Google indicated in a small (hidden) field.