Learn about Centmin Mod LEMP Stack today
Register Now

Wordpress Get CDN service working with Redis and Autooptimize

Discussion in 'Blogs & CMS usage' started by hkim, Feb 27, 2019.

  1. hkim

    hkim New Member

    24
    3
    3
    Feb 14, 2019
    Ratings:
    +4
    Local Time:
    5:08 AM
    I've installed LEMP with option 22 in Centminmod with REDIS and KeyCDN. However, I do not want to use KeyCDN. I have therefore disabled CDN Helper and installed a plugin for Bunny CDN. However, even though I followed their instructions things are not working.

    Do I need to make some changes in the predefined settings of Centminmod's installation of LEMP to get this working?
     
  2. hkim

    hkim New Member

    24
    3
    3
    Feb 14, 2019
    Ratings:
    +4
    Local Time:
    5:08 AM
    Oh, this was an issue with Elementor Pro. I needed open, edit something and save the post to get it to rebuild properly.
     
    • Informative Informative x 1
  3. eva2000

    eva2000 Administrator Staff Member

    41,292
    9,265
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,216
    Local Time:
    1:08 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    Good to know :)
     
  4. hkim

    hkim New Member

    24
    3
    3
    Feb 14, 2019
    Ratings:
    +4
    Local Time:
    5:08 AM
    Well it is working and not working. Further testing verified that it has nothing to do with the pagebuilder.

    It seems to be an issue with Autoptimize (AO). If I make an update to a post, just saving the post doesn't work. Having AO enabled then leads to messing up the formatting of the post. It does not matter if I then manually clear the cache, the problem persists until I have to manually disable and enable AO.

    This it totally unpractical of course. What can be wrong?
     
  5. eva2000

    eva2000 Administrator Staff Member

    41,292
    9,265
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,216
    Local Time:
    1:08 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    play with autoptimize settings some of the css/js inlining options can break stuff as outlined in settings page itself so turn those off