Join the community today
Become a Member

Install FTP password, getting wrong password error

Discussion in 'Install & Upgrades or Pre-Install Questions' started by elargento, Jul 31, 2017.

  1. elargento

    elargento Member

    293
    16
    18
    Jan 4, 2016
    Ratings:
    +39
    Local Time:
    10:21 AM
    10
    • CentOS Version: CentOS 7 64bit ?
    • Centmin Mod Version Installed: 123.09beta01
    Can anybody else reproduce this on a fresh install? I was able to reproduce it twice but don't want to format the server again to check it.

    Just try to create an ftp account with the following password:
    lYVKlCXp0vj2uSFFOPhq5

    When I want to connect to FTP I get a wrong password error. I'm 99% sure I didn't copy any space.
     
  2. eva2000

    eva2000 Administrator Staff Member

    30,924
    6,911
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,407
    Local Time:
    11:21 PM
    Nginx 1.13.x
    MariaDB 5.5
  3. elargento

    elargento Member

    293
    16
    18
    Jan 4, 2016
    Ratings:
    +39
    Local Time:
    10:21 AM
    10
  4. eva2000

    eva2000 Administrator Staff Member

    30,924
    6,911
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,407
    Local Time:
    11:21 PM
    Nginx 1.13.x
    MariaDB 5.5
    i am not able to reproduce this problem using your password uFpdN3tNGvc7 i can change and log in fine. How are you copying and pasting the passwords from within your SSH client to your FTP/SFTP client ? Tried highlighting the password and right click, copy and paste ? Some SSH clients with their own shortcuts add extra spaces to copied text.
     
  5. elargento

    elargento Member

    293
    16
    18
    Jan 4, 2016
    Ratings:
    +39
    Local Time:
    10:21 AM
    10
    Well, I've just copied the password from my post. Set the same password to ftp (right click), went to filezilla and pasted the same password (so I made sure the same password was entered) and I still get the authentication error
     
  6. elargento

    elargento Member

    293
    16
    18
    Jan 4, 2016
    Ratings:
    +39
    Local Time:
    10:21 AM
    10
    Can password be decrypted so we can find out what was set?
     
  7. eva2000

    eva2000 Administrator Staff Member

    30,924
    6,911
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,407
    Local Time:
    11:21 PM
    Nginx 1.13.x
    MariaDB 5.5
    not really,

    did you run both commands from Pure-FTPD Virtual FTP Users - CentminMod.com LEMP Nginx web stack for CentOS for passwd and mkdb ? Try using show command before and after password change to see if the encrypted password changed
    Code (Text):
    pure-pw show FTPUSERNAME
    pure-pw passwd FTPUSERNAME
    pure-pw mkdb
    pure-pw show FTPUSERNAME
    

    where FTPUSERNAME is your ftp username created by centmin.sh nginx vhost generation routine.

    also filezilla enable debug log verbose display so when you log in you get more details for specific issue
     
  8. elargento

    elargento Member

    293
    16
    18
    Jan 4, 2016
    Ratings:
    +39
    Local Time:
    10:21 AM
    10
    the encrypted password changed.

    same issue
    Code:
    Traza:    We claim version: SSH-2.0-PuTTY_Local:_Apr_30_2017_13:18:36
    Traza:    Server version: SSH-2.0-OpenSSH_6.6.1
    Traza:    We believe remote version has SSH-2 channel request bug
    Traza:    Using SSH protocol version 2
    Traza:    Doing Diffie-Hellman group exchange
    Traza:    Doing Diffie-Hellman key exchange with hash SHA-256
    Traza:    Server also has ssh-ed25519/ecdsa-sha2-nistp256 host keys, but we don't know any of them
    Traza:    Host key fingerprint is:
    Traza:    ssh-rsa 2048 cd:df:8e:e1:aa:10:13:ce:74:0d:9c:1a:b8:a4:06:c0 oQ3m1rhpBuormv4pVqlbWLED6Ugk/czGC3AM401uO18=
    Traza:    Initialised AES-256 GCM client->server encryption
    Traza:    Initialised AES256 GCM client->server MAC algorithm (in ETM mode) (required by cipher)
    Traza:    Initialised AES-256 GCM server->client encryption
    Traza:    Initialised AES256 GCM server->client MAC algorithm (in ETM mode) (required by cipher)
    Comando:    Pass: *********************
    Traza:    Sent password
    Traza:    Password authentication failed
    Error:    La autenticación falló.
    Traza:    CControlSocket::DoClose(1030)
    Traza:    CSftpControlSocket::ResetOperation(1094)
    Traza:    CControlSocket::ResetOperation(1094)
    Error:    Critical error: No se pudo conectar al servidor
    Traza:    CFileZillaEnginePrivate::ResetOperation(1094)
     
  9. eva2000

    eva2000 Administrator Staff Member

    30,924
    6,911
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,407
    Local Time:
    11:21 PM
    Nginx 1.13.x
    MariaDB 5.5
    set filezilla default system language to english instead could be non-english character set issues
     
  10. elargento

    elargento Member

    293
    16
    18
    Jan 4, 2016
    Ratings:
    +39
    Local Time:
    10:21 AM
    10
    This fixed it. What's the explanation? The IP, username and password were the same when Filezilla was in another language but this time I was able to log in
     
  11. eva2000

    eva2000 Administrator Staff Member

    30,924
    6,911
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,407
    Local Time:
    11:21 PM
    Nginx 1.13.x
    MariaDB 5.5
    Differences in how non-english character sets recognise certain characters I suppose. For 100% problem free usage, SSH and SFTP/FTP clients should always be set to English and UTF-8 if possible.
     
  12. elargento

    elargento Member

    293
    16
    18
    Jan 4, 2016
    Ratings:
    +39
    Local Time:
    10:21 AM
    10
    What is strange is the password doesn't have any non-english characters
     
  13. eva2000

    eva2000 Administrator Staff Member

    30,924
    6,911
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,407
    Local Time:
    11:21 PM
    Nginx 1.13.x
    MariaDB 5.5
    who knows could be filezilla bug :)
     
    • Funny Funny x 1