Welcome to Centmin Mod Community
Register Now

Wordpress FTP connection on plugin update issue

Discussion in 'Blogs & CMS usage' started by Afaq, Apr 16, 2016.

Tags:
  1. Afaq

    Afaq Member

    61
    1
    8
    Aug 5, 2015
    Ratings:
    +2
    Local Time:
    7:34 AM
    I installed the WordPress using the automatic option. Now, I am trying to update some plugin and it is asking me to enter the FTP information. Even though I am entering the right credentials, it is not working. The dialog box disappears for a second and then comes back. Any idea how can I disable this extra piece of security?

    Thanks.
     
  2. eva2000

    eva2000 Administrator Staff Member

    30,947
    6,915
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,413
    Local Time:
    12:34 PM
    Nginx 1.13.x
    MariaDB 5.5
    You'll need to post on the forums with the following info
    • Server or VPS details ? XEN, KVM, OpenVZ, VMWare or dedicated server ? OS ? CentOS 6.7 or 7.2 ? 32bit or 64bit ?
    • What version of Centmin Mod ? .07 stable or 08 stable or .09 beta01 or another branch version ?
    • Was it fresh install or upgrade ?
    • Method of install ? Via centmin.sh menu option 1, Git install or curl one liner install as outlined at centminmod.com/download.html ?
    • How long ago did you install Centmin Mod ?
    • There's numerous code changes, bug fixes over time, so ensure you have latest Centmin Mod code installed by upgrading your Centmin Mod code as instructed below.
    Updating Wordpress plugin from WP admin plugin page ? it shouldn't need to prompt for FTP user details. How was the specifc WP plugin initially installed ? via WP admin plugin > add new plugin or via standard FTP user update as root user or as Pure-ftpd virtual user ? If used standard FTP user upload to initially install WP plugin, then follow Getting Started Guide step 2 and chown the right user and group permissions to nginx
    Easiest way is to ensure you install WP plugins via WP admin plugin > add new plugin so the installed files have correct user and group permissions.

    Also are you using any caching like WP Super Cache or KeyCDN Cache Enabler ? ensure you have configured them not to cache logged in users as well as outlined at Wordpress Nginx Auto Installer (WP Super Cache)