Learn about Centmin Mod LEMP Stack today
Register Now

Forum Weekly Digest

Discussion in 'Forum News' started by eva2000, Nov 19, 2015.

  1. eva2000

    eva2000 Administrator Staff Member

    31,027
    6,928
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,434
    Local Time:
    2:48 AM
    Nginx 1.13.x
    MariaDB 5.5
    Added a forum weekly digest of popular threads rated by most viewed.

    The email has it's own subscribe and unsubscribe management link at the foot of the email digests.

    upload_2015-11-19_11-32-51.png

    upload_2015-11-19_11-33-46.png
     
    • Like Like x 1
  2. eva2000

    eva2000 Administrator Staff Member

    31,027
    6,928
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,434
    Local Time:
    2:48 AM
    Nginx 1.13.x
    MariaDB 5.5
    FYI, the digest has been temporarily disabled as links and unsubscribe link were broken and missing forum domain name so need to fix the bug.
     
  3. eva2000

    eva2000 Administrator Staff Member

    31,027
    6,928
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,434
    Local Time:
    2:48 AM
    Nginx 1.13.x
    MariaDB 5.5
    Opened up this thread for replies as trying to troubleshoot a problem with Weekly digest email's linked threads and unsubscribe like missing the forum domain name in the url links ONLY for forum wide mailings. If i do single userid test email to myself the forum domain exists in url links in email !.

    Anyone else get the weekly digest missing the forum domain name in thread and unsubscribe links ?

    @Matt @RoldanLT @Matt Williams @jeffwidman @pamamolf @Jimmy @Sunka @deltahf @Andy ?
     
  4. RoldanLT

    RoldanLT Well-Known Member

    3,982
    966
    113
    May 25, 2014
    Phillipines
    Ratings:
    +1,331
    Local Time:
    12:48 AM
    1.11
    10.2
    Yeah no forum url, I received yesterday.
    But I'm not using that addon, so no idea why :|.
     
  5. eva2000

    eva2000 Administrator Staff Member

    31,027
    6,928
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,434
    Local Time:
    2:48 AM
    Nginx 1.13.x
    MariaDB 5.5
    cheers @RoldanLT - it's a strange bug indeed.. has both AndyB (addon author) and me scratching our heads. AndyB believes it's something to do with Amazon SES SMTP usage on the forums as modified code testing saving the digest email to local file shows the domain exists for both forum wide and single user tests ! Weird !

    For now have weekly digest disabled until I can figure this out.
     
  6. Matt

    Matt Moderator Staff Member

    697
    322
    63
    May 25, 2014
    Sheffield, UK
    Ratings:
    +449
    Local Time:
    4:48 PM
    1.7.1
    MariaDB 10
    I'm using Amazon SES via SMTP, and everything works fine?? I can forward you a copy of the mail if you want to take a look?
     
  7. eva2000

    eva2000 Administrator Staff Member

    31,027
    6,928
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,434
    Local Time:
    2:48 AM
    Nginx 1.13.x
    MariaDB 5.5
    hey @Matt

    ah wonder if it's due to me being on XF 1.4 branch still and you using XF 1.5 ? Need to find a long enough free window of time to do updates, deploy new still (FA+) etc :)
     
  8. Matt

    Matt Moderator Staff Member

    697
    322
    63
    May 25, 2014
    Sheffield, UK
    Ratings:
    +449
    Local Time:
    4:48 PM
    1.7.1
    MariaDB 10
    Possible, but I don't see how that could have really impacted it? I've been using SES for ages, and only recently upgraded to XF1.5
     
    • Like Like x 1
  9. eva2000

    eva2000 Administrator Staff Member

    31,027
    6,928
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,434
    Local Time:
    2:48 AM
    Nginx 1.13.x
    MariaDB 5.5
    yeah has me scratching my head.. but going to revisit it once I update to XF 1.5 :)
     
    • Like Like x 1
  10. RoldanLT

    RoldanLT Well-Known Member

    3,982
    966
    113
    May 25, 2014
    Phillipines
    Ratings:
    +1,331
    Local Time:
    12:48 AM
    1.11
    10.2
  11. eva2000

    eva2000 Administrator Staff Member

    31,027
    6,928
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,434
    Local Time:
    2:48 AM
    Nginx 1.13.x
    MariaDB 5.5
  12. RoldanLT

    RoldanLT Well-Known Member

    3,982
    966
    113
    May 25, 2014
    Phillipines
    Ratings:
    +1,331
    Local Time:
    12:48 AM
    1.11
    10.2
    Aw not via crontab anymore? Why?
     
  13. eva2000

    eva2000 Administrator Staff Member

    31,027
    6,928
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,434
    Local Time:
    2:48 AM
    Nginx 1.13.x
    MariaDB 5.5
    system cron i refer to is crontab/crond
     
    • Like Like x 1
  14. RoldanLT

    RoldanLT Well-Known Member

    3,982
    966
    113
    May 25, 2014
    Phillipines
    Ratings:
    +1,331
    Local Time:
    12:48 AM
    1.11
    10.2
    Then this could be the reason of your problem here:
     
    • Informative Informative x 1
  15. eva2000

    eva2000 Administrator Staff Member

    31,027
    6,928
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,434
    Local Time:
    2:48 AM
    Nginx 1.13.x
    MariaDB 5.5
    oh i see the possible problem now
    so i ran with crond set php cli command to cli/defer.php instead of /deferred.php curl call so maybe domain name variable missing ? But doesn't explain why testing single userid works and member wide is missing domain name only ?
    @Matt how have you got deferred.php called ?
     
  16. RoldanLT

    RoldanLT Well-Known Member

    3,982
    966
    113
    May 25, 2014
    Phillipines
    Ratings:
    +1,331
    Local Time:
    12:48 AM
    1.11
    10.2
    Maybe because doing it manually should work fine versus deferred doing it via cron?
     
  17. eva2000

    eva2000 Administrator Staff Member

    31,027
    6,928
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,434
    Local Time:
    2:48 AM
    Nginx 1.13.x
    MariaDB 5.5
    ah maybe the case, i don't think i'd done manual runs with member wide ! Sunday is quiet so will do a test run.. hope members don't mind :)
     
  18. Matt

    Matt Moderator Staff Member

    697
    322
    63
    May 25, 2014
    Sheffield, UK
    Ratings:
    +449
    Local Time:
    4:48 PM
    1.7.1
    MariaDB 10
    I'm calling it per the built in XF process, I've not split it out into a cron
     
    • Informative Informative x 1
  19. eva2000

    eva2000 Administrator Staff Member

    31,027
    6,928
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,434
    Local Time:
    2:48 AM
    Nginx 1.13.x
    MariaDB 5.5
    thanks.. just updated to weekly digest 2.0 and setup crond curl call to deferred.php and will see :)
     
  20. eva2000

    eva2000 Administrator Staff Member

    31,027
    6,928
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,434
    Local Time:
    2:48 AM
    Nginx 1.13.x
    MariaDB 5.5
    yay works for me on manual run at least

    was a member wide run

    upload_2015-12-6_7-44-57.png
     
    • Like Like x 1