Discover Centmin Mod today
Register Now

Beta Branch fix python 3.6 native CentOS 7 support in 123.09beta01

Discussion in 'Centmin Mod Github Commits' started by eva2000, Sep 20, 2019.

  1. eva2000

    eva2000 Administrator Staff Member

    46,180
    10,499
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,278
    Local Time:
    9:35 AM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    fix python 3.6 native CentOS 7 support in 123.09beta01

    - CentOS 7.7 now as native python 3.6 yum packages named in format python3-, while previously Centmin Mod used python36u from IUS Community and then replaced that with python36 paackages from EPEL. As such yum updates may report conflicts.
    - This update attempts to fix those conflicts, when you run cmupdate to update 123.09beta01 and then run centmin.sh menu option once and then exit via centmin.sh menu option 24 - which will prompt you to run /usr/local/src/centminmod/addons/python36_install.sh if python36u is detected. Running /usr/local/src/centminmod/addons/python36_install.sh will then resolve most of known conflicts by replacing python36u or python36 packages with native python3 packages which seem to be available for both CentOS 7.6 and 7.7 now.
    - You can also do this by running cmupdate and then /usr/local/src/centminmod/addons/python36_install.sh for 90% of the fixes. For 100% of fixes, cmupdate + centmin.sh menu run once is needed, before running /usr/local/src/centminmod/addons/python36_install.sh
    - These conflicts only occur on existing Centmin Mod 123.09beta01 installs and not fresh new ones which will install by default python3 correct native CentOS 7 packages now instead of python36u from IUS Community or python36 from EPEL.

    Continue reading...

    123.09beta01 branch