Welcome to Centmin Mod Community
Become a Member

FFMPEG Error Installing

Discussion in 'Install & Upgrades or Pre-Install Questions' started by MRY, Oct 23, 2020.

  1. MRY

    MRY New Member

    6
    1
    3
    Sep 23, 2020
    Ratings:
    +2
    Local Time:
    5:54 PM
    • CentOS Version: CentOS 7.8.2003 64bit 5.8.14-1.el7.elrepo.x86_64
    • Centmin Mod Version Installed: 123.09beta01
    • Nginx Version Installed: 1.19.3
    • PHP Version Installed: 7.2.34
    • MariaDB MySQL Version Installed: 10.4.15
    • When was last time updated Centmin Mod code base ? : Today
    • Persistent Config: Do you have any persistent config file options set in /etc/centminmod/custom_config.inc ? You can check via this command:
      Code (Text):
      cat /etc/centminmod/custom_config.inc
      
      NGINX_HPACK='y'
      CLOUDFLARE_ZLIB='y'
      NGINX_DYNAMICTLS='y'
      PHP_PGO_ALWAYS='y'
      PHP_PGO='y'
      PHP_TUNING='y'
      PHPIONCUBE='y'
      MARIADB_INSTALLTENFOUR='y'
      ENABLE_MARIADBTENTWOUPGRADE='y'
      ENABLE_MARIADBTENTHREEUPGRADE='y'
      ENABLE_MARIADBTENFOURUPGRADE='y'
      PHP_LIBZIP='y'
      PHP_ARGON='y'
      PHP_BROTLI='y'
      PHP_LZFOUR='y'
      PHP_LZF='y'
      PHP_ZSTD='y'
      AUTODETECPHP_OVERRIDE='y'
      DUALCERTS='y'
      LETSENCRYPT_DETECT='y'
      ACMEDEBUG='y'
      PHPFINFO='y'
      NGINX_SSLCACHE_ALLOWOVERRIDE='y'
      NGINX_STAPLE_CACHE_OVERRIDE='y'
      NGINX_STAPLE_CACHE_TTL='86400'
      AUTOHARDTUNE_NGINXBACKLOG='y'
      ZSTD_LOGROTATE_NGINX='y'
      ZSTD_LOGROTATE_PHPFPM='y'
      SELFSIGNEDSSL_ECDSA='y'
      NGINX_ZERODT='y'
      NGINX_GEOIPTWOLITE='y'
      NGXDYNAMIC_GEOIPTWOLITE='y'
      MM_LICENSE_KEY='XXXXXXXXXXXXXXXXXXXX'
      NGINX_IOURING_PATCH_BETA='y'
      MARCH_TARGETNATIVE='y'
      NGXDYNAMIC_VHOSTSTATS='n'
      DEVTOOLSETNINE='y'
      GENERAL_DEVTOOLSETGCC='y'
      CRYPTO_DEVTOOLSETGCC='y'
      NGINX_DEVTOOLSETGCC='y'
      PUREFTPD_DISABLED='y'
      PHP_VERSION='7.2.34'
      ZOPCACHEDFT='y'
      
      


      AMD Ryzen 5 3600
      64 GB Ram
      2x 512GB NVME Raid 0

      I always get the same error during installation, I tried different explanations in the forum but I keep getting the same error.

      cmupdate
      cmdir
      cd addons
      ./ffmpeg.sh install

      OR centminmod menu setup...

      Code (Text):
      ERROR
      
      If you think configure made a mistake, make sure you are using the latest
      version from Git.  If the latest version fails, report the problem to the
      ffmpeg-user@ffmpeg.org mailing list or IRC #ffmpeg on irc.freenode.net.
      Include the log file "ffbuild/config.log" produced by configure as this will help
      solve the problem.
      Makefile:2: ffbuild/config.mak: No such file or directory
      Makefile:40: /tools/Makefile: No such file or directory
      Makefile:41: /ffbuild/common.mak: No such file or directory
      Makefile:104: /libavutil/Makefile: No such file or directory
      Makefile:104: /ffbuild/library.mak: No such file or directory
      Makefile:106: /fftools/Makefile: No such file or directory
      Makefile:107: /doc/Makefile: No such file or directory
      Makefile:108: /doc/examples/Makefile: No such file or directory
      Makefile:174: /tests/Makefile: No such file or directory
      make: *** No rule to make target `/tests/Makefile'.  Stop.
      Makefile:2: ffbuild/config.mak: No such file or directory
      Makefile:40: /tools/Makefile: No such file or directory
      Makefile:41: /ffbuild/common.mak: No such file or directory
      Makefile:104: /libavutil/Makefile: No such file or directory
      Makefile:104: /ffbuild/library.mak: No such file or directory
      Makefile:106: /fftools/Makefile: No such file or directory
      Makefile:107: /doc/Makefile: No such file or directory
      Makefile:108: /doc/examples/Makefile: No such file or directory
      Makefile:174: /tests/Makefile: No such file or directory
      make: *** No rule to make target `/tests/Makefile'.  Stop.
      Makefile:2: ffbuild/config.mak: No such file or directory
      Makefile:40: /tools/Makefile: No such file or directory
      Makefile:41: /ffbuild/common.mak: No such file or directory
      Makefile:104: /libavutil/Makefile: No such file or directory
      Makefile:104: /ffbuild/library.mak: No such file or directory
      Makefile:106: /fftools/Makefile: No such file or directory
      Makefile:107: /doc/Makefile: No such file or directory
      Makefile:108: /doc/examples/Makefile: No such file or directory
      Makefile:174: /tests/Makefile: No such file or directory
      make: *** No rule to make target `/tests/Makefile'.  Stop.
      /opt/ffmpeg/lib
      
      Installed FFMPEG binary at /opt/bin/ffmpeg
      
      /usr/local/src/centminmod/addons/ffmpeg.sh: line 550: /opt/bin/ffmpeg: No such file or directory
      
      /usr/local/src/centminmod/addons/ffmpeg.sh: line 553: /opt/bin/ffmpeg: No such file or directory
      
      Binaries installed at /opt/bin
      
      The ffmpeg php extension is no longer supported due to developer support ending
      If you have ran centmin.sh menu option 19 submenu option 1, then you have installed
      ffmpeg binary at /opt/bin/ffmpeg and can use that with some web apps only requiring
      pointing to the full path of ffmpeg binary at /opt/bin/ffmpeg
      
      



      Code (Text):
      ls -lahrt /root/centminlogs | grep ffmpeg
      -rw-r--r--   1 root root 537K Oct 22 23:25 centminmod_ffmpeg_install_221020-232240.log
      -rw-r--r--   1 root root  373 Oct 22 23:25 centminmod_ffmpeg_phpext_install_221020-232504.log
      -rw-r--r--   1 root root  373 Oct 22 23:27 centminmod_ffmpeg_phpext_install_221020-232726.log
      -rw-r--r--   1 root root 537K Oct 22 23:32 centminmod_ffmpeg_install_221020-233043.log
      -rw-r--r--   1 root root 537K Oct 22 23:59 centminmod_ffmpeg_install_221020-235722.log
      -rw-r--r--   1 root root 537K Oct 23 12:34 centminmod_ffmpeg_install_231020-123314.log
      -rw-r--r--   1 root root  373 Oct 23 12:34 centminmod_ffmpeg_phpext_install_231020-123453.log
      
      



     

    Attached Files:

  2. eva2000

    eva2000 Administrator Staff Member

    45,660
    10,359
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,078
    Local Time:
    12:54 AM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    looks like you found a bug in x265 download routine which either changed download URLs or your server hand issues downloading x265 download source files. Will take a look at it

    Code (Text):
    abort: HTTP Error 404: Not Found
    /usr/local/src/centminmod/addons/ffmpeg.sh: line 392: cd: /opt/ffmpeg_sources/x265/build/linux: No such file or directory
    
     
  3. MRY

    MRY New Member

    6
    1
    3
    Sep 23, 2020
    Ratings:
    +2
    Local Time:
    5:54 PM
    This setup was very important to me :( I guess I have no choice but to wait.

    I can share my server information privately with you if you want to check. already a test server No problem for me...
     
  4. eva2000

    eva2000 Administrator Staff Member

    45,660
    10,359
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,078
    Local Time:
    12:54 AM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    Last edited: Oct 24, 2020
  5. eva2000

    eva2000 Administrator Staff Member

    45,660
    10,359
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,078
    Local Time:
    12:54 AM
    Nginx 1.19.x
    MariaDB 5.5/10.x
  6. MRY

    MRY New Member

    6
    1
    3
    Sep 23, 2020
    Ratings:
    +2
    Local Time:
    5:54 PM
    You are awesome, it installed seamlessly. <3 centminmod