Want to subscribe to topics you're interested in?
Become a Member

Joomla Failed to start the session

Discussion in 'Blogs & CMS usage' started by uzey, May 24, 2016.

  1. uzey

    uzey New Member

    16
    3
    3
    May 15, 2016
    Ratings:
    +5
    Local Time:
    1:36 PM
    1.9.15
    5.5
    Hi all,

    Currently installing on my vbox centos 7 + centmin mod .08stable.

    After a complete restore a joomla webpage (using akeeba backup/restore wizard), I get this error on my browser "Error displaying the error page: Application Instantiation Error:Failed to start the session"

    Does anyone have this problem before? Please help!!

    Thanks!!
     
  2. eva2000

    eva2000 Administrator Staff Member

    30,195
    6,789
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,144
    Local Time:
    3:36 PM
    Nginx 1.13.x
    MariaDB 5.5
    same php version on both old and new server setups ?

    quite a few google results if you search for "Error displaying the error page: Application Instantiation Error:Failed to start the session" as it's joomla specific
     
  3. uzey

    uzey New Member

    16
    3
    3
    May 15, 2016
    Ratings:
    +5
    Local Time:
    1:36 PM
    1.9.15
    5.5
    the old server using php 7.0.5 the new vm using 7.0.6. I found few threads regarding igbinary.ini in joomla. Need more info on this, since this is totaly new for me
     
  4. eva2000

    eva2000 Administrator Staff Member

    30,195
    6,789
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,144
    Local Time:
    3:36 PM
    Nginx 1.13.x
    MariaDB 5.5
    if it's igbinary, you can check by temp disabling the extension load line in igbinary.ini file

    the command below lists all custom PHP extensions' ini file paths for extensions added by Centmin Mod specifically
    Code (Text):
    php --ini


    find the igbinary.ini path file and edit it and comment out the extension load line and restart PHP-FPM service

    example
    Code (Text):
    php --ini
    Configuration File (php.ini) Path: /usr/local/lib
    Loaded Configuration File: /usr/local/lib/php.ini
    Scan for additional .ini files in: /etc/centminmod/php.d
    Additional .ini files parsed: /etc/centminmod/php.d/a_customphp.ini,
    /etc/centminmod/php.d/curlcainfo.ini,
    /etc/centminmod/php.d/geoip.ini,
    /etc/centminmod/php.d/igbinary.ini,
    /etc/centminmod/php.d/imagick.ini,
    /etc/centminmod/php.d/memcache.ini,
    /etc/centminmod/php.d/memcached.ini,
    /etc/centminmod/php.d/mongodb.ini,
    /etc/centminmod/php.d/redis.ini,
    /etc/centminmod/php.d/suhosin.ini


    restart PHP
    Code (Text):
    service php-fpm restart

    or with command shortcut
    Code (Text):
    fpmrestart


    If that fixes it, you can try permanently disabling php igbinary install via creating persistent config file at /etc/centminmod/custom_config.inc and add to it
    Code (Text):
    IGBINARY_INSTALL='n'

    then whenever in future you recompile or update PHP via centmin.sh menu option 5, php igbinary is not installed