Welcome to Centmin Mod Community
Become a Member

Upgrade Error while upgrade to 123.09beta01

Discussion in 'Install & Upgrades or Pre-Install Questions' started by Doni, Dec 1, 2016.

  1. Doni

    Doni New Member

    29
    1
    3
    Aug 23, 2014
    Ratings:
    +3
    Local Time:
    4:44 PM
    nginx/1.7.4
    mysql Ver 15.1 Distrib 5.5.39-MariaDB, for Linux (x86_64) using readline 5.1
    Hi eva, i just upgrade centmin to 123.09beta01, but when i run centminmod i found error on some config and also the wget could not updated. Is there anyway to fix that?


    Code:
    [root@harimao addons]# centmin
    
    /usr/local/src/centminmod /usr/local/src/centminmod/addons
    
    
    /etc/init.d /usr/local/src/centminmod
    
    /usr/local/src/centminmod
    
    inc/cpcheck.inc: line 941: /usr/local/nginx/conf/wpsecure_ononiha.id.conf
    
    /usr/local/nginx/conf/wpincludes/travel.kabarnias.com/wpsecure_travel.kabarnias.com.conf
    
    /usr/local/nginx/conf/wpincludes/ononiha.net/wpsecure_ononiha.net.conf
    
    /usr/local/nginx/conf/wpincludes/kandangboekoe.ononiha.org/wpsecure_kandangboekoe.ononiha.org.conf: No such file or directory
    
    update wget to 1.18 version... one time task
    
    /usr/local/src/centminmod/addons/wget.sh: line 178: /usr/local/bin/wget: No such file or directory
    
    Download wget-1.18.tar.gz ...
    
    wget-1.18.tar.gz Archive found, skipping download...
    
    wget-1.18.tar.gz valid file.
    
    
    
    configure: configuring for GNU Wget 1.18
    
    checking for a BSD-compatible install... /usr/bin/install -c
    
    checking whether build environment is sane... yes
    
    checking for a thread-safe mkdir -p... /bin/mkdir -p
    
    checking for gawk... gawk
    
    checking whether make sets $(MAKE)... yes
    
    checking whether make supports nested variables... yes
    
    checking build system type... x86_64-pc-linux-gnu
    
    checking host system type... x86_64-pc-linux-gnu
    
    checking whether make supports nested variables... (cached) yes
    
    checking for gcc... /opt/rh/devtoolset-4/root/usr/bin/gcc
    
    checking whether the C compiler works... no
    
    configure: error: in `/svr-setup/wget-1.18':
    
    configure: error: C compiler cannot create executables
    
    See `config.log' for more details
    
    There seems to be no Makefile in this directory.
    
    You must run ./configure before running 'make'.
    
    make: *** [abort-due-to-no-makefile] Error 1
    
    There seems to be no Makefile in this directory.
    
    You must run ./configure before running 'make'.
    
    make: *** [abort-due-to-no-makefile] Error 1
    
    ldconfig: /usr/lib64/libstdc++.so.6 is not a symbolic link
    
    
    
    --------------------------------------------------------
    
    ldconfig -p | grep libpcre.so.1
    
    libpcre.so.1 (libc6,x86-64) => /usr/local/lib/libpcre.so.1
    
    
    ldd /usr/bin/wget
    
    linux-vdso.so.1 =>  (0x00007ffded109000)
    
    libssl.so.10 => /usr/lib64/libssl.so.10 (0x00007f29f5cd5000)
    
    libcrypto.so.10 => /usr/lib64/libcrypto.so.10 (0x00007f29f58f1000)
    
    libdl.so.2 => /lib64/libdl.so.2 (0x00007f29f56ec000)
    
    librt.so.1 => /lib64/librt.so.1 (0x00007f29f54e4000)
    
    libc.so.6 => /lib64/libc.so.6 (0x00007f29f5150000)
    
    libgssapi_krb5.so.2 => /lib64/libgssapi_krb5.so.2 (0x00007f29f4f0b000)
    
    libkrb5.so.3 => /lib64/libkrb5.so.3 (0x00007f29f4c24000)
    
    libcom_err.so.2 => /lib64/libcom_err.so.2 (0x00007f29f4a20000)
    
    libk5crypto.so.3 => /lib64/libk5crypto.so.3 (0x00007f29f47f3000)
    
    libz.so.1 => /lib64/libz.so.1 (0x00007f29f45dd000)
    
    /lib64/ld-linux-x86-64.so.2 (0x00007f29f5f54000)
    
    libpthread.so.0 => /lib64/libpthread.so.0 (0x00007f29f43c0000)
    
    libkrb5support.so.0 => /lib64/libkrb5support.so.0 (0x00007f29f41b4000)
    
    libkeyutils.so.1 => /lib64/libkeyutils.so.1 (0x00007f29f3fb1000)
    
    libresolv.so.2 => /lib64/libresolv.so.2 (0x00007f29f3d97000)
    
    libselinux.so.1 => /lib64/libselinux.so.1 (0x00007f29f3b77000)
    
    --------------------------------------------------------
    
    wget -V
    
    GNU Wget 1.12 built on linux-gnu.
    
    
    +digest +ipv6 +nls +ntlm +opie +md5/openssl +https -gnutls +openssl 
    
    -iri 
    
    
    Wgetrc: 
    
        /etc/wgetrc (system)
    
    Locale: /usr/share/locale 
    
    Compile: gcc -DHAVE_CONFIG_H -DSYSTEM_WGETRC="/etc/wgetrc" 
    
        -DLOCALEDIR="/usr/share/locale" -I. -I../lib -O2 -g -pipe -Wall 
    
        -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector 
    
        --param=ssp-buffer-size=4 -m64 -mtune=generic -fno-strict-aliasing 
    
    Link: gcc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions 
    
        -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic 
    
        -fno-strict-aliasing -Wl,-z,relro -lssl -lcrypto 
    
        /usr/lib64/libssl.so /usr/lib64/libcrypto.so -ldl -lrt ftp-opie.o 
    
        openssl.o http-ntlm.o gen-md5.o ../lib/libgnu.a 
    
    
    Copyright © 2009 Free Software Foundation, Inc.
    
    License GPLv3+: GNU GPL version 3 or later
    
    <http://www.gnu.org/licenses/gpl.html>.
    
    This is free software: you are free to change and redistribute it.
    
    There is NO WARRANTY, to the extent permitted by law.
    
    
    Originally written by Hrvoje Nikšić <hniksic@xemacs.org>.
    
    Currently maintained by Micah Cowan <micah@cowan.name>.
    
    Please send bug reports and questions to <bug-wget@gnu.org>.
    
    --------------------------------------------------------
    
    wget 1.18 failed to update, still using system wget
    
    --------------------------------------------------------
    
     
  2. eva2000

    eva2000 Administrator Staff Member

    30,196
    6,789
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,144
    Local Time:
    7:44 PM
    Nginx 1.13.x
    MariaDB 5.5
    which centos version 6.8 or 7.2 ? you can find out within /etc/redhat-release
    Code (Text):
    cat /etc/redhat-release

    you can try manual addons/wget.sh update via these ssh commands as root user
    Code (Text):
    cd /usr/local/src/centminmod/addons
    ./wget.sh install

    and then check the log at /root/centminlogs

    this ssh command sorts logs in /root/centminlogs filtered by grep for wget text
    Code (Text):
    ls -lahrt /root/centminlogs | grep wget

    then copy and paste contents of the log and post contents of log to pastebin.com or gist.github.com
     
  3. Doni

    Doni New Member

    29
    1
    3
    Aug 23, 2014
    Ratings:
    +3
    Local Time:
    4:44 PM
    nginx/1.7.4
    mysql Ver 15.1 Distrib 5.5.39-MariaDB, for Linux (x86_64) using readline 5.1
    Hi eva this is the output:

    gist:7c971a9659a7dbf0a1687ecb1f3e1bdf · GitHub

    And also how to fix this, i've already delete this vhost ..
    Code:
    /usr/local/nginx/conf/wpincludes/kandangboekoe.ononiha.org/wpsecure_kandangboekoe.ononiha.org.conf: No such file or directory
    
     
  4. eva2000

    eva2000 Administrator Staff Member

    30,196
    6,789
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,144
    Local Time:
    7:44 PM
    Nginx 1.13.x
    MariaDB 5.5
    find out which config file references wpsecure_kandangboekoe.ononiha.org.conf via a recursive grep of /usr/local/nginx/conf directory using command
    Code (Text):
    grep -ro 'wpsecure_kandangboekoe.ononiha.org.conf' /usr/local/nginx/conf
    

    what's output ?

    as to wget strange on working centos 6.8 system addons/wget.sh run should start with the following output
    Code (Text):
    Download done.
    wget-1.18.tar.gz valid file.
    
    install centos-release-scl for newer gcc and g++ versions
    warning: rpmts_HdrFromFdno: Header V4 RSA/SHA1 Signature, key ID f2ee9d55: NOKEY
    Importing GPG key 0xF2EE9D55:
     Userid : CentOS SoftwareCollections SIG (https://wiki.centos.org/SpecialInterestGroup/SCLo) <security@centos.org>
     Package: centos-release-scl-rh-2-3.el6.centos.noarch (@extras)
     From   : /etc/pki/rpm-gpg/RPM-GPG-KEY-CentOS-SIG-SCLo
    
    gcc (GCC) 5.2.1 20150902 (Red Hat 5.2.1-2)
    Copyright (C) 2015 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions.  There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
    
    g++ (GCC) 5.2.1 20150902 (Red Hat 5.2.1-2)
    Copyright (C) 2015 Free Software Foundation, Inc.
    This is free software; see the source for copying conditions.  There is NO
    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
    
    configure: configuring for GNU Wget 1.18
    checking for a BSD-compatible install... /usr/bin/install -c
    checking whether build environment is sane... yes
    checking for a thread-safe mkdir -p... /bin/mkdir -p
    checking for gawk... gawk
    checking whether make sets $(MAKE)... yes
    checking whether make supports nested variables... yes
    checking build system type... x86_64-pc-linux-gnu
    checking host system type... x86_64-pc-linux-gnu
    checking whether make supports nested variables... (cached) yes
    checking for gcc... /opt/rh/devtoolset-4/root/usr/bin/gcc
    checking whether the C compiler works... yes
    checking for C compiler default output file name... a.out
    checking for suffix of executables... 
    checking whether we are cross compiling... no
    checking for suffix of object files... o
    checking whether we are using the GNU C compiler... yes
    checking whether /opt/rh/devtoolset-4/root/usr/bin/gcc accepts -g... yes
    checking for /opt/rh/devtoolset-4/root/usr/bin/gcc option to accept ISO C89... none needed
    checking whether /opt/rh/devtoolset-4/root/usr/bin/gcc understands -c and -o together... yes
    checking for style of include used by make... GNU
    checking dependency style of /opt/rh/devtoolset-4/root/usr/bin/gcc... gcc3
    checking how to run the C preprocessor... /opt/rh/devtoolset-4/
    

    but yours is failing
     
  5. Doni

    Doni New Member

    29
    1
    3
    Aug 23, 2014
    Ratings:
    +3
    Local Time:
    4:44 PM
    nginx/1.7.4
    mysql Ver 15.1 Distrib 5.5.39-MariaDB, for Linux (x86_64) using readline 5.1
    Strange that it doesnt output anything. Ive delete all the config related to that vhosts.

    Code:
    [root@harimao conf]# grep -ro 'wpsecure_kandangboekoe.ononiha.org.conf' /usr/local/nginx/conf
    [root@harimao conf]# 
    
    About the wget, yes it confuse me also, why it failed. Anything that i could do? or shall i consult to the VPS provider?
     
  6. eva2000

    eva2000 Administrator Staff Member

    30,196
    6,789
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,144
    Local Time:
    7:44 PM
    Nginx 1.13.x
    MariaDB 5.5
    these are centmin mod issues nothing to do with VPS provider

    for wget, what's contents of /svr-setup/wget-1.18/config.log post to gist.github.com
    also output for
    Code (Text):
    ls -lah /svr-setup/wget-1.18


    delete the remaining /usr/local/nginx/conf/wpincludes/ files for vhosts that have been removed too
     
  7. Doni

    Doni New Member

    29
    1
    3
    Aug 23, 2014
    Ratings:
    +3
    Local Time:
    4:44 PM
    nginx/1.7.4
    mysql Ver 15.1 Distrib 5.5.39-MariaDB, for Linux (x86_64) using readline 5.1
  8. eva2000

    eva2000 Administrator Staff Member

    30,196
    6,789
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,144
    Local Time:
    7:44 PM
    Nginx 1.13.x
    MariaDB 5.5
    looks like devtoolset-4 yum install is triggered so devtoolset-4's gcc compiler is missing
    Code (Text):
    configure:4637: result: /opt/rh/devtoolset-4/root/usr/bin/gcc
    configure:4866: checking for C compiler version
    configure:4875: /opt/rh/devtoolset-4/root/usr/bin/gcc --version >&5
    ./configure: line 4877: /opt/rh/devtoolset-4/root/usr/bin/gcc: No such file or directory
    configure:4886: $? = 127

    re-try wget.sh install run but using bash debug mode (bash -x)
    Code (Text):
    cd /usr/local/src/centminmod/addons
    bash -x wget.sh install
    

    post output to gist.github.com so can see why devtoolset-4 doesn't get installed
     
  9. Doni

    Doni New Member

    29
    1
    3
    Aug 23, 2014
    Ratings:
    +3
    Local Time:
    4:44 PM
    nginx/1.7.4
    mysql Ver 15.1 Distrib 5.5.39-MariaDB, for Linux (x86_64) using readline 5.1
  10. eva2000

    eva2000 Administrator Staff Member

    30,196
    6,789
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,144
    Local Time:
    7:44 PM
    Nginx 1.13.x
    MariaDB 5.5
    strange your system is picking up gcc version being 4.9 based on centos 6 while it should be 4.4 based and devtoolset-4 should set it's gcc version to 5.2 based

    409 -lt 407 where 4.9 less than 4.7 is triggered which shouldn't happen as centos 6 gcc is natively 4.4 based not 4.9
    Code (Text):
    + cd wget-1.18
    + gccdevtools
    + [[ ! -f /opt/rh/devtoolset-4/root/usr/bin/gcc ]]
    + [[ 6 = \6 ]]
    + scl_install
    + [[ 6 = \6 ]]
    ++ cut -d . -f1,2
    ++ awk '{print $3}'
    ++ sed 's|\.|0|'
    ++ head -n1
    ++ gcc --version
    + [[ 409 -lt 407 ]]
    + unset CC
    + unset CXX
    + export CC=/opt/rh/devtoolset-4/root/usr/bin/gcc
    + CC=/opt/rh/devtoolset-4/root/usr/bin/gcc
    + export CXX=/opt/rh/devtoolset-4/root/usr/bin/g++
    + CXX=/opt/rh/devtoolset-4/root/usr/bin/g++


    when you type the follow what output you get ?
    Code (Text):
    gcc --version
     
  11. Doni

    Doni New Member

    29
    1
    3
    Aug 23, 2014
    Ratings:
    +3
    Local Time:
    4:44 PM
    nginx/1.7.4
    mysql Ver 15.1 Distrib 5.5.39-MariaDB, for Linux (x86_64) using readline 5.1
    This is the gcc version

    gcc (GCC) 4.9.2

    Copyright (C) 2014 Free Software Foundation, Inc.

    This is free software; see the source for copying conditions. There is NO

    warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
     
  12. eva2000

    eva2000 Administrator Staff Member

    30,196
    6,789
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,144
    Local Time:
    7:44 PM
    Nginx 1.13.x
    MariaDB 5.5
    Strange and output for command
    Code (Text):
    which gcc
    

    try running addons/devtoolset-4.sh to fix gcc version first
    Code (Text):
    cd /usr/local/src/centminmod/addons
    ./devtoolset-4.sh install
    

    then double check
    Code (Text):
    gcc --version
    which gcc

    then retry
    Code (Text):
    cd /usr/local/src/centminmod/addons
    ./wget.sh install
     
  13. Doni

    Doni New Member

    29
    1
    3
    Aug 23, 2014
    Ratings:
    +3
    Local Time:
    4:44 PM
    nginx/1.7.4
    mysql Ver 15.1 Distrib 5.5.39-MariaDB, for Linux (x86_64) using readline 5.1
  14. eva2000

    eva2000 Administrator Staff Member

    30,196
    6,789
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,144
    Local Time:
    7:44 PM
    Nginx 1.13.x
    MariaDB 5.5
    seems gcc 4.9 was fixed as a command alias which centmin mod has never setup or configured such !

    what's output for
    Code (Text):
    alias

    there might be an alias gcc='/usr/local/bin/gcc' entry outputted if so backup and edit /root/.bashrc and remove that line for alias gcc='/usr/local/bin/gcc'

    backup
    Code (Text):
    cp -a /root/.bashrc /root/.bashrc.bak

    then use nano text editor or vim text editor to edit /root/.bashrc to remove that line for alias gcc='/usr/local/bin/gcc'
    then unalias gcc command
    Code (Text):
    unalias gcc
    

    confirm the alias command for gcc is removed via alias output command
    Code (Text):
    alias

    for devtoolset-4.sh
    try
    Code (Text):
    sed -i '/^http:\/\/apt.sw.be/d' /etc/yum.repos.d/mirrors-rpmforge
    yum clean all
    cd /usr/local/src/centminmod/addons
    ./devtoolset-4.sh install
    
     
  15. Doni

    Doni New Member

    29
    1
    3
    Aug 23, 2014
    Ratings:
    +3
    Local Time:
    4:44 PM
    nginx/1.7.4
    mysql Ver 15.1 Distrib 5.5.39-MariaDB, for Linux (x86_64) using readline 5.1
    Hi eva, i check the alias and theres no alias for gcc. Here's the output

    gist:6f1df5a135c6b114a643810e84a72392 · GitHub

    Its seems that the apt.se repo still there my server can not connect to it

    Thank you so much for your patience, eva.
     
  16. eva2000

    eva2000 Administrator Staff Member

    30,196
    6,789
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,144
    Local Time:
    7:44 PM
    Nginx 1.13.x
    MariaDB 5.5
    strange as something has altered the gcc path from default /usr/bin/gcc from your logs
    Code (Text):
    which gcc
    /usr/local/bin/gcc
    

    and centmin mod has never fixed the gcc path only used devtoolset-3/4 to temp enable alternate gcc version which ends after the runs and doesn't persist in SSH sessions
    what's output for
    Code (Text):
    ls -lah /usr/local/bin/gcc
    ls -lah /usr/bin/gcc

    what's output for
    Code (Text):
    cat /etc/yum.repos.d/rpmforge.repo

    Might want to use CODE tags for code How to use forum BBCODE code tags :)
    if it differs from below version, try replacing it's contents of /etc/yum.repos.d/rpmforge.repo with below
    Code (Text):
    ### Name: RPMforge RPM Repository for RHEL 6 - dag
    ### URL: http://rpmforge.net/
    [rpmforge]
    name = RHEL $releasever - RPMforge.net - dag
    baseurl = http://apt.sw.be/redhat/el6/en/$basearch/rpmforge
    mirrorlist = http://mirrorlist.repoforge.org/el6/mirrors-rpmforge
    #mirrorlist = file:///etc/yum.repos.d/mirrors-rpmforge
    enabled = 1
    protect = 0
    gpgkey = file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmforge-dag
    gpgcheck = 1
    priority=5
    exclude=pure-ftpd optipng
    
    [rpmforge-extras]
    name = RHEL $releasever - RPMforge.net - extras
    baseurl = http://apt.sw.be/redhat/el6/en/$basearch/extras
    mirrorlist = http://mirrorlist.repoforge.org/el6/mirrors-rpmforge-extras
    #mirrorlist = file:///etc/yum.repos.d/mirrors-rpmforge-extras
    enabled = 0
    protect = 0
    gpgkey = file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmforge-dag
    gpgcheck = 1
    
    [rpmforge-testing]
    name = RHEL $releasever - RPMforge.net - testing
    baseurl = http://apt.sw.be/redhat/el6/en/$basearch/testing
    mirrorlist = http://mirrorlist.repoforge.org/el6/mirrors-rpmforge-testing
    #mirrorlist = file:///etc/yum.repos.d/mirrors-rpmforge-testing
    enabled = 0
    protect = 0
    gpgkey = file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmforge-dag
    gpgcheck = 1
    

    then try
    Code (Text):
    yum clean all
    cd /usr/local/src/centminmod/addons
    ./devtoolset-4.sh install
    
     
  17. Doni

    Doni New Member

    29
    1
    3
    Aug 23, 2014
    Ratings:
    +3
    Local Time:
    4:44 PM
    nginx/1.7.4
    mysql Ver 15.1 Distrib 5.5.39-MariaDB, for Linux (x86_64) using readline 5.1
    Hi eva this is the ouput
    Code (Text):
    [root@harimao addons]# ls -lah /usr/local/bin/gcc
    -rwxr-xr-x 3 root root 3.1M Jun  1  2016 /usr/local/bin/gcc
    [root@harimao addons]# ls -lah /usr/bin/gcc
    -rwxr-xr-x 2 root root 258K May 10  2016 /usr/bin/gcc


    And this is for the repo
    Code (Text):
    [root@harimao addons]# cat /etc/yum.repos.d/rpmforge.repo
    ### Name: RPMforge RPM Repository for RHEL 6 - dag
    ### URL: http://rpmforge.net/
    [rpmforge]
    name = RHEL $releasever - RPMforge.net - dag
    baseurl = http://apt.sw.be/redhat/el6/en/$basearch/rpmforge
    mirrorlist = http://mirrorlist.repoforge.org/el6/mirrors-rpmforge
    #mirrorlist = file:///etc/yum.repos.d/mirrors-rpmforge
    enabled = 1
    protect = 0
    gpgkey = file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmforge-dag
    gpgcheck = 1
    priority=5
    exclude=pure-ftpd optipng
    
    [rpmforge-extras]
    name = RHEL $releasever - RPMforge.net - extras
    baseurl = http://apt.sw.be/redhat/el6/en/$basearch/extras
    mirrorlist = http://mirrorlist.repoforge.org/el6/mirrors-rpmforge-extras
    #mirrorlist = file:///etc/yum.repos.d/mirrors-rpmforge-extras
    enabled = 0
    protect = 0
    gpgkey = file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmforge-dag
    gpgcheck = 1
    
    [rpmforge-testing]
    name = RHEL $releasever - RPMforge.net - testing
    baseurl = http://apt.sw.be/redhat/el6/en/$basearch/testing
    mirrorlist = http://mirrorlist.repoforge.org/el6/mirrors-rpmforge-testing
    #mirrorlist = file:///etc/yum.repos.d/mirrors-rpmforge-testing
    enabled = 0
    protect = 0
    gpgkey = file:///etc/pki/rpm-gpg/RPM-GPG-KEY-rpmforge-dag
    gpgcheck = 1
    


    I dont see any different with the config that you gave me.
     
  18. eva2000

    eva2000 Administrator Staff Member

    30,196
    6,789
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,144
    Local Time:
    7:44 PM
    Nginx 1.13.x
    MariaDB 5.5
    around June 1, 2016 looks like you compiled custom GCC 4.9 version at /usr/local/bin/gcc yourself ? centmin mod has never done this from memory
    Code (Text):
    ls -lah /usr/local/bin/gcc
    -rwxr-xr-x 3 root root 3.1M Jun  1  2016 /usr/local/bin/gcc
    

    try to refresh mirrors and yum update first
    Code (Text):
    rm -rf /etc/yum.repos.d/mirrors-rpmforge*
    yum clean all
    yum -y update
    

    but seems rpmforge as it's no longer maintained has broken mirrors which did try to fix previously

    i updated 123.09beta01 to disable rpmforge for addons/devtoolset-4.sh run so you might want to update 123.09beta01 first via centmin.sh menu option 23 or via commands
    Code (Text):
    cd /usr/local/src/centminmod
    git stash
    git pull
    
     
  19. Doni

    Doni New Member

    29
    1
    3
    Aug 23, 2014
    Ratings:
    +3
    Local Time:
    4:44 PM
    nginx/1.7.4
    mysql Ver 15.1 Distrib 5.5.39-MariaDB, for Linux (x86_64) using readline 5.1
    I dont remember compiling any gcc on that date. Is there anyway to revert it to default.

    And the devtoolset4 is still failed to install. Even after clean the yum

    Code (Text):
    [root@harimao ~]# rm -rf /etc/yum.repos.d/mirrors-rpmforge*
    [root@harimao ~]# yum clean all
    Loaded plugins: fastestmirror, priorities, protectbase, security
    Cleaning repos: base centos dag epel extras mariadb rpmforge slc6-scl updates
    Cleaning up Everything
    Cleaning up list of fastest mirrors
    [root@harimao ~]# yum -y update
    Loaded plugins: fastestmirror, priorities, protectbase, security
    Setting up Update Process
    Determining fastest mirrors
    epel/metalink                                                                                                                       | 5.3 kB     00:00     
     * base: centos.biz.net.id
     * epel: fedora.dionipe.web.id
     * extras: mirror.smartmedia.net.id
     * rpmforge: mirror.smartmedia.net.id
     * updates: mirror.smartmedia.net.id
    base                                                                                                                                | 3.7 kB     00:00     
    base/primary_db                                                                                                                     | 4.7 MB     00:07     
    centos                                                                                                                              | 3.7 kB     00:00     
    centos/primary_db                                                                                                                   | 4.7 MB     00:02     
    http://apt.sw.be/redhat/el6/en/x86_64/dag/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
    Trying other mirror.
    To address this issue please refer to the below knowledge base article
    
    https://access.redhat.com/articles/1320623
    
    If above article doesn't help to resolve this issue please open a ticket with Red Hat Support.
    
    Error: Cannot retrieve repository metadata (repomd.xml) for repository: dag. Please verify its path and try again
    [root@harimao ~]# cd /usr/local/src/centminmod
    [root@harimao centminmod]# git stash
    No local changes to save
    [root@harimao centminmod]# git pull
    Updating 7cf0a80..c8d9427
    Fast-forward
     addons/devtoolset-4.sh           |   20 ++++++++++----------
     addons/nodejs.sh                 |    4 ++--
     addons/wget.sh                   |    8 ++++----
     inc/brotli.inc                   |    8 ++++----
     installer-gitlab.sh              |    8 ++++----
     installer-latest-gitlab.sh       |    8 ++++----
     installer-latest.sh              |    8 ++++----
     installer-minimal-gitlab.sh      |    8 ++++----
     installer-minimal.sh             |    8 ++++----
     installer-ngxpagespeed-gitlab.sh |    8 ++++----
     installer-ngxpagespeed.sh        |    8 ++++----
     installer.sh                     |    8 ++++----
     installer55-gitlab.sh            |    8 ++++----
     installer55.sh                   |    8 ++++----
     installer56-gitlab.sh            |    8 ++++----
     installer56.sh                   |    8 ++++----
     installer7-gitlab.sh             |    8 ++++----
     installer7.sh                    |    8 ++++----
     18 files changed, 76 insertions(+), 76 deletions(-)
    [root@harimao centminmod]# cd /usr/local/src/centminmod/addons
    [root@harimao addons]# ./devtoolset-4.sh install
    installing devtoolset-4 from softwarecollections.org
    Loaded plugins: fastestmirror, priorities, protectbase, security
    Cleaning repos: base centos dag epel extras mariadb rpmforge slc6-scl updates
    Cleaning up Everything
    Cleaning up list of fastest mirrors
    http://apt.sw.be/redhat/el6/en/x86_64/dag/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
    Trying other mirror.
    To address this issue please refer to the below knowledge base article
    
    https://access.redhat.com/articles/1320623
    
    If above article doesn't help to resolve this issue please open a ticket with Red Hat Support.
    
    Error: Cannot retrieve repository metadata (repomd.xml) for repository: dag. Please verify its path and try again
    http://apt.sw.be/redhat/el6/en/x86_64/dag/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
    Trying other mirror.
    To address this issue please refer to the below knowledge base article
    
    https://access.redhat.com/articles/1320623
    
    If above article doesn't help to resolve this issue please open a ticket with Red Hat Support.
    
    Error: Cannot retrieve repository metadata (repomd.xml) for repository: dag. Please verify its path and try again
    
    ./devtoolset-4.sh: line 87: /opt/rh/devtoolset-4/root/usr/bin/gcc: No such file or directory
    ./devtoolset-4.sh: line 88: /opt/rh/devtoolset-4/root/usr/bin/g++: No such file or directory
    
    devtoolset-4 installed...
     
  20. eva2000

    eva2000 Administrator Staff Member

    30,196
    6,789
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,144
    Local Time:
    7:44 PM
    Nginx 1.13.x
    MariaDB 5.5
    oh just noticed you have an even older repo = dag which is no longer used and not related to rpmforge your centmin mod version prior to 123.09beta01 must of been pretty old ?

    you can remove /etc/yum.repos.d/dag.repo
    Code (Text):
    rm -rf /etc/yum.repos.d/dag.repo
    yum clean all
    


    what prior centmin mod versions installed, you can output contents of /etc/centminmod-release history log
    Code (Text):
    cat /etc/centminmod-versionlog