Discover Centmin Mod today
Register Now

PHP-FPM Disabling multiple phpfpm pools

Discussion in 'Nginx, PHP-FPM & MariaDB MySQL' started by pamamolf, Nov 14, 2017.

  1. pamamolf

    pamamolf Well-Known Member

    2,767
    245
    63
    May 31, 2014
    Ratings:
    +436
    Local Time:
    8:19 AM
    Nginx-1.13.x
    MariaDB 10.1.x
    • CentOS Version: CentOS 7 64bit ?
    • Centmin Mod Version Installed: 123.09beta01
    • Nginx Version Installed: 1.13.x latest
    • PHP Version Installed: 5.6.x latest
    • MariaDB MySQL Version Installed: 10.1.x latest
    • When was last time updated Centmin Mod code base ? : today

    Hello :)

    I am trying to disable phpfpm multiple pools by adjusting:

    to

    and then i restart nginx and phpfpm

    but when i run:

    i can see all pools :(

    then i thought about:

    adjusting this line to:

    but on that path is the config for phpmyadmin and it will break it :(

    Any help?

    Thank you
     
  2. Sunka

    Sunka Active Member

    923
    240
    43
    Oct 31, 2015
    Rijeka, Croatia
    Ratings:
    +388
    Local Time:
    7:19 AM
    Nginx 1.13.3
    MariaDB 10.1.24
    custom.php maybe?
     
  3. pamamolf

    pamamolf Well-Known Member

    2,767
    245
    63
    May 31, 2014
    Ratings:
    +436
    Local Time:
    8:19 AM
    Nginx-1.13.x
    MariaDB 10.1.x
    What do you mean?
     
  4. Sunka

    Sunka Active Member

    923
    240
    43
    Oct 31, 2015
    Rijeka, Croatia
    Ratings:
    +388
    Local Time:
    7:19 AM
    Nginx 1.13.3
    MariaDB 10.1.24
    If you want to retain php.ini changes don't use php-fpm config but you can instead just move them into their own /etc/centminmod/php.d/custom.ini file using normal php.ini syntax
     
  5. pamamolf

    pamamolf Well-Known Member

    2,767
    245
    63
    May 31, 2014
    Ratings:
    +436
    Local Time:
    8:19 AM
    Nginx-1.13.x
    MariaDB 10.1.x
    Confused :-(

    What I am asking is why phpfpm pools are not disabled after adjusting the settings on my first post and not related to the php ini changes....
     
  6. pamamolf

    pamamolf Well-Known Member

    2,767
    245
    63
    May 31, 2014
    Ratings:
    +436
    Local Time:
    8:19 AM
    Nginx-1.13.x
    MariaDB 10.1.x
    I think it just load the rest pools as the configs are there but not use them so it seems that only one pool is in used.... ?
     
  7. eva2000

    eva2000 Administrator Staff Member

    30,581
    6,854
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,275
    Local Time:
    4:19 PM
    Nginx 1.13.x
    MariaDB 5.5
    all php-fpm pools need to be located in /usr/local/nginx/conf/phpfpmd/ to work you can't comment out include line for /usr/local/nginx/conf/phpfpmd/* and allow phpmyadmin php-fpm include file to work.

    Right now there is no way to disable the multiple pools other than deleting them from /usr/local/nginx/conf/phpfpmd/ but centmin mod 123.09beta01 will auto re-add them if they're detected missing. They do not consume much resources at all as they're all on-demand php-fpm pools and only are used if you specifically enable them to be used in your nginx vhost. The netstat/ss listening is just for multiple php-fpm pool's master process which doesn't use much resources anyway.
    Code (Text):
    ls -lah /usr/local/nginx/conf/phpfpmd/
    
    -rw-r--r--. 1 root root 1.7K Apr  4  2017 phpfpm_pool2.conf
    -rw-r--r--. 1 root root 1.7K Apr  4  2017 phpfpm_pool3.conf
    -rw-r--r--. 1 root root 1.7K Apr  4  2017 phpfpm_pool4.conf
    -rw-r--r--. 1 root root 1.7K Apr  4  2017 phpfpm_pool5.conf
    
     
    • Informative Informative x 1