Welcome to Centmin Mod Community
Become a Member

Beta Branch disable query_cache with mariadb 10.1 default installs

Discussion in 'Centmin Mod Github Commits' started by eva2000, Mar 22, 2016.

  1. eva2000

    eva2000 Administrator Staff Member

    44,118
    10,047
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,530
    Local Time:
    2:29 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    • Like Like x 3
    • Informative Informative x 1
  2. pamamolf

    pamamolf Premium Member Premium Member

    3,769
    366
    83
    May 31, 2014
    Ratings:
    +706
    Local Time:
    7:29 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    For me this one was not able to disable it:

    Code:
    query_cache_type = 0
    at least mysqltuner can't see it as disable.....

    I had to set to 0 also this:

    Code:
    query_cache_size = 0
    Then all ok :)

    Maybe you must set this also to 0 on the Centminmod mycnf templates?
     
    • Informative Informative x 1
  3. negative

    negative Active Member

    382
    45
    28
    Apr 11, 2015
    Ratings:
    +88
    Local Time:
    7:29 PM
    1.9.10
    10.1.11
    So, do you advice to disable query_cache on innodb tables in mariadb ?

    I have about 10gigabyte innodb database on my xenforo board and using query_cache with very big config size. :confused:
     
  4. eva2000

    eva2000 Administrator Staff Member

    44,118
    10,047
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,530
    Local Time:
    2:29 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    fixed
    see Mysqltuner | Centmin Mod Community
     
  5. rdan

    rdan Well-Known Member

    4,921
    1,172
    113
    May 25, 2014
    Ratings:
    +1,769
    Local Time:
    12:29 AM
    Mainline
    10.2
    Mine was:
     
  6. negative

    negative Active Member

    382
    45
    28
    Apr 11, 2015
    Ratings:
    +88
    Local Time:
    7:29 PM
    1.9.10
    10.1.11
    I tried a few days disabled the query_cache but i observe the negative effect on performance. I didn't any test but i feel the latency while open the thread_view pages especially. So i enabled it again. My database server only runs the mariadb and has 48gb of ram so cache maybe better, i don't know :)
     
  7. pamamolf

    pamamolf Premium Member Premium Member

    3,769
    366
    83
    May 31, 2014
    Ratings:
    +706
    Local Time:
    7:29 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    We need a benchmark for this :)
     
  8. negative

    negative Active Member

    382
    45
    28
    Apr 11, 2015
    Ratings:
    +88
    Local Time:
    7:29 PM
    1.9.10
    10.1.11
    How can i benchmark it ? If you tell me a way, then i can do it and share with you. But personally, i see that page generate times some increased after query_cache disabled.
     
  9. pamamolf

    pamamolf Premium Member Premium Member

    3,769
    366
    83
    May 31, 2014
    Ratings:
    +706
    Local Time:
    7:29 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    Don't know :(
     
  10. rdan

    rdan Well-Known Member

    4,921
    1,172
    113
    May 25, 2014
    Ratings:
    +1,769
    Local Time:
    12:29 AM
    Mainline
    10.2
    Be sure almost all of your tables are on Innodb and nothing on MyIsam.