Get the most out of your Centmin Mod LEMP stack
Become a Member

Disable Memcache, redis and Zend?

Discussion in 'Other Centmin Mod Installed software' started by lushen, Oct 7, 2018.

  1. lushen

    lushen New Member

    13
    2
    3
    Nov 13, 2017
    Ratings:
    +4
    Local Time:
    7:33 AM
    • CentOS Version: CentOS 7 64bit ?
    • Centmin Mod Version Installed: 123.09beta01
    • Nginx Version Installed: 1.15.5
    • PHP Version Installed: 7.2.10
    • MariaDB MySQL Version Installed: 10.1.36
    • When was last time updated Centmin Mod code base ? : Just did it
    • Persistent Config:
      Code (Text):
      LETSENCRYPT_DETECT='y'
      


      Hello there,
      I think I made a mistake because I was in hurry.

      I installed a Wordpress website with menu option 22.

      On the first installation for Wordpress caching I choosed option 1 (KeyCDN Cache Enabler (default & recommended)), then I noticed I wanted to choose option 3, so I uninstalled the WP Installation (From /root/wp_uninstall_DOMAIN.sh) and re-installed (Option 22 from centmin) but I choosed option 3 (Wordpress Super Cache) this time.

      Now, I see an error with Query Monitor:

      Code (Text):
      The Memcache extension for PHP is installed but is not in use by WordPress
      The Memcached extension for PHP is installed but is not in use by WordPress
      The Redis extension for PHP is installed but is not in use by WordPress
      The Zend OPcache extension for PHP is installed but is not in use by WordPress
      


      I already tried:
      Code (Text):
        service memcached stop
        chkconfig memcached off
      


      But it still shows up. Is there a way to get rid of the message?

      Looks pretty annoying :(


      Screenshot_7.png


      Screenshot_8.png
     
  2. eva2000

    eva2000 Administrator Staff Member

    37,359
    8,162
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,563
    Local Time:
    4:33 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    are you actually use memcached server or redis server ? if not then it's fine to ignore those messages as the php extensions are installed but if you don't specifically use them/configure them for your wordpress install, then you can ignore them - though zend opcache one should usually be used by PHP which means used by wordpress (so i'd question the validity of the warning by the query monitor)
     
  3. lushen

    lushen New Member

    13
    2
    3
    Nov 13, 2017
    Ratings:
    +4
    Local Time:
    7:33 AM
    Nope, using none of them. That's why I would like to get rid of the messages. Thought there is a way to disable it in a custom config file or so.
     
  4. eva2000

    eva2000 Administrator Staff Member

    37,359
    8,162
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,563
    Local Time:
    4:33 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    problem is query monitor coding not centmin mod environment. It's common for installed PHP extensions to possibly not be in use. Though Zend Opcache should be used by Wordpress as it's used by any PHP script.
     
    • Informative Informative x 1
  5. lushen

    lushen New Member

    13
    2
    3
    Nov 13, 2017
    Ratings:
    +4
    Local Time:
    7:33 AM
    Got it, thank you!

    Btw, can you edit the title? I forgot an 'e' on memcache :(
     
  6. eva2000

    eva2000 Administrator Staff Member

    37,359
    8,162
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,563
    Local Time:
    4:33 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    believe you can edit titles within certain time limit, but did it for you :)
     
    • Friendly Friendly x 1
..