Learn about Centmin Mod LEMP Stack today
Become a Member

Upgrade cURL Upgrade

Discussion in 'Install & Upgrades or Pre-Install Questions' started by Jimmy, Nov 19, 2015.

  1. Jimmy

    Jimmy Premium Member Premium Member

    1,026
    231
    63
    Oct 24, 2015
    East Coast USA
    Ratings:
    +555
    Local Time:
    12:58 PM
    1.13.x
    MariaDB 10.1.x
    I was trying to upgrade my cURL to the most current version. 7.45.0. I was following the directions on the IPB forum (listed below). I'm running Centos 7 with the latest stable version of Centmin Mod. When I tried to remove the items in #1 below I got this error:

    Code:
    Error: Trying to remove "yum", which is protected
    Does anyone have any idea what is going wrong? Do I have to set a flag to skip dependencies?

    --------------------------------------------------

    Updating cURL in Centos 6

    1) Remove the cURL version that you have:

    Code:
    yum remove curl curl-devel
    2) Download the cURL version you need (for example: 7.45.0)

    Code:
    wget http://curl.haxx.se/download/curl-7.45.0.tar.bz2
    3) Extract it:

    Code:
    tar xfj curl-7.45.0.tar.bz2
    4) Install it (execute each line after finishing the previous one):

    Code:
    cd curl-7.45.0
    ./configure --prefix=/usr
    make
    make install
    
    5) Check the cURL version (you should see now the version you have just finished installing)

    Code:
    curl -V

    At this point you are ready shall now reinstall/update PHP (compiling it) through the centmin.sh. If you don't do it, as libCURL is hardcoded in PHP, you will still see php as using the old version. If you cannot access to centmin.sh, you can use the following options to compile php (this is for the 64-bit CentOS):

    Code:
    ../configure --enable-fpm --enable-intl --enable-pcntl --with-mcrypt --with-snmp --with-mhash --with-zlib --with-gettext --enable-exif --enable-zip --with-bz2 --enable-soap --enable-sockets --enable-sysvmsg --enable-sysvsem --enable-sysvshm --enable-shmop --with-pear --enable-mbstring --with-openssl --with-mysql=mysqlnd --with-libdir=lib64 --with-mysqli=mysqlnd --with-mysql-sock=/var/lib/mysql/mysql.sock --with-curl --with-gd --with-xmlrpc --enable-bcmath --enable-calendar --enable-ftp --enable-gd-native-ttf --with-freetype-dir=/usr --with-jpeg-dir=/usr --with-png-dir=/usr --with-xpm-dir=/usr --with-vpx-dir=/usr --with-t1lib=/usr --enable-pdo --with-pdo-sqlite --with-pdo-mysql=mysqlnd --enable-inline-optimization --with-imap --with-imap-ssl --with-kerberos --with-readline --with-libedit --with-gmp --with-pspell --with-tidy --with-enchant --with-fpm-user=nginx --with-fpm-group=nginx --disable-fileinfo --with-config-file-scan-dir=/etc/centminmod/php.d
    
     
  2. eva2000

    eva2000 Administrator Staff Member

    29,034
    6,589
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,784
    Local Time:
    2:58 AM
    Nginx 1.13.x
    MariaDB 5.5
    nooo DO NOT do that you could royally screw up your entire system.

    If you want to upgrade curl/libcurl use the addson/customcurl.sh add which has custom RPM packages for curl 7.43+ and 7.45 for 123.08stable and 123.09beta01 respectively outlined at Beta Branch - Centmin Mod curl 7.43+ custom rpms

    the custom curl RPM packages arose out of @Tracy Perry report at PHP-FPM - PHP-CURL | Centmin Mod Community

    Centmin Mod uses YUM Priorities plugin see full details at Third Party YUM Repos with Centmin Mod - CentminMod.com LEMP Nginx web stack for CentOS so if you're using of trying to see if 3rd party YUM repositories have a newer YUM package or YUM package available yes need to pass flag to --disableplugin=priorities

    Technically, you can use 123.09beta01 addons/customcurl.sh version standalone on 123.08stable too for curl 7.45 located at centminmod/addons at 123.09beta01 and actual code for customcurl.sh https://raw.githubusercontent.com/centminmod/centminmod/123.09beta01/addons/customcurl.sh
     
    Last edited: Nov 19, 2015
    • Informative Informative x 1
  3. Jimmy

    Jimmy Premium Member Premium Member

    1,026
    231
    63
    Oct 24, 2015
    East Coast USA
    Ratings:
    +555
    Local Time:
    12:58 PM
    1.13.x
    MariaDB 10.1.x
    Thanks! I'll take a look at the docs. I wonder if guy who upgraded his Centos 6 Centmin Mod system, in the IPB thread, messed his system up and doesn't know it?
     
  4. eva2000

    eva2000 Administrator Staff Member

    29,034
    6,589
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,784
    Local Time:
    2:58 AM
    Nginx 1.13.x
    MariaDB 5.5
    curl and curl devel packages are required by the following packages via repoquery command RepoQuery - yum - Trac

    the big ones would be rpm and thus yum package itself

    for curl and curl-devel
    Code:
    repoquery --whatrequires --installed --recursive curl curl-devel
    curl-0:7.19.7-46.el6.x86_64
    cmake-0:2.8.12.2-4.el6.x86_64
    cmake28-0:2.8.11.2-1.el6.x86_64
    cronie-0:1.4.4-15.el6.x86_64
    cronie-anacron-0:1.4.4-15.el6.x86_64
    crontabs-0:1.10-33.el6.noarch
    curlftpfs-0:0.9.2-14.el6.x86_64
    cyrus-imapd-0:2.3.16-13.el6_6.x86_64
    deltarpm-0:3.5-0.5.20090913git.el6.x86_64
    dracut-0:004-388.el6.noarch
    dracut-kernel-0:004-388.el6.noarch
    fuse-0:2.8.3-4.el6.x86_64
    git-0:1.7.1-3.el6_4.1.x86_64
    initscripts-0:9.03.49-1.el6.centos.1.x86_64
    iproute-0:2.6.32-45.el6.x86_64
    iptables-0:1.4.7-16.el6.x86_64
    iptables-devel-0:1.4.7-16.el6.x86_64
    iptables-ipv6-0:1.4.7-16.el6.x86_64
    iputils-0:20071127-20.el6.x86_64
    kbd-0:1.15-11.el6.x86_64
    net-snmp-1:5.5-54.el6_7.1.x86_64
    net-snmp-devel-1:5.5-54.el6_7.1.x86_64
    net-snmp-libs-1:5.5-54.el6_7.1.x86_64
    net-snmp-utils-1:5.5-54.el6_7.1.x86_64
    openssh-0:5.3p1-112.el6_7.x86_64
    openssh-clients-0:5.3p1-112.el6_7.x86_64
    openssh-server-0:5.3p1-112.el6_7.x86_64
    perl-Git-0:1.7.1-3.el6_4.1.noarch
    plymouth-0:0.8.3-27.el6.centos.1.x86_64
    policycoreutils-0:2.0.83-24.el6.x86_64
    postfix-2:2.6.6-6.el6_5.x86_64
    postfix-perl-scripts-2:2.6.6-6.el6_5.x86_64
    pure-ftpd-0:1.0.30-1.el6.x86_64
    quota-1:3.17-23.el6.x86_64
    remi-release-0:6.5-1.el6.remi.noarch
    rpm-0:4.8.0-47.el6.x86_64
    rpm-devel-0:4.8.0-47.el6.x86_64
    rpm-libs-0:4.8.0-47.el6.x86_64
    rpm-python-0:4.8.0-47.el6.x86_64
    rsyslog-0:5.8.10-10.el6_6.x86_64
    subversion-0:1.6.11-15.el6_7.x86_64
    sysstat-0:9.0.4-27.el6.x86_64
    yum-0:3.2.29-69.el6.centos.noarch
    yum-plugin-fastestmirror-0:1.1.30-30.el6.noarch
    yum-plugin-priorities-0:1.1.30-30.el6.noarch
    yum-plugin-security-0:1.1.30-30.el6.noarch
    yum-utils-0:1.1.30-30.el6.noarch
    and dependency list of packages for curl and curl-devel
    Code:
    yum deplist curl curl-devel -q
    package: curl.x86_64 7.19.7-46.el6
      dependency: libssh2.so.1()(64bit)
       provider: libssh2.x86_64 1.4.2-1.el6_6.1
      dependency: libz.so.1()(64bit)
       provider: zlib.x86_64 1.2.3-29.el6
      dependency: libkrb5.so.3()(64bit)
       provider: krb5-libs.x86_64 1.10.3-42.el6
      dependency: libldap-2.4.so.2()(64bit)
       provider: openldap.x86_64 2.4.40-5.el6
       provider: openldap.x86_64 2.4.40-6.el6_7
       provider: openldap.x86_64 2.4.40-7.el6_7
      dependency: libpthread.so.0()(64bit)
       provider: glibc.x86_64 2.12-1.166.el6
       provider: glibc.x86_64 2.12-1.166.el6_7.1
       provider: glibc.x86_64 2.12-1.166.el6_7.3
      dependency: libgssapi_krb5.so.2()(64bit)
       provider: krb5-libs.x86_64 1.10.3-42.el6
      dependency: libpthread.so.0(GLIBC_2.2.5)(64bit)
       provider: glibc.x86_64 2.12-1.166.el6
       provider: glibc.x86_64 2.12-1.166.el6_7.1
       provider: glibc.x86_64 2.12-1.166.el6_7.3
      dependency: libcurl.so.4()(64bit)
       provider: libcurl.x86_64 7.19.7-46.el6
      dependency: libnssutil3.so()(64bit)
       provider: nss-util.x86_64 3.18.0-1.el6_6
       provider: nss-util.x86_64 3.19.1-1.el6_6
       provider: nss-util.x86_64 3.19.1-2.el6_7
      dependency: libk5crypto.so.3()(64bit)
       provider: krb5-libs.x86_64 1.10.3-42.el6
      dependency: libplc4.so()(64bit)
       provider: nspr.x86_64 4.10.8-1.el6_6
       provider: nspr.x86_64 4.10.8-2.el6_7
      dependency: librt.so.1(GLIBC_2.2.5)(64bit)
       provider: glibc.x86_64 2.12-1.166.el6
       provider: glibc.x86_64 2.12-1.166.el6_7.1
       provider: glibc.x86_64 2.12-1.166.el6_7.3
      dependency: libplds4.so()(64bit)
       provider: nspr.x86_64 4.10.8-1.el6_6
       provider: nspr.x86_64 4.10.8-2.el6_7
      dependency: libcurl = 7.19.7-46.el6
       provider: libcurl.x86_64 7.19.7-46.el6
      dependency: libdl.so.2()(64bit)
       provider: glibc.x86_64 2.12-1.166.el6
       provider: glibc.x86_64 2.12-1.166.el6_7.1
       provider: glibc.x86_64 2.12-1.166.el6_7.3
      dependency: libnss3.so()(64bit)
       provider: nss.x86_64 3.18.0-5.3.el6_6
       provider: nss.x86_64 3.19.1-3.el6_6
       provider: nss.x86_64 3.19.1-5.el6_7
      dependency: libc.so.6(GLIBC_2.7)(64bit)
       provider: glibc.x86_64 2.12-1.166.el6
       provider: glibc.x86_64 2.12-1.166.el6_7.1
       provider: glibc.x86_64 2.12-1.166.el6_7.3
      dependency: libcom_err.so.2()(64bit)
       provider: libcom_err.x86_64 1.41.12-22.el6
      dependency: librt.so.1()(64bit)
       provider: glibc.x86_64 2.12-1.166.el6
       provider: glibc.x86_64 2.12-1.166.el6_7.1
       provider: glibc.x86_64 2.12-1.166.el6_7.3
      dependency: libssl3.so()(64bit)
       provider: nss.x86_64 3.18.0-5.3.el6_6
       provider: nss.x86_64 3.19.1-3.el6_6
       provider: nss.x86_64 3.19.1-5.el6_7
      dependency: libsmime3.so()(64bit)
       provider: nss.x86_64 3.18.0-5.3.el6_6
       provider: nss.x86_64 3.19.1-3.el6_6
       provider: nss.x86_64 3.19.1-5.el6_7
      dependency: libnspr4.so()(64bit)
       provider: nspr.x86_64 4.10.8-1.el6_6
       provider: nspr.x86_64 4.10.8-2.el6_7
      dependency: libidn.so.11()(64bit)
       provider: libidn.x86_64 1.18-2.el6
      dependency: rtld(GNU_HASH)
       provider: glibc.x86_64 2.12-1.166.el6
       provider: glibc.x86_64 2.12-1.166.el6_7.1
       provider: glibc.x86_64 2.12-1.166.el6_7.3
    package: curl.x86_64 7.19.7-46.el6
      dependency: libssh2.so.1()(64bit)
       provider: libssh2.x86_64 1.4.2-1.el6_6.1
      dependency: libz.so.1()(64bit)
       provider: zlib.x86_64 1.2.3-29.el6
      dependency: libkrb5.so.3()(64bit)
       provider: krb5-libs.x86_64 1.10.3-42.el6
      dependency: libldap-2.4.so.2()(64bit)
       provider: openldap.x86_64 2.4.40-5.el6
       provider: openldap.x86_64 2.4.40-6.el6_7
       provider: openldap.x86_64 2.4.40-7.el6_7
      dependency: libpthread.so.0()(64bit)
       provider: glibc.x86_64 2.12-1.166.el6
       provider: glibc.x86_64 2.12-1.166.el6_7.1
       provider: glibc.x86_64 2.12-1.166.el6_7.3
      dependency: libgssapi_krb5.so.2()(64bit)
       provider: krb5-libs.x86_64 1.10.3-42.el6
      dependency: libpthread.so.0(GLIBC_2.2.5)(64bit)
       provider: glibc.x86_64 2.12-1.166.el6
       provider: glibc.x86_64 2.12-1.166.el6_7.1
       provider: glibc.x86_64 2.12-1.166.el6_7.3
      dependency: libcurl.so.4()(64bit)
       provider: libcurl.x86_64 7.19.7-46.el6
      dependency: libnssutil3.so()(64bit)
       provider: nss-util.x86_64 3.18.0-1.el6_6
       provider: nss-util.x86_64 3.19.1-1.el6_6
       provider: nss-util.x86_64 3.19.1-2.el6_7
      dependency: libk5crypto.so.3()(64bit)
       provider: krb5-libs.x86_64 1.10.3-42.el6
      dependency: libplc4.so()(64bit)
       provider: nspr.x86_64 4.10.8-1.el6_6
       provider: nspr.x86_64 4.10.8-2.el6_7
      dependency: librt.so.1(GLIBC_2.2.5)(64bit)
       provider: glibc.x86_64 2.12-1.166.el6
       provider: glibc.x86_64 2.12-1.166.el6_7.1
       provider: glibc.x86_64 2.12-1.166.el6_7.3
      dependency: libplds4.so()(64bit)
       provider: nspr.x86_64 4.10.8-1.el6_6
       provider: nspr.x86_64 4.10.8-2.el6_7
      dependency: libcurl = 7.19.7-46.el6
       provider: libcurl.x86_64 7.19.7-46.el6
      dependency: libdl.so.2()(64bit)
       provider: glibc.x86_64 2.12-1.166.el6
       provider: glibc.x86_64 2.12-1.166.el6_7.1
       provider: glibc.x86_64 2.12-1.166.el6_7.3
      dependency: libnss3.so()(64bit)
       provider: nss.x86_64 3.18.0-5.3.el6_6
       provider: nss.x86_64 3.19.1-3.el6_6
       provider: nss.x86_64 3.19.1-5.el6_7
      dependency: libc.so.6(GLIBC_2.7)(64bit)
       provider: glibc.x86_64 2.12-1.166.el6
       provider: glibc.x86_64 2.12-1.166.el6_7.1
       provider: glibc.x86_64 2.12-1.166.el6_7.3
      dependency: libcom_err.so.2()(64bit)
       provider: libcom_err.x86_64 1.41.12-22.el6
      dependency: librt.so.1()(64bit)
       provider: glibc.x86_64 2.12-1.166.el6
       provider: glibc.x86_64 2.12-1.166.el6_7.1
       provider: glibc.x86_64 2.12-1.166.el6_7.3
      dependency: libssl3.so()(64bit)
       provider: nss.x86_64 3.18.0-5.3.el6_6
       provider: nss.x86_64 3.19.1-3.el6_6
       provider: nss.x86_64 3.19.1-5.el6_7
      dependency: libsmime3.so()(64bit)
       provider: nss.x86_64 3.18.0-5.3.el6_6
       provider: nss.x86_64 3.19.1-3.el6_6
       provider: nss.x86_64 3.19.1-5.el6_7
      dependency: libnspr4.so()(64bit)
       provider: nspr.x86_64 4.10.8-1.el6_6
       provider: nspr.x86_64 4.10.8-2.el6_7
      dependency: libidn.so.11()(64bit)
       provider: libidn.x86_64 1.18-2.el6
      dependency: rtld(GNU_HASH)
       provider: glibc.x86_64 2.12-1.166.el6
       provider: glibc.x86_64 2.12-1.166.el6_7.1
       provider: glibc.x86_64 2.12-1.166.el6_7.3
    dependency list for rpm includes curl
    Code:
    yum deplist rpm -q
    package: rpm.x86_64 4.8.0-47.el6
      dependency: libc.so.6(GLIBC_2.3.4)(64bit)
       provider: glibc.x86_64 2.12-1.166.el6
       provider: glibc.x86_64 2.12-1.166.el6_7.1
       provider: glibc.x86_64 2.12-1.166.el6_7.3
      dependency: libpopt.so.0()(64bit)
       provider: popt.x86_64 1.13-7.el6
      dependency: libselinux.so.1()(64bit)
       provider: libselinux.x86_64 2.0.94-5.8.el6
      dependency: libz.so.1()(64bit)
       provider: zlib.x86_64 1.2.3-29.el6
      dependency: rtld(GNU_HASH)
       provider: glibc.x86_64 2.12-1.166.el6
       provider: glibc.x86_64 2.12-1.166.el6_7.1
       provider: glibc.x86_64 2.12-1.166.el6_7.3
      dependency: libacl.so.1()(64bit)
       provider: libacl.x86_64 2.2.49-6.el6
      dependency: librpmio.so.1()(64bit)
       provider: rpm-libs.x86_64 4.8.0-47.el6
      dependency: libpthread.so.0()(64bit)
       provider: glibc.x86_64 2.12-1.166.el6
       provider: glibc.x86_64 2.12-1.166.el6_7.1
       provider: glibc.x86_64 2.12-1.166.el6_7.3
      dependency: coreutils
       provider: coreutils.x86_64 8.4-37.el6
       provider: coreutils.x86_64 8.4-37.el6_7.3
      dependency: libpthread.so.0(GLIBC_2.2.5)(64bit)
       provider: glibc.x86_64 2.12-1.166.el6
       provider: glibc.x86_64 2.12-1.166.el6_7.1
       provider: glibc.x86_64 2.12-1.166.el6_7.3
      dependency: popt >= 1.10.2.1
       provider: popt.x86_64 1.13-7.el6
      dependency: liblua-5.1.so()(64bit)
       provider: lua.x86_64 5.1.4-4.1.el6
      dependency: libdb-4.7.so()(64bit)
       provider: db4.x86_64 4.7.25-19.el6_6
       provider: db4.x86_64 4.7.25-20.el6_7
      dependency: liblzma.so.0()(64bit)
       provider: xz-libs.x86_64 4.999.9-0.5.beta.20091007git.el6
      dependency: libm.so.6()(64bit)
       provider: glibc.x86_64 2.12-1.166.el6
       provider: glibc.x86_64 2.12-1.166.el6_7.1
       provider: glibc.x86_64 2.12-1.166.el6_7.3
      dependency: librpm.so.1()(64bit)
       provider: rpm-libs.x86_64 4.8.0-47.el6
      dependency: libelf.so.1()(64bit)
       provider: elfutils-libelf.x86_64 0.161-3.el6
      dependency: librpmbuild.so.1()(64bit)
       provider: rpm-libs.x86_64 4.8.0-47.el6
      dependency: db4-utils
       provider: db4-utils.x86_64 4.7.25-19.el6_6
       provider: db4-utils.x86_64 4.7.25-20.el6_7
      dependency: libnss3.so()(64bit)
       provider: nss.x86_64 3.18.0-5.3.el6_6
       provider: nss.x86_64 3.19.1-3.el6_6
       provider: nss.x86_64 3.19.1-5.el6_7
      dependency: libmagic.so.1()(64bit)
       provider: file-libs.x86_64 5.04-21.el6
      dependency: libbz2.so.1()(64bit)
       provider: bzip2-libs.x86_64 1.0.5-7.el6_0
      dependency: librt.so.1()(64bit)
       provider: glibc.x86_64 2.12-1.166.el6
       provider: glibc.x86_64 2.12-1.166.el6_7.1
       provider: glibc.x86_64 2.12-1.166.el6_7.3
      dependency: /bin/sh
       provider: bash.x86_64 4.1.2-33.el6
       provider: bash.x86_64 4.1.2-33.el6_7.1
      dependency: /bin/bash
       provider: bash.x86_64 4.1.2-33.el6
       provider: bash.x86_64 4.1.2-33.el6_7.1
      dependency: libcap.so.2()(64bit)
       provider: libcap.x86_64 2.16-5.5.el6
      dependency: libpopt.so.0(LIBPOPT_0)(64bit)
       provider: popt.x86_64 1.13-7.el6
      dependency: curl
       provider: curl.x86_64 7.19.7-46.el6
     
    Last edited: Nov 19, 2015
    • Informative Informative x 1
  5. Jimmy

    Jimmy Premium Member Premium Member

    1,026
    231
    63
    Oct 24, 2015
    East Coast USA
    Ratings:
    +555
    Local Time:
    12:58 PM
    1.13.x
    MariaDB 10.1.x
    @eva2000 you think of everything! Found the addons directory and everything worked out perfect. (y)
     
    • Like Like x 1
  6. eva2000

    eva2000 Administrator Staff Member

    29,034
    6,589
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,784
    Local Time:
    2:58 AM
    Nginx 1.13.x
    MariaDB 5.5
    Well I try to.. and have to seeing as I use Centmin Mod myself on 90+ servers now :D
     
    • Like Like x 1
  7. Jimmy

    Jimmy Premium Member Premium Member

    1,026
    231
    63
    Oct 24, 2015
    East Coast USA
    Ratings:
    +555
    Local Time:
    12:58 PM
    1.13.x
    MariaDB 10.1.x
    90 servers? That's a lot of servers. I'm really happy I took the time to learn Centmin Mod. I'm coming from cPanel and even though it was really easy to use and I could focus all my time on my sites, there's something about using the command line and knowing how things work that makes me feel a little more comfortable.
     
    • Like Like x 1
  8. Jimmy

    Jimmy Premium Member Premium Member

    1,026
    231
    63
    Oct 24, 2015
    East Coast USA
    Ratings:
    +555
    Local Time:
    12:58 PM
    1.13.x
    MariaDB 10.1.x
    Quick question... do you have an tuts on creating users vs. running everything as root. Should I just follow the normal procedures for setting up users for my site and locking down root? I searched around the site and the forum and didn't really see anything about setting up users or running everything as root with ssh keys setup. Thanks!
     
  9. eva2000

    eva2000 Administrator Staff Member

    29,034
    6,589
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,784
    Local Time:
    2:58 AM
    Nginx 1.13.x
    MariaDB 5.5
    Yeah alot of servers.. just centminmod.com official site is on 16+ VPS servers geographically dispersed :)

    Centmin Mod LEMP stack is just my vision of how I want to manage my servers and sites

    sort of covered at Security | Centmin Mod Community

    and FAQ item 2 covers users accounts you can't lock site accounts down to user level like cpanel/WHM as there is no 100% user isolation between site accounts on Centmin Mod. Pure-ftpd virtual ftp only isolates ftp Pure-FTPD Virtual FTP Users - CentminMod.com LEMP Nginx web stack for CentOS but isn't fully jailed like cpanel/WHM as Centmin Mod is not made or setup for shared hosting like cpanel/WHM but more for usage by trusted user (myself/yourself).
     
    • Informative Informative x 1
  10. Jimmy

    Jimmy Premium Member Premium Member

    1,026
    231
    63
    Oct 24, 2015
    East Coast USA
    Ratings:
    +555
    Local Time:
    12:58 PM
    1.13.x
    MariaDB 10.1.x
    Did I read somewhere about you working on fully jailed for the future?
     
  11. eva2000

    eva2000 Administrator Staff Member

    29,034
    6,589
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,784
    Local Time:
    2:58 AM
    Nginx 1.13.x
    MariaDB 5.5
    yeah in notes on page at Pure-FTPD Virtual FTP Users - CentminMod.com LEMP Nginx web stack for CentOS

    However, it's a long long way off before it's available as it's partially gauged by the level of current beta testing feedback and testing I get for the next 123.09beta and subsequent releases. More willing beta testers and feedback activity, means a large enough user base of users who are willing to test and provide feedback for future developments :)
     
  12. Jimmy

    Jimmy Premium Member Premium Member

    1,026
    231
    63
    Oct 24, 2015
    East Coast USA
    Ratings:
    +555
    Local Time:
    12:58 PM
    1.13.x
    MariaDB 10.1.x
    I thought I read something about that somewhere. It's only me using the server, so I should be fine.

    Oh, you've got great vision! There is a nice feel to your software. I'm happy to say goodbye to Apache and cPanel.
     
    • Like Like x 1
  13. eva2000

    eva2000 Administrator Staff Member

    29,034
    6,589
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,784
    Local Time:
    2:58 AM
    Nginx 1.13.x
    MariaDB 5.5
    • Like Like x 1