Want more timely Centmin Mod News Updates?
Become a Member

Cosmetic fixes

Discussion in 'Bug Reports' started by pamamolf, Aug 1, 2016.

  1. pamamolf

    pamamolf Premium Member Premium Member

    3,947
    400
    83
    May 31, 2014
    Ratings:
    +779
    Local Time:
    7:15 AM
    Nginx-1.17.x
    MariaDB 10.3.x
    Hi

    I am using latest beta 09 and when i run nginx upgrade i got :


    Code:
    Installing yum-plugin-security
    Installing iptables*
    Installing {curl,curl-devel}
    Installing {libjpeg,libjpeg-devel}
    Installing {libc-client,libc-client-devel}
    Installing {ImageMagicklast,ImageMagick-last-devel}
    then i run also Php upgrade and got the same info.....

    it seems that is not detect correct the already installed packages?

    Also at the end of installation of packages i am getting this Error:

    Code:
    percona-release-0.1-3.noarch.rpm [found]
            package percona-release-0.1-3.noarch is already installed
    Error: problem with percona-release-0.1-3.noarch.rpm install.
    Thanks :)
     
  2. eva2000

    eva2000 Administrator Staff Member

    47,292
    10,703
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,628
    Local Time:
    2:15 PM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    yeah that's normal for now for php ones

    for percona will check
     
  3. eva2000

    eva2000 Administrator Staff Member

    47,292
    10,703
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,628
    Local Time:
    2:15 PM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    oh did you answer yes to yum check on php upgrade ?

    if you did then yes that's where it's coming from to double check all the existing centmin mod branch's yum repos and packages are setup. It's useful only for major centmin mod branch changes/upgrades i.e. if you are on very old centmin mod branches like 1.2.3-eva2000.06 and below which may not have remi repo etc or some yum packages included in 123.09beta01 etc. That's why i usually answer no to yum checks on php upgrades if I installed from 123.09beta01 :)
     
  4. pamamolf

    pamamolf Premium Member Premium Member

    3,947
    400
    83
    May 31, 2014
    Ratings:
    +779
    Local Time:
    7:15 AM
    Nginx-1.17.x
    MariaDB 10.3.x
    I just answer yes on both Nginx and Php upgrade.

    And i am getting the above errors on both.

    So if there is no major upgrade on Centminmod should i answer yes only on Nginx upgrade?
     
  5. eva2000

    eva2000 Administrator Staff Member

    47,292
    10,703
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,628
    Local Time:
    2:15 PM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    if there's no major centmin mod branch upgrades i.e. install 123.09beta01 on only use that branch, you can answer no to both yum checks in nginx and php-fpm upgrades via centmin.sh menu options 4 and 5 respectively
     
  6. pamamolf

    pamamolf Premium Member Premium Member

    3,947
    400
    83
    May 31, 2014
    Ratings:
    +779
    Local Time:
    7:15 AM
    Nginx-1.17.x
    MariaDB 10.3.x
    Cosmetic fix for:

    Code:
    Install which version of PHP? (version i.e. 5.6.25, 7.0.0, NGDEBUG)
    to

    Code:
    Install which version of PHP? (version i.e. 5.6.25, 7.0.10, NGDEBUG)
    :)
     
  7. pamamolf

    pamamolf Premium Member Premium Member

    3,947
    400
    83
    May 31, 2014
    Ratings:
    +779
    Local Time:
    7:15 AM
    Nginx-1.17.x
    MariaDB 10.3.x
    And now it needs to be :

    from:

    to

    :)
     
  8. eva2000

    eva2000 Administrator Staff Member

    47,292
    10,703
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,628
    Local Time:
    2:15 PM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    yeah that value isn't obtained from any variable like php 5.6.26 value that's why