Welcome to Centmin Mod Community
Register Now

PHP-FPM Compiling multiple versions of PHP

Discussion in 'Install & Upgrades or Pre-Install Questions' started by TasmaniaMan, Oct 1, 2015.

  1. TasmaniaMan

    TasmaniaMan New Member

    4
    0
    1
    May 21, 2015
    Ratings:
    +0
    Local Time:
    3:40 PM
    nginx/1.7.12
    5.5.43-MariaDB MariaDB Server
    Hi,

    I have a test server running Centminmod 1.2.3-eva2000.08 and I'm wondering how I could go about having multiple versions of PHP installed and usable.

    I have a web app that still requires php version 5.3 but would like to test applications on higher versions.

    Setting up additional php pools is ok however any tips on compiling php without overriding the 5.3 version that i've configured would be great.

    Thanks in advance,

    :)
     
  2. eva2000

    eva2000 Administrator Staff Member

    28,934
    6,567
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,747
    Local Time:
    3:40 PM
    Nginx 1.13.x
    MariaDB 5.5
  3. TasmaniaMan

    TasmaniaMan New Member

    4
    0
    1
    May 21, 2015
    Ratings:
    +0
    Local Time:
    3:40 PM
    nginx/1.7.12
    5.5.43-MariaDB MariaDB Server
    Thanks for the fast reply! Virtualbox it is. :)