Want to subscribe to topics you're interested in?
Become a Member

[Solved] compat-libtidy-devel Conflict

Discussion in 'Bug Reports' started by Jimmy, Jun 11, 2017.

  1. Jimmy

    Jimmy Premium Member Premium Member

    1,025
    231
    63
    Oct 24, 2015
    East Coast USA
    Ratings:
    +555
    Local Time:
    7:21 PM
    1.13.x
    MariaDB 10.1.x
    09beta

    Just did a yum update and I believe the conflicting file below was part of that update. Building nginx again I saw this error:

    Code:
    Error: compat-libtidy-devel conflicts with libtidy-devel-5.4.0-1.el7.x86_64
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest
    
    Cancelled the build. Just wanted to make you aware.
     
  2. eva2000

    eva2000 Administrator Staff Member

    28,925
    6,566
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,744
    Local Time:
    9:21 AM
    Nginx 1.13.x
    MariaDB 5.5
    output for command
    Code (Text):
    yum list compat-libtidy-devel libtidy-devel -q
    

    and output for
    Code (Text):
    yum history info compat-libtidy-devel
    
     
  3. Jimmy

    Jimmy Premium Member Premium Member

    1,025
    231
    63
    Oct 24, 2015
    East Coast USA
    Ratings:
    +555
    Local Time:
    7:21 PM
    1.13.x
    MariaDB 10.1.x
    Code:
    # yum list compat-libtidy-devel libtidy-devel -q
    Installed Packages
    compat-libtidy-devel.x86_64                           0.99.0-37.20091203.el7                            @epel
    Available Packages
    libtidy-devel.x86_64                                  5.4.0-1.el7                                       epel 
    
    Code:
    # yum history info compat-libtidy-devel
    Loaded plugins: fastestmirror, priorities
    Transaction ID : 91
    Begin time     : Sat Jun 10 22:47:56 2017
    Begin rpmdb    : 717:98712f148238bb667f4c401c84a1d5684a97f305
    End time       :            22:47:57 2017 (1 seconds)
    End rpmdb      : 717:1c4e159a1f5aa6a46e88b4cee44cbca7a134800a
    User           : root <root>
    Return-Code    : Success
    Command Line   : update --disableplugin=priorities --enablerepo=remi,city-fan.org
    Transaction performed with:
        Installed     rpm-4.11.3-21.el7.x86_64                      @anaconda
        Installed     yum-3.4.3-150.el7.centos.noarch               @anaconda
        Installed     yum-metadata-parser-1.1.4-10.el7.x86_64       @anaconda
        Installed     yum-plugin-fastestmirror-1.1.31-40.el7.noarch @anaconda
    Packages Altered:
        Obsoleting compat-libtidy-0.99.0-37.20091203.el7.x86_64       @epel
        Obsoleting compat-libtidy-devel-0.99.0-37.20091203.el7.x86_64 @epel
        Obsoleted  libtidy-0.99.0-34.20091203.0.el7.x86_64            @city-fan.org
        Obsoleted  libtidy-devel-0.99.0-34.20091203.0.el7.x86_64      @city-fan.org
    history info
    
    
     
  4. eva2000

    eva2000 Administrator Staff Member

    28,925
    6,566
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,744
    Local Time:
    9:21 AM
    Nginx 1.13.x
    MariaDB 5.5
    hmm seems yum update on CentOS 7 replaced libtidy from city-fan yum repo (for curl custom 7.5x) with compat-libtidy packages from EPEL repo

    Code (Text):
    yum -y update
    Loaded plugins: fastestmirror, priorities
    Loading mirror speeds from cached hostfile
    Excluding mirror: ca.mirror.babylon.network
     * base: mirror2.evolution-host.com
    Excluding mirror: ca.mirror.babylon.network
     * elrepo: ftp.osuosl.org
    Excluding mirror: ca.mirror.babylon.network
     * epel: epel.mirror.constant.com
    Excluding mirror: ca.mirror.babylon.network
     * extras: mirror2.evolution-host.com
     * rpmforge: repoforge.mirror.constant.com
    Excluding mirror: ca.mirror.babylon.network
     * updates: mirror2.evolution-host.com
    452 packages excluded due to repository priority protections
    Resolving Dependencies
    --> Running transaction check
    ---> Package compat-libtidy.x86_64 0:0.99.0-37.20091203.el7 will be obsoleting
    ---> Package compat-libtidy-devel.x86_64 0:0.99.0-37.20091203.el7 will be obsoleting
    ---> Package libtidy.x86_64 0:0.99.0-34.20091203.0.el7 will be obsoleted
    ---> Package libtidy-devel.x86_64 0:0.99.0-34.20091203.0.el7 will be obsoleted
    --> Finished Dependency Resolution
    
    Dependencies Resolved
    
    ==========================================================================================================================================================================================================================================================
     Package                                                            Arch                                                 Version                                                                 Repository                                          Size
    ==========================================================================================================================================================================================================================================================
    Installing:
     compat-libtidy                                                     x86_64                                               0.99.0-37.20091203.el7                                                  epel                                               133 k
         replacing  libtidy.x86_64 0.99.0-34.20091203.0.el7
     compat-libtidy-devel                                               x86_64                                               0.99.0-37.20091203.el7                                                  epel                                                25 k
         replacing  libtidy-devel.x86_64 0.99.0-34.20091203.0.el7
    
    Transaction Summary
    ==========================================================================================================================================================================================================================================================
    Install  2 Packages
    
    Total download size: 158 k
    Downloading packages:
    (1/2): compat-libtidy-0.99.0-37.20091203.el7.x86_64.rpm                                                                                                                                                                            | 133 kB  00:00:00    
    (2/2): compat-libtidy-devel-0.99.0-37.20091203.el7.x86_64.rpm                                                                                                                                                                      |  25 kB  00:00:00    
    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    Total                                                                                                                                                                                                                     456 kB/s | 158 kB  00:00:00    
    Running transaction check
    Running transaction test
    Transaction test succeeded
    Running transaction
      Installing : compat-libtidy-0.99.0-37.20091203.el7.x86_64                                                                                                                                                                                           1/4
      Installing : compat-libtidy-devel-0.99.0-37.20091203.el7.x86_64                                                                                                                                                                                     2/4
      Erasing    : libtidy-devel-0.99.0-34.20091203.0.el7.x86_64                                                                                                                                                                                          3/4
      Erasing    : libtidy-0.99.0-34.20091203.0.el7.x86_64                                                                                                                                                                                                4/4
      Verifying  : compat-libtidy-0.99.0-37.20091203.el7.x86_64                                                                                                                                                                                           1/4
      Verifying  : compat-libtidy-devel-0.99.0-37.20091203.el7.x86_64                                                                                                                                                                                     2/4
      Verifying  : libtidy-0.99.0-34.20091203.0.el7.x86_64                                                                                                                                                                                                3/4
      Verifying  : libtidy-devel-0.99.0-34.20091203.0.el7.x86_64                                                                                                                                                                                          4/4
    
    Installed:
      compat-libtidy.x86_64 0:0.99.0-37.20091203.el7                                                                           compat-libtidy-devel.x86_64 0:0.99.0-37.20091203.el7                                                                        
    
    Replaced:
      libtidy.x86_64 0:0.99.0-34.20091203.0.el7                                                                                libtidy-devel.x86_64 0:0.99.0-34.20091203.0.el7                                                                              
    
    Complete!

    did you run yum check when running nginx update via centmin.sh menu option 4 ? the yum check forces a libtidy and libtidy-devel yum install which conflicts
    Code (Text):
    yum -y install libtidy libtidy-devel --disablerepo=rpmforge       
    Loaded plugins: fastestmirror, priorities
    Loading mirror speeds from cached hostfile
    Excluding mirror: ca.mirror.babylon.network
     * base: mirror2.evolution-host.com
    Excluding mirror: ca.mirror.babylon.network
     * elrepo: ftp.osuosl.org
    Excluding mirror: ca.mirror.babylon.network
     * epel: epel.mirror.constant.com
    Excluding mirror: ca.mirror.babylon.network
     * extras: mirror2.evolution-host.com
    Excluding mirror: ca.mirror.babylon.network
     * updates: mirror2.evolution-host.com
    358 packages excluded due to repository priority protections
    Resolving Dependencies
    --> Running transaction check
    ---> Package libtidy.x86_64 0:5.4.0-1.el7 will be installed
    ---> Package libtidy-devel.x86_64 0:5.4.0-1.el7 will be installed
    --> Processing Conflict: compat-libtidy-devel-0.99.0-37.20091203.el7.x86_64 conflicts libtidy-devel > 5.0
    --> Finished Dependency Resolution
    Error: compat-libtidy-devel conflicts with libtidy-devel-5.4.0-1.el7.x86_64
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest
    

    so not sure why yum update replaced libtidy with older compat-libtidy packages. Looks like I need to exclude compat-libtidy from Epel city-fan.org repository

    so from output of
    Code (Text):
    yum history info compat-libtidy-devel
    

    find your transaction id which from above = 91 and undo it to reverse the change

    for me it's transaction id = 74

    as you installed custom curl addon via city-fan.org repo, you need to enable it for yum history undo
    Code (Text):
    yum history undo 74 --enablerepo=city-fan.org --disableplugin=priorities
    

    Code (Text):
    yum history undo 74 --enablerepo=city-fan.org --disableplugin=priorities
    Loaded plugins: fastestmirror
    Undoing transaction 74, from Sat Jun 10 23:00:57 2017
        Obsoleting compat-libtidy-0.99.0-37.20091203.el7.x86_64       @epel
        Obsoleting compat-libtidy-devel-0.99.0-37.20091203.el7.x86_64 @epel
        Obsoleted  libtidy-0.99.0-34.20091203.0.el7.x86_64            @city-fan.org
        Obsoleted  libtidy-devel-0.99.0-34.20091203.0.el7.x86_64      @city-fan.org
    Loading mirror speeds from cached hostfile
    Excluding mirror: ca.mirror.babylon.network
     * base: mirror2.evolution-host.com
     * city-fan.org: www.city-fan.org
    Excluding mirror: ca.mirror.babylon.network
     * elrepo: ftp.osuosl.org
    Excluding mirror: ca.mirror.babylon.network
     * epel: epel.mirror.constant.com
    Excluding mirror: ca.mirror.babylon.network
     * extras: mirror2.evolution-host.com
     * rpmforge: repoforge.mirror.constant.com
    Excluding mirror: ca.mirror.babylon.network
     * updates: mirror2.evolution-host.com
    Resolving Dependencies
    --> Running transaction check
    ---> Package compat-libtidy.x86_64 0:0.99.0-37.20091203.el7 will be erased
    ---> Package compat-libtidy-devel.x86_64 0:0.99.0-37.20091203.el7 will be erased
    ---> Package libtidy.x86_64 0:0.99.0-34.20091203.0.el7 will be installed
    ---> Package libtidy-devel.x86_64 0:0.99.0-34.20091203.0.el7 will be installed
    --> Finished Dependency Resolution
    
    Dependencies Resolved
    
    ==========================================================================================================================================================================================================================================================
     Package                                                          Arch                                               Version                                                               Repository                                                Size
    ==========================================================================================================================================================================================================================================================
    Installing:
     libtidy                                                          x86_64                                             0.99.0-34.20091203.0.el7                                              city-fan.org                                             134 k
     libtidy-devel                                                    x86_64                                             0.99.0-34.20091203.0.el7                                              city-fan.org                                             163 k
    Removing:
     compat-libtidy                                                   x86_64                                             0.99.0-37.20091203.el7                                                @epel                                                    392 k
     compat-libtidy-devel                                             x86_64                                             0.99.0-37.20091203.el7                                                @epel                                                     82 k
    
    Transaction Summary
    ==========================================================================================================================================================================================================================================================
    Install  2 Packages
    Remove   2 Packages
    
    Total download size: 297 k
    Is this ok [y/d/N]: y
    Downloading packages:
    (1/2): libtidy-0.99.0-34.20091203.0.el7.x86_64.rpm                                                                                                                                                                                 | 134 kB  00:00:00   
    (2/2): libtidy-devel-0.99.0-34.20091203.0.el7.x86_64.rpm                                                                                                                                                                           | 163 kB  00:00:01   
    ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
    Total                                                                                                                                                                                                                     175 kB/s | 297 kB  00:00:01   
    Running transaction check
    Running transaction test
    Transaction test succeeded
    Running transaction
      Installing : libtidy-0.99.0-34.20091203.0.el7.x86_64                                                                                                                                                                                                1/4
      Installing : libtidy-devel-0.99.0-34.20091203.0.el7.x86_64                                                                                                                                                                                          2/4
      Erasing    : compat-libtidy-devel-0.99.0-37.20091203.el7.x86_64                                                                                                                                                                                     3/4
      Erasing    : compat-libtidy-0.99.0-37.20091203.el7.x86_64                                                                                                                                                                                           4/4
      Verifying  : libtidy-0.99.0-34.20091203.0.el7.x86_64                                                                                                                                                                                                1/4
      Verifying  : libtidy-devel-0.99.0-34.20091203.0.el7.x86_64                                                                                                                                                                                          2/4
      Verifying  : compat-libtidy-0.99.0-37.20091203.el7.x86_64                                                                                                                                                                                           3/4
      Verifying  : compat-libtidy-devel-0.99.0-37.20091203.el7.x86_64                                                                                                                                                                                     4/4
    
    Removed:
      compat-libtidy.x86_64 0:0.99.0-37.20091203.el7                                                                           compat-libtidy-devel.x86_64 0:0.99.0-37.20091203.el7                                                                         
    
    Installed:
      libtidy.x86_64 0:0.99.0-34.20091203.0.el7                                                                                libtidy-devel.x86_64 0:0.99.0-34.20091203.0.el7                                                                             
    
    Complete!
    

    Then install proper packages
    Code (Text):
    yum -y install libtidy libtidy-devel --disablerepo=rpmforge
    

    Code (Text):
    yum list libtidy libtidy-devel -q
    Installed Packages
    libtidy.x86_64                                                                                                                 5.4.0-1.el7                                                                                                           @epel
    libtidy-devel.x86_64                                                                                                           5.4.0-1.el7                                                                                                           @epel
    

    on centmin.sh menu option 4 and 5 you can skip yum checks 99.99% of the time to prevent this before I can fix it with 123.09beta01 update
     
    Last edited: Jun 12, 2017
  5. Jimmy

    Jimmy Premium Member Premium Member

    1,025
    231
    63
    Oct 24, 2015
    East Coast USA
    Ratings:
    +555
    Local Time:
    7:21 PM
    1.13.x
    MariaDB 10.1.x
    Got some errors on the uninstall.

    Code:
    # yum history info compat-libtidy-devel
    Loaded plugins: fastestmirror, priorities
    Transaction ID : 91
    Begin time     : Sat Jun 10 22:47:56 2017
    Begin rpmdb    : 717:98712f148238bb667f4c401c84a1d5684a97f305
    End time       :            22:47:57 2017 (1 seconds)
    End rpmdb      : 717:1c4e159a1f5aa6a46e88b4cee44cbca7a134800a
    User           : root <root>
    Return-Code    : Success
    Command Line   : update --disableplugin=priorities --enablerepo=remi,city-fan.org
    Transaction performed with:
        Installed     rpm-4.11.3-21.el7.x86_64                      @anaconda
        Installed     yum-3.4.3-150.el7.centos.noarch               @anaconda
        Installed     yum-metadata-parser-1.1.4-10.el7.x86_64       @anaconda
        Installed     yum-plugin-fastestmirror-1.1.31-40.el7.noarch @anaconda
    Packages Altered:
        Obsoleting compat-libtidy-0.99.0-37.20091203.el7.x86_64       @epel
        Obsoleting compat-libtidy-devel-0.99.0-37.20091203.el7.x86_64 @epel
        Obsoleted  libtidy-0.99.0-34.20091203.0.el7.x86_64            @city-fan.org
        Obsoleted  libtidy-devel-0.99.0-34.20091203.0.el7.x86_64      @city-fan.org
    history info
    
    Code:
    # yum history undo 91 --enablerepo=city-fan.org --disableplugin=priorities
    Loaded plugins: fastestmirror
    Undoing transaction 91, from Sat Jun 10 22:47:56 2017
        Obsoleting compat-libtidy-0.99.0-37.20091203.el7.x86_64       @epel
        Obsoleting compat-libtidy-devel-0.99.0-37.20091203.el7.x86_64 @epel
        Obsoleted  libtidy-0.99.0-34.20091203.0.el7.x86_64            @city-fan.org
        Obsoleted  libtidy-devel-0.99.0-34.20091203.0.el7.x86_64      @city-fan.org
    Loading mirror speeds from cached hostfile
    Excluding mirror: ca.mirror.babylon.network
     * base: mirror2.evolution-host.com
     * city-fan.org: www.city-fan.org
    Excluding mirror: ca.mirror.babylon.network
     * epel: epel.mirror.constant.com
    Excluding mirror: ca.mirror.babylon.network
     * extras: mirror2.evolution-host.com
     * rpmforge: repoforge.mirror.constant.com
    Excluding mirror: ca.mirror.babylon.network
     * updates: mirror2.evolution-host.com
    Package matching libtidy-0.99.0-34.20091203.0.el7.x86_64 already installed. Checking for update.
    Resolving Dependencies
    --> Running transaction check
    ---> Package compat-libtidy.x86_64 0:0.99.0-37.20091203.el7 will be erased
    --> Processing Dependency: libtidy-0.99.so.0()(64bit) for package: libtidy-devel-0.99.0-34.20091203.0.el7.x86_64
    ---> Package compat-libtidy-devel.x86_64 0:0.99.0-37.20091203.el7 will be erased
    ---> Package libtidy-devel.x86_64 0:0.99.0-34.20091203.0.el7 will be installed
    --> Processing Dependency: libtidy(x86-64) = 0.99.0-34.20091203.0.el7 for package: libtidy-devel-0.99.0-34.20091203.0.el7.x86_64
    --> Processing Dependency: libtidy = 0.99.0-34.20091203.0.el7 for package: libtidy-devel-0.99.0-34.20091203.0.el7.x86_64
    --> Processing Dependency: libtidy-0.99.so.0()(64bit) for package: libtidy-devel-0.99.0-34.20091203.0.el7.x86_64
    --> Finished Dependency Resolution
    Error: Package: libtidy-devel-0.99.0-34.20091203.0.el7.x86_64 (city-fan.org)
               Requires: libtidy-0.99.so.0()(64bit)
               Removing: compat-libtidy-0.99.0-37.20091203.el7.x86_64 (@epel)
                   libtidy-0.99.so.0()(64bit)
               Available: libtidy-0.99.0-34.20091203.0.el7.x86_64 (city-fan.org)
                   libtidy-0.99.so.0()(64bit)
               Installed: libtidy-5.4.0-1.el7.x86_64 (@epel)
                   Not found
    Error: Package: libtidy-devel-0.99.0-34.20091203.0.el7.x86_64 (city-fan.org)
               Requires: libtidy = 0.99.0-34.20091203.0.el7
               Installed: libtidy-5.4.0-1.el7.x86_64 (@epel)
                   libtidy = 5.4.0-1.el7
               Available: libtidy-0.99.0-34.20091203.0.el7.x86_64 (city-fan.org)
                   libtidy = 0.99.0-34.20091203.0.el7
    Error: Package: libtidy-devel-0.99.0-34.20091203.0.el7.x86_64 (city-fan.org)
               Requires: libtidy(x86-64) = 0.99.0-34.20091203.0.el7
               Installed: libtidy-5.4.0-1.el7.x86_64 (@epel)
                   libtidy(x86-64) = 5.4.0-1.el7
               Available: libtidy-0.99.0-34.20091203.0.el7.x86_64 (city-fan.org)
                   libtidy(x86-64) = 0.99.0-34.20091203.0.el7
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest
    
     
  6. eva2000

    eva2000 Administrator Staff Member

    28,925
    6,566
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,744
    Local Time:
    9:21 AM
    Nginx 1.13.x
    MariaDB 5.5
    Strange worked for my install.

    Fix for existing users who ran addons/customcurl.sh to install curl 7.5* is to disable libtidy packages and exclude then from city-fan.org yum repo as epel yum repo has a copy already
    Code (Text):
    sed -i 's|^gpgkey=.*|&\nexcludes=libtidy libtidy-devel|' /etc/yum.repos.d/city-fan.org.repo
    

    then would insert excludes line in /etc/yum.repos.d/city-fan.org.repo example
    Code (Text):
    cat /etc/yum.repos.d/city-fan.org.repo                                                                                   
    [city-fan.org]
    name=city-fan.org repository for Red Hat Enterprise Linux (and clones) $releasever ($basearch)
    #baseurl=http://mirror.city-fan.org/ftp/contrib/yum-repo/rhel$releasever/$basearch
    mirrorlist=http://mirror.city-fan.org/ftp/contrib/yum-repo/mirrorlist-rhel$releasever
    enabled=0
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-city-fan.org
    priority=99
    excludes=libtidy libtidy-devel
    
    [city-fan.org-debuginfo]
    name=city-fan.org debuginfo repository for Red Hat Enterprise Linux (and clones) $releasever ($basearch)
    #baseurl=http://www.city-fan.org/ftp/contrib-debug/rhel$releasever/$basearch
    mirrorlist=http://www.city-fan.org/ftp/contrib-debug/mirrorlist-rhel$releasever
    enabled=0
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-city-fan.org
    priority=99
    excludes=libtidy libtidy-devel
    
    [city-fan.org-source]
    name=city-fan.org source repository for Red Hat Enterprise Linux (and clones) $releasever
    #baseurl=http://mirror.city-fan.org/ftp/contrib/yum-repo/rhel$releasever/source
    mirrorlist=http://mirror.city-fan.org/ftp/contrib/yum-repo/source-mirrorlist-rhel$releasever
    enabled=0
    gpgcheck=1
    gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-city-fan.org
    priority=99
    excludes=libtidy libtidy-devel
    


    But @Jimmy you should NOT do this step yet
     
  7. Jimmy

    Jimmy Premium Member Premium Member

    1,025
    231
    63
    Oct 24, 2015
    East Coast USA
    Ratings:
    +555
    Local Time:
    7:21 PM
    1.13.x
    MariaDB 10.1.x
    Should I do the above? Or did you mean "shouldn't do this step yet"?

    I have to go out for awhile, I'll be back in a few hours.
     
  8. eva2000

    eva2000 Administrator Staff Member

    28,925
    6,566
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,744
    Local Time:
    9:21 AM
    Nginx 1.13.x
    MariaDB 5.5
    sorry forgot the NOT should not do above step yet

    what output do you get for
    Code (Text):
    yum list libtidy libtidy-devel compat-libtidy* --disablerepo=rpmforge --enablerepo=city-fan.org --disableplugin=priorities
    

    example
    Code (Text):
    yum list libtidy libtidy-devel compat-libtidy* --disablerepo=rpmforge --enablerepo=city-fan.org --disableplugin=priorities
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    Excluding mirror: ca.mirror.babylon.network
     * base: mirror2.evolution-host.com
     * city-fan.org: www.city-fan.org
    Excluding mirror: ca.mirror.babylon.network
     * elrepo: ftp.osuosl.org
    Excluding mirror: ca.mirror.babylon.network
     * epel: epel.mirror.constant.com
    Excluding mirror: ca.mirror.babylon.network
     * extras: mirror2.evolution-host.com
    Excluding mirror: ca.mirror.babylon.network
     * updates: mirror2.evolution-host.com
    Installed Packages
    compat-libtidy.x86_64                                                                                                        0.99.0-37.20091203.el7                                                                                                  @epel
    libtidy.x86_64                                                                                                               5.4.0-1.el7                                                                                                             @epel
    libtidy-devel.x86_64                                                                                                         5.4.0-1.el7                                                                                                             @epel
    Available Packages
    compat-libtidy-devel.x86_64                                                                                                  0.99.0-37.20091203.el7                                                                                                  epel 
    
     
    Last edited: Jun 11, 2017
  9. Jimmy

    Jimmy Premium Member Premium Member

    1,025
    231
    63
    Oct 24, 2015
    East Coast USA
    Ratings:
    +555
    Local Time:
    7:21 PM
    1.13.x
    MariaDB 10.1.x
    No worries, that's what I thought you meant.

    Code:
    # yum list libtidy libtidy-devel compat-libtidy* --disablerepo=rpmforge --enablerepo=city-fan.org --disableplugin=priorities
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    Excluding mirror: ca.mirror.babylon.network
     * base: mirror2.evolution-host.com
     * city-fan.org: www.city-fan.org
    Excluding mirror: ca.mirror.babylon.network
     * epel: epel.mirror.constant.com
    Excluding mirror: ca.mirror.babylon.network
     * extras: mirror2.evolution-host.com
    Excluding mirror: ca.mirror.babylon.network
     * updates: mirror2.evolution-host.com
    Installed Packages
    compat-libtidy.x86_64                                                       0.99.0-37.20091203.el7                                                  @epel
    compat-libtidy-devel.x86_64                                                 0.99.0-37.20091203.el7                                                  @epel
    libtidy.x86_64                                                              5.4.0-1.el7                                                             @epel
    Available Packages
    libtidy-devel.x86_64                                                        5.4.0-1.el7                                                             epel
     
  10. eva2000

    eva2000 Administrator Staff Member

    28,925
    6,566
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,744
    Local Time:
    9:21 AM
    Nginx 1.13.x
    MariaDB 5.5
    without answering yes to remove prompt (answer no) what output do you get from
    Code (Text):
    yum remove compat-libtidy-devel
    

    only answer yes to remove if no other yum packages are removed /listed to be removed. If only that compat-libtidy-devel package is removed, then you can install libtidy-devel
    Code (Text):
    yum -y install libtidy-devel
    

    and then add excludes line to city-fan.org.repo via sed insertion
    Code (Text):
    sed -i 's|^gpgkey=.*|&\nexcludes=libtidy libtidy-devel|' /etc/yum.repos.d/city-fan.org.repo
    
     
    Last edited: Jun 11, 2017
  11. pamamolf

    pamamolf Well-Known Member

    2,485
    229
    63
    May 31, 2014
    Ratings:
    +390
    Local Time:
    2:21 AM
    Nginx-1.13.x
    MariaDB 10.1.x
    Ok so what's the proper fix for users that already run and use customcurl and for users that maybe will use it later?
     
  12. eva2000

    eva2000 Administrator Staff Member

    28,925
    6,566
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,744
    Local Time:
    9:21 AM
    Nginx 1.13.x
    MariaDB 5.5
    • Like Like x 2
  13. Jimmy

    Jimmy Premium Member Premium Member

    1,025
    231
    63
    Oct 24, 2015
    East Coast USA
    Ratings:
    +555
    Local Time:
    7:21 PM
    1.13.x
    MariaDB 10.1.x
    Below is the output I got. Since it's only listing I can remove it (compat-libtidy-devel) via that same command (answering yes) and do the other two steps you outlined?

    Code:
    yum list libtidy libtidy-devel compat-libtidy* --disablerepo=rpmforge --enablerepo=city-fan.org --disableplugin=priorities
    Loaded plugins: fastestmirror
    Loading mirror speeds from cached hostfile
    Excluding mirror: ca.mirror.babylon.network
     * base: mirror2.evolution-host.com
     * city-fan.org: www.city-fan.org
    Excluding mirror: ca.mirror.babylon.network
     * epel: epel.mirror.constant.com
    Excluding mirror: ca.mirror.babylon.network
     * extras: mirror2.evolution-host.com
    Excluding mirror: ca.mirror.babylon.network
     * updates: mirror2.evolution-host.com
    Installed Packages
    compat-libtidy.x86_64                                                       0.99.0-37.20091203.el7                                                  @epel
    compat-libtidy-devel.x86_64                                                 0.99.0-37.20091203.el7                                                  @epel
    libtidy.x86_64                                                              5.4.0-1.el7                                                             @epel
    Available Packages
    libtidy-devel.x86_64                                                        5.4.0-1.el7                                                             epel
    [root@server1 centminmod]# yum remove compat-libtidy-devel
    Loaded plugins: fastestmirror, priorities
    Resolving Dependencies
    --> Running transaction check
    ---> Package compat-libtidy-devel.x86_64 0:0.99.0-37.20091203.el7 will be erased
    --> Finished Dependency Resolution
    
    Dependencies Resolved
    
    =========================================================================================================================================================
     Package                                    Arch                         Version                                       Repository                   Size
    =========================================================================================================================================================
    Removing:
     compat-libtidy-devel                       x86_64                       0.99.0-37.20091203.el7                        @epel                        82 k
    
    Transaction Summary
    =========================================================================================================================================================
    Remove  1 Package
    
    Installed size: 82 k
    Is this ok [y/N]: n
    Exiting on user command
    Your transaction was saved, rerun it with:
     yum load-transaction /tmp/yum_save_tx.2017-06-11.03-30.GCTawa.yumtx
    
     
  14. eva2000

    eva2000 Administrator Staff Member

    28,925
    6,566
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,744
    Local Time:
    9:21 AM
    Nginx 1.13.x
    MariaDB 5.5
  15. Jimmy

    Jimmy Premium Member Premium Member

    1,025
    231
    63
    Oct 24, 2015
    East Coast USA
    Ratings:
    +555
    Local Time:
    7:21 PM
    1.13.x
    MariaDB 10.1.x
    Looks good. Ran the nginx upgrade #4 and didn't get the warning. Thanks for all your help!
     
    • Like Like x 1
  16. eva2000

    eva2000 Administrator Staff Member

    28,925
    6,566
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,744
    Local Time:
    9:21 AM
    Nginx 1.13.x
    MariaDB 5.5
    Excellent. Thanks for the bug report .. another one squashed :D
     
    • Like Like x 1
  17. Jimmy

    Jimmy Premium Member Premium Member

    1,025
    231
    63
    Oct 24, 2015
    East Coast USA
    Ratings:
    +555
    Local Time:
    7:21 PM
    1.13.x
    MariaDB 10.1.x
    No problem. Glad I caught it, normally I don't look over that information when nginx builds.
     
    • Like Like x 1