Learn about Centmin Mod LEMP Stack today
Become a Member

Wordpress Change from WP-FFPC to WP-Super Cache

Discussion in 'Blogs & CMS usage' started by Mak Adang, Apr 8, 2015.

  1. Mak Adang

    Mak Adang Member

    39
    13
    8
    Jan 4, 2015
    Ratings:
    +14
    Local Time:
    2:40 PM
    1.9.0
    10.0.18-MariaDB
    Hi @eva2000, i just change my wp-ffpc to wp-super cache by tutorial writen here WordPress + Super Cache plugin for Centmin Mod Nginx | wp1.centmincache.com
    Everything just work fine and better performance so far.

    I just confused about old configuration that should be used for wp-ffpc before :
    • in /usr/local/nginx/conf/nginx.conf
      Code:
      http {
      # memcached servers, generated according to wp-ffpc config
      upstream memcached-servers {
      server 127.0.0.1:11211;
      }
      
      Please advise what should i do with this code should i remove it or leave it.
    • in /usr/local/nginx/conf/pagespeed.conf
      Code:
      # let's speed up PageSpeed by storing it in the super duper fast memcached
           # Ensure Memcached server installed http://centminmod.com/memcached.html
           # default install for centmin mod is on port 11211, so localhost:11211 is correct
           # uncomment - remove hash # in front of below 2 lines to enable
           # timeout set at 100 milliseconds
           pagespeed MemcachedThreads 1;
           pagespeed MemcachedServers "localhost:11211";
           pagespeed MemcachedTimeoutUs 100000;
      Also please advise since i'm using pagespeed too what about this code should i keep or remove it
    • the last in /usr/local/nginx/conf/conf.d/mydomain.conf
      Code:
      server {
      server_name mydomain.com
      include /usr/local/nginx/conf/wpnocache.conf;
      what about wpnocache.conf since wp-ffpc use this code before.
    Thank you.
     
    • Like Like x 1
  2. eva2000

    eva2000 Administrator Staff Member

    30,178
    6,786
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,139
    Local Time:
    5:40 PM
    Nginx 1.13.x
    MariaDB 5.5
    remove from nginx.conf

    Code:
    # memcached servers, generated according to wp-ffpc config
    upstream memcached-servers {
    server 127.0.0.1:11211;
    }
    leave pagespeed.conf alone

    can remove
    Code:
    include /usr/local/nginx/conf/wpnocache.conf;
     
    • Like Like x 1
  3. Mak Adang

    Mak Adang Member

    39
    13
    8
    Jan 4, 2015
    Ratings:
    +14
    Local Time:
    2:40 PM
    1.9.0
    10.0.18-MariaDB
  4. Mak Adang

    Mak Adang Member

    39
    13
    8
    Jan 4, 2015
    Ratings:
    +14
    Local Time:
    2:40 PM
    1.9.0
    10.0.18-MariaDB
    Hi @eva2000 sorry to disturb you again, i just try wp-supercache with one of my wp-multisite.
    I have problem now, my subdomain image cannot show up. Do you have same case before and please advise what to do.

    Thank You.
     
  5. eva2000

    eva2000 Administrator Staff Member

    30,178
    6,786
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,139
    Local Time:
    5:40 PM
    Nginx 1.13.x
    MariaDB 5.5
    unfortunately i have no experience with wp super cache on multi site wordpress setups as that requires other tweaks I believe