Learn about Centmin Mod LEMP Stack today
Become a Member

CentOS 7.x CentOS 7.x Security & Bug Fix Yum Updates - Linux Kernel 3.10.0-957.10.1

Discussion in 'CentOS, Redhat & Oracle Linux News' started by eva2000, Mar 21, 2019.

  1. eva2000

    eva2000 Administrator Staff Member

    42,001
    9,473
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,577
    Local Time:
    11:14 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    Yesterday, CentOS announced alot of bug and security errata YUM updates for release - including updates for CentOS 7.x Linux Kernel 3.10.0-957.10.1.el7 and OpenSSL 1.0.2k-16.el7_6.1 system yum updates ( Side-channel vulnerability on SMT/Hyper-Threading architectures (PortSmash CVE-2018-5407) at Errata/Releases, March 19th 2019.

    Folks should do a yum update and reboot their servers (due to Kernel updates requiring a server reboot)
    Code (Text):
    yum clean all
    yum -y update
    

    Then reboot your servers at a time of your choosing i.e. low peak hour traffic. Here, I usually run mysqladmin flush-tables to ensure all mysql data in memory buffers is written to disk and wait at least 60 seconds (maybe more if you have large database/memory buffer settings) and then reboot the server.
    Code (Text):
    mysqladmin flush-tables
    sleep 60
    reboot
    


     
    • Like Like x 5
  2. eva2000

    eva2000 Administrator Staff Member

    42,001
    9,473
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,577
    Local Time:
    11:14 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    Looks like some centos 7 yum mirrors aren't fully populated yet as yum update gives me follow errors on some mirrors
    Code (Text):
    Some delta RPMs failed to download or rebuild. Retrying..                                                     100% [====================================================================================================] 2.0 MB/s |  50 MB  00:00:00 ETA
    polkit-0.112-18.el7_6.1.x86_64 FAILED                                        
    http://mirror.sfo12.us.leaseweb.net/centos/7.6.1810/updates/x86_64/Packages/polkit-0.112-18.el7_6.1.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable                                             ]  0.0 B/s |    0 B  --:--:-- ETA
    Trying other mirror.
    polkit-0.112-18.el7_6.1.x86_64 FAILED                                        
    http://mirror.fileplanet.com/centos/7.6.1810/updates/x86_64/Packages/polkit-0.112-18.el7_6.1.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable                                                    ]  0.0 B/s |    0 B  --:--:-- ETA
    Trying other mirror.
    polkit-0.112-18.el7_6.1.x86_64 FAILED                                        
    http://centos.sonn.com/7.6.1810/updates/x86_64/Packages/polkit-0.112-18.el7_6.1.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable                                                                 ]  0.0 B/s |    0 B  --:--:-- ETA
    Trying other mirror.
    polkit-0.112-18.el7_6.1.x86_64 FAILED                                        
    http://mirror.linuxfix.com/centos/7.6.1810/updates/x86_64/Packages/polkit-0.112-18.el7_6.1.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable                                                      ]  0.0 B/s |    0 B  --:--:-- ETA
    Trying other mirror.
    polkit-0.112-18.el7_6.1.x86_64 FAILED                                        
    http://mirrors.usc.edu/pub/linux/distributions/centos/7.6.1810/updates/x86_64/Packages/polkit-0.112-18.el7_6.1.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable                                  ]  0.0 B/s |    0 B  --:--:-- ETA
    Trying other mirror.
    polkit-0.112-18.el7_6.1.x86_64 FAILED                                        
    http://mirror.keystealth.org/centos/7.6.1810/updates/x86_64/Packages/polkit-0.112-18.el7_6.1.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable                                                    ]  0.0 B/s |    0 B  --:--:-- ETA
    Trying other mirror.
    polkit-0.112-18.el7_6.1.x86_64 FAILED                                        
    http://centos.mirror.ndchost.com/7.6.1810/updates/x86_64/Packages/polkit-0.112-18.el7_6.1.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable                                                       ]  0.0 B/s |    0 B  --:--:-- ETA
    Trying other mirror.
    polkit-0.112-18.el7_6.1.x86_64 FAILED                                        
    http://mirror.san.fastserv.com/pub/linux/centos/7.6.1810/updates/x86_64/Packages/polkit-0.112-18.el7_6.1.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable                                        ]  0.0 B/s |    0 B  --:--:-- ETA
    Trying other mirror.
    polkit-0.112-18.el7_6.1.x86_64 FAILED                                        
    http://mirrors.xtom.com/centos/7.6.1810/updates/x86_64/Packages/polkit-0.112-18.el7_6.1.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable                                                         ]  0.0 B/s |    0 B  --:--:-- ETA
    Trying other mirror.
    polkit-0.112-18.el7_6.1.x86_64 FAILED                                        
    http://mirror.scalabledns.com/centos/7.6.1810/updates/x86_64/Packages/polkit-0.112-18.el7_6.1.x86_64.rpm: [Errno 14] HTTP Error 416 - Requested Range Not Satisfiable                                                   ]  0.0 B/s |    0 B  --:--:-- ETA
    Trying other mirror.
    
    
    Error downloading packages:
      polkit-0.112-18.el7_6.1.x86_64: [Errno 256] No more mirrors to try.
    


    You can wait for mirrors to populate, or just exclude polkit from yum update for now
    Code (Text):
    yum clean all
    yum -y update --exclude=polkit
    

    Code (Text):
    mysqladmin flush-tables
    sleep 60
    reboot
    
     
    • Like Like x 4
    • Winner Winner x 1
  3. steph40

    steph40 Premium Member Premium Member

    60
    13
    8
    Jan 28, 2019
    Ratings:
    +25
    Local Time:
    8:14 AM
    1.1.5
    mariadb 10
    All done with no error, Thank you!
     
    • Like Like x 1
  4. Itworx4me

    Itworx4me Premium Member Premium Member

    196
    21
    18
    Mar 14, 2017
    Ratings:
    +34
    Local Time:
    5:14 AM
    Nginx 1.17.X
    MariaDB 10.3.X
    After doing this upgrade my root login in very slow. Also signing onto centmin does the same thing. 2 to 5 minutes sometimes before the command prompt shows up. Never used to be this way. Any ideas?
     
  5. eva2000

    eva2000 Administrator Staff Member

    42,001
    9,473
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,577
    Local Time:
    11:14 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
  6. Jon Snow

    Jon Snow Active Member

    445
    66
    28
    Jun 30, 2017
    Ratings:
    +104
    Local Time:
    9:14 AM
    Nginx 1.13.9
    MariaDB 10.1.31
    When do you think the mirrors will populate? Should I just ignore polkit and update right away? It's been some days and it hasn't populated yet.

    Code (Text):
    polkit-0.112-18.el7_6.1.x86_64: [Errno 256] No more mirrors to try.
     
  7. eva2000

    eva2000 Administrator Staff Member

    42,001
    9,473
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,577
    Local Time:
    11:14 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    ensure you run yum clean all before re-trying yum updates
     
  8. Jon Snow

    Jon Snow Active Member

    445
    66
    28
    Jun 30, 2017
    Ratings:
    +104
    Local Time:
    9:14 AM
    Nginx 1.13.9
    MariaDB 10.1.31
    That's what I've been doing.
     
  9. Kintaro

    Kintaro Member

    63
    3
    8
    Dec 2, 2016
    Italy
    Ratings:
    +14
    Local Time:
    2:14 PM
    1.15.x
    MariaDB 10
    I found this:
    yum upgrade problem - Page 2 - CentOS

    And I used:
    Code (Text):
    --setopt=deltarpm=0

    so:
    Code (Text):
    yum update --setopt=deltarpm=0 --disableplugin=priorities --enablerepo=remi
     
    • Informative Informative x 2
    • Like Like x 1
  10. eva2000

    eva2000 Administrator Staff Member

    42,001
    9,473
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,577
    Local Time:
    11:14 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    @Kintaro nice find

    yum clean all did eventually clear it up for my on servers with polkit reported issues for yum update though
     
  11. deltahf

    deltahf Premium Member Premium Member

    338
    155
    43
    Jun 8, 2014
    Ratings:
    +244
    Local Time:
    8:14 AM
    Just updated now; no problems to report.
     
    • Like Like x 1
  12. eva2000

    eva2000 Administrator Staff Member

    42,001
    9,473
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,577
    Local Time:
    11:14 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    better late than never :)
     
    • Agree Agree x 1