Want more timely Centmin Mod News Updates?
Become a Member

Centos 7.7 install Mysql 8 error!

Discussion in 'Install & Upgrades or Pre-Install Questions' started by KinderOvO, Jan 9, 2020.

  1. KinderOvO

    KinderOvO Member

    91
    1
    8
    Jan 13, 2015
    Ratings:
    +1
    Local Time:
    9:54 AM
    1.4
    10
    Hello, I removed mariadb because I need to use mysql 8.

    When trying to install, I tried to use all major google tutorials.
    But I always get the same error.

    Example: https://tecadmin.net/install-mysql-8-on-centos/

    yum --enablerepo=mysql80-community install mysql-community-server
    No package mysql-community-server available.
    Error: Nothing to do

    Thanks in advance who can help resolve this error.
     
  2. eva2000

    eva2000 Administrator Staff Member

    43,079
    9,781
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,100
    Local Time:
    9:54 AM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    What do you need in Oracle MySQL 8.0 than MariaDB 10.3 doesn't provide ?

    Centmin Mod doesn't have any official Oracle MySQL 8.0 support. One of the reasons why is outlined at https://community.centminmod.com/threads/mariadb-mysql-vs-oracle-mysql-vs-percona-mysql.13853/ due to no auto optimisation routines and testing for Oracle MySQL 8.0 and other differences in how MySQL 8.0 operates unless you know the differences and adjust accordingly your configuration/management of MySQL 8.0 server/backups etc. However, I have been working on a Centmin Mod MariaDB 10.3 to Oracle MySQL 8.0 switch script for one of my paid clients which is still in testing phase.

    The reason is because Centmin Mod uses yum priorities plugin and also yum exclude configuration outlined at https://centminmod.com/yum.html which prevents YUM package conflicts with Centmin Mod's YUM packages it installs. We don't want mysql yum packages conflicting with MariaDB yum packages.

    If you have manually removed MariaDB yum packages, then want to install Oracle MySQL 8 packages, you need to pass --disableexcludes=main flag to yum install command to disable main yum repo config excludes preventing any mysql* named packages from being installed/detected.

    Note, you'd be on your own with MySQL 8.0 for as Centmin Mod doesn't officially support it.