Learn about Centmin Mod LEMP Stack today
Register Now

Wordpress CentminMod clearing the transients automatically everyday

Discussion in 'Blogs & CMS usage' started by Saumya Majumder, Dec 12, 2016.

  1. Saumya Majumder

    Saumya Majumder Member

    60
    3
    8
    Mar 16, 2016
    Ratings:
    +12
    Local Time:
    3:42 AM
    1.9.12
    10.0.24
    Hi,
    recently I've installed wordpress in one of my subdomain using the centmin.sh menu and by default it added cache enabler, cdn enabler, scuri etc. plugin. After installing WordPress I've deleted these plugins of my site and started using the redis + redis nginx combination in my subdomain like my main site.

    Now everything is working fine but there is just one issue that is highly bothering me. In this new install I can see that somehow all the transients within WordPress gets deleted everyday and this is creating a problem for me as many plugin uses transients to hold key data.

    Is there any way I can delete this auto transient deletion from my wp install?
     
  2. eva2000

    eva2000 Administrator Staff Member

    28,957
    6,574
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,756
    Local Time:
    8:12 AM
    Nginx 1.13.x
    MariaDB 5.5
    not a wordpress developer but maybe this is true/recommended Don't Cache Everything in a Transient - Pressjitsu ?
    Transients API « WordPress Codex
     
    Last edited: Dec 12, 2016
  3. Saumya Majumder

    Saumya Majumder Member

    60
    3
    8
    Mar 16, 2016
    Ratings:
    +12
    Local Time:
    3:42 AM
    1.9.12
    10.0.24
    Its not about everything. But I just don't understand whats clearing the transients everyday...
     
  4. eva2000

    eva2000 Administrator Staff Member

    28,957
    6,574
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,756
    Local Time:
    8:12 AM
    Nginx 1.13.x
    MariaDB 5.5
    did you install redis object cache wp plugin ? IIRC there's a cache TTL value you can set in wp admin

    probably is you don't want a too long cache TTLS for redis object cache or your settings changes might not be live/operational.

    so probably better to just disable redis object cache plugin itself
     
  5. Saumya Majumder

    Saumya Majumder Member

    60
    3
    8
    Mar 16, 2016
    Ratings:
    +12
    Local Time:
    3:42 AM
    1.9.12
    10.0.24
    I have tried disabling the redis object cache plugin for one day and it still removing all transients everyday...

    Now the problem is that different transient has different expiration time, so if it deletes all transients everyday, it just doesnt make any sense.
     
  6. Saumya Majumder

    Saumya Majumder Member

    60
    3
    8
    Mar 16, 2016
    Ratings:
    +12
    Local Time:
    3:42 AM
    1.9.12
    10.0.24
    I also see these following define statements in my wp-config file:

    Code:
    define('WP_CACHE_KEY_SALT', md5( DB_NAME . $table_prefix . __FILE__ ) );
    define('WP_REDIS_MAXTTL', 28800);
    define('WP_REDIS_DATABASE', 6);
    
    should I comment them out?
     
  7. eva2000

    eva2000 Administrator Staff Member

    28,957
    6,574
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,756
    Local Time:
    8:12 AM
    Nginx 1.13.x
    MariaDB 5.5
    not the 1st and 3rd, the 2nd you could change the value and see

    however Transients API « WordPress Codex
     
    Last edited: Dec 12, 2016
    • Informative Informative x 1