Join the community today
Register Now

PHP-FPM Centmin News Installation (Php-fpm cant install correctly)

Discussion in 'Install & Upgrades or Pre-Install Questions' started by negative, Apr 11, 2015.

Tags:
  1. negative

    negative Premium Member Premium Member

    222
    22
    18
    Apr 11, 2015
    Ratings:
    +50
    Local Time:
    2:23 AM
    1.9.10
    10.1.11
    Hello, i have installed centminmod yet on digitalocean vps server (centos 6.5 64bit)

    I read install instructions and installed via ./centmin.sh install and everything installed except php-fpm i think. Because, i set my domain then i add name server details too without problem and when i enter the domain name as url, webpage runs. It shows default welcome page. But, when i put any php file, it doesnt work. All php files Server 502 bad gateway error.

    I tried with #5 reinstall php, then tried again with different php version, and tried #21 reinstall nginx + php-fpm but still same problem.

    When i tried the restart, reload or stop/start php-fpm via command, it says

    [[email protected] centmin-v1.2.3mod]# service php-fpm restart

    Gracefully shutting down php-fpm kill: usage: kill [-s sigspec | -n signum | -sigspec] pid | jobspec ... or kill -l [sigspec]
    ................................... failed. Use force-exit

    Starting php-fpm /etc/init.d/php-fpm: line 68: /usr/local/sbin/php-fpm: No such file or directory

    failed


    **Force quit cant work too.

    What may be problem ?
     
  2. eva2000

    eva2000 Administrator Staff Member

    35,991
    7,896
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,174
    Local Time:
    9:23 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    PHP failed to install.. it could be a system locale issue as i see you're dates aren't in english ?

    what does output of command give in ssh as root user

    Code:
    locale
    i.e.
    Code:
    locale
    LANG=en_US.UTF-8
    LC_CTYPE="en_US.UTF-8"
    LC_NUMERIC="en_US.UTF-8"
    LC_TIME="en_US.UTF-8"
    LC_COLLATE="en_US.UTF-8"
    LC_MONETARY="en_US.UTF-8"
    LC_MESSAGES="en_US.UTF-8"
    LC_PAPER="en_US.UTF-8"
    LC_NAME="en_US.UTF-8"
    LC_ADDRESS="en_US.UTF-8"
    LC_TELEPHONE="en_US.UTF-8"
    LC_MEASUREMENT="en_US.UTF-8"
    LC_IDENTIFICATION="en_US.UTF-8"
    LC_ALL=
     
  3. negative

    negative Premium Member Premium Member

    222
    22
    18
    Apr 11, 2015
    Ratings:
    +50
    Local Time:
    2:23 AM
    1.9.10
    10.1.11
    Output is :
    I didnt set my language as Turkish, but i m from Turkey. I bought a newest vps from digitalocean and i didnt set anything. Should i set my locale set to English now for install without problem ? Or you have a config option for this, i prefer stay on my language too.
     
  4. eva2000

    eva2000 Administrator Staff Member

    35,991
    7,896
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,174
    Local Time:
    9:23 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    well centmin mod has only been tested by me in english environment, so i suggest you try first in english environment to rule out centmin mod itself as the problem first
     
  5. negative

    negative Premium Member Premium Member

    222
    22
    18
    Apr 11, 2015
    Ratings:
    +50
    Local Time:
    2:23 AM
    1.9.10
    10.1.11
    But everything working and set without problem except php-fpm

    Also, when i run the this command;
    It says;
    So i think, its locale in Turkish because my computer language in Turkish. I think, Digitalocean's image cant do it because they dont interested with my country or language.

    Also, i know that too many non-english guys running centminmod.
     
  6. eva2000

    eva2000 Administrator Staff Member

    35,991
    7,896
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,174
    Local Time:
    9:23 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    Yeah CentOS picks up locale from your host pc from /etc/profile.d/lang.sh I believe. It's probably a PHP bug itself PHP :: Bug #18556 :: Setting locale to 'tr_TR' lowercases class names nothing to do with Centmin Mod really. Unfortunately, as I said I haven't tested in non-English locales so would need to investigate myself - it could be specific issue to just Turkish language.

    try adding to 2nd line of inc/php_configure.inc the following

    Code:
    LANG=en_US.UTF-8
    so first 2 lines become
    Code:
    function funct_phpconfigure {
    LANG=en_US.UTF-8
    save inc/php_configure.inc and try centmin.sh menu option 5 to reinstall PHP
     
  7. negative

    negative Premium Member Premium Member

    222
    22
    18
    Apr 11, 2015
    Ratings:
    +50
    Local Time:
    2:23 AM
    1.9.10
    10.1.11
    Okay i set my pc locale to English then php-fpm reinstall completed, thanks for help eva
     
    • Like Like x 1
  8. eva2000

    eva2000 Administrator Staff Member

    35,991
    7,896
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +12,174
    Local Time:
    9:23 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    yup confirmed problem is with Turkish locale as i set my locale to Turkish and got same error !

    in inc/php_configure.inc I set
    Code:
    function funct_phpconfigure {
    LANG=tr_TR.UTF-8
    
    and got

    Code:
    Generating phar.phar
    
    Parse error: syntax error, unexpected '/' in /svr-setup/php-5.5.23/fpm-build/ext/phar/phar.php on line 20
    make: *** [ext/phar/phar.phar] Hata 255
    
    real    5m8.943s
    user    7m19.885s
    sys     1m18.028s
    Generating phar.phar
    
    Parse error: syntax error, unexpected '/' in /svr-setup/php-5.5.23/fpm-build/ext/phar/phar.php on line 20
    make: *** [ext/phar/phar.phar] Hata 255
    
    real    0m0.533s
    user    0m0.116s
    sys     0m0.042s
    Gracefully shutting down php-fpm . done
    Starting php-fpm Failed loading opcache.so:  opcache.so: cannot open shared object file: No such file or directory
    done
    *************************************************
    
    Cum Nis 10 21:53:28 UTC 2015
    Success: PHP configure ok
    
    *************************************************
    make -j3
    Generating phar.phar
    
    Parse error: syntax error, unexpected '/' in /svr-setup/php-5.5.23/fpm-build/ext/phar/phar.php on line 20
    make: *** [ext/phar/phar.phar] Hata 255
    
    real    0m0.457s
    user    0m0.127s
    sys     0m0.031s
    *************************************************
    
    Cum Nis 10 21:53:30 UTC 2015
    Error: 2, PHP make failed (1.2.3-eva2000.07)
    
    *************************************************
     
..