Join the community today
Become a Member

Centmin Mod latest version check notification ?

Discussion in 'Feature Requests & Suggestions' started by eva2000, Jun 5, 2014.

  1. eva2000

    eva2000 Administrator Staff Member

    49,763
    11,447
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +17,789
    Local Time:
    3:56 AM
    Nginx 1.21.x
    MariaDB 10.x
    Been thinking about this since Centmin Mod started but wasn't sure how intrusive this would be for a shell based script. What if Centmin Mod when centmin.sh is run, it will check if you have the latest version installed and notify you if there was a newer version ?

    Basically it would be a static text file at centminmod.com/latest.txt with only the Centmin Mod version number. Then when centmin.sh is run, it compares your current used Centmin Mod version used with the version specified at centminmod.com/latest.txt and if latest.txt is newer will just give you a message in SSH that there's a newer version update available ?

    In software it's generally nice to have such feature, but within an SSH shell based app it could be seen as intrusive or a security issue by some folks.


    What do you think ?
     
    Last edited: Jun 5, 2014
  2. rdan

    rdan Well-Known Member

    5,372
    1,348
    113
    May 25, 2014
    Ratings:
    +2,110
    Local Time:
    1:56 AM
    Mainline
    10.2
    Good to have for me :)
    I always check your site and this forum so no need for that :D
     
  3. Peter Downey

    Peter Downey Member

    64
    24
    8
    May 28, 2014
    Ratings:
    +27
    Local Time:
    12:56 PM
    I'm absolutely fine with it.
     
  4. Matt

    Matt Well-Known Member

    895
    408
    63
    May 25, 2014
    Rotherham, UK
    Ratings:
    +651
    Local Time:
    5:56 PM
    1.5.15
    MariaDB 10.2
    Yes, always good to know you are on the latest version.
     
  5. pamamolf

    pamamolf Well-Known Member

    4,000
    420
    83
    May 31, 2014
    Ratings:
    +812
    Local Time:
    7:56 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    not need it as i check daily the site :)