Welcome to Centmin Mod Community
Register Now

Upgrade Centmin Mod 123.09beta - Nginx + openssl 1.0.2g update issues

Discussion in 'Install & Upgrades or Pre-Install Questions' started by ModeltogTossen, Mar 2, 2016.

Tags:
  1. ModeltogTossen

    ModeltogTossen I wish I could??

    313
    97
    28
    Dec 20, 2015
    Denmark
    Ratings:
    +143
    Local Time:
    11:58 AM
    1.9.12
    10.0.23
    After commented out all the 503 lines and execute nprestart - I now got a totally white screen.. Should I perhaps go to CF and change status from orange to grey for the html traffic?
     
  2. pamamolf

    pamamolf Premium Member Premium Member

    3,806
    369
    83
    May 31, 2014
    Ratings:
    +711
    Local Time:
    12:58 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    @ModeltogTossen
    Yes i am using Cloudflare and i am on 64bit Centos always :)
     
  3. BigIron

    BigIron Member

    62
    15
    8
    Sep 18, 2015
    Ratings:
    +18
    Local Time:
    2:58 AM
    Having issues updating .09, I'm sure it's just a noob issue. CentOS 7, if it matters.

    Got this far, closed the ssh session and logged in again, ran /centmin.sh and it's coming up asking for my Server Administration Email (like it's going to install fresh).
     
  4. pamamolf

    pamamolf Premium Member Premium Member

    3,806
    369
    83
    May 31, 2014
    Ratings:
    +711
    Local Time:
    12:58 PM
    Nginx-1.17.x
    MariaDB 10.3.x
    Just hit enter and you will be fine or just add your mails and it will never ask again for it :)
     
  5. BigIron

    BigIron Member

    62
    15
    8
    Sep 18, 2015
    Ratings:
    +18
    Local Time:
    2:58 AM
    Great, thanks!
     
  6. eva2000

    eva2000 Administrator Staff Member

    44,406
    10,139
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,684
    Local Time:
    7:58 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    you on cloudflare free or paid pro plan ? try disabling CF cache and see

    in developer tools network tab of browser, is the white screen http status 503 or 200 ?
     
  7. ModeltogTossen

    ModeltogTossen I wish I could??

    313
    97
    28
    Dec 20, 2015
    Denmark
    Ratings:
    +143
    Local Time:
    11:58 AM
    1.9.12
    10.0.23
    Sorry all - I got it all working yesterday - but had to attend to a meating out of town.. What I did last yesterday was:

    1. Re-compile back to 1.0.2g after a 1.0.2f test.
    2. Removed the 503 included lines from my conf. - and they still are - only that the cloudflare options enabled for now.
    3. Flush redis
    4. rm -rf in pagespeed directory
    5. nprestart

    And BANG - back in business.. So still at CF with free plan and orange net for www and root site.

    I have to be very honest here - it was very frustrated for me - and yesterday I did think, I will never ever be the first anymore to try new stuff out :hungover: - will simply wait for others.

    That was a 503 - spotted in chrome..

    So @eva2000 - should you perhaps in code, if cache detected - have some flush/clear cache after if we have compiled something like open/libre-ssl, php and nginx and before nprestart?

    I'm glad for now.
     
  8. eva2000

    eva2000 Administrator Staff Member

    44,406
    10,139
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,684
    Local Time:
    7:58 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    which cache you referring to ?
     
  9. ModeltogTossen

    ModeltogTossen I wish I could??

    313
    97
    28
    Dec 20, 2015
    Denmark
    Ratings:
    +143
    Local Time:
    11:58 AM
    1.9.12
    10.0.23
    I my case - when I did flush redis and empty the pagespeed with rm -rf - I got my site back in the air - So Redis and Pagespeed. That suggestion is only made by missing knowledge.

    I did see you posted another post where you updated code with rm -rf on the pagespeed cache directory.
     
  10. eva2000

    eva2000 Administrator Staff Member

    44,406
    10,139
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +15,684
    Local Time:
    7:58 PM
    Nginx 1.17.x
    MariaDB 5.5/10.x
    yeah added pagespeed cache clear on nginx upgrades

    redis is tricky as redis can be used as a cache or as a storage database like mysql, so flushing probably not the best idea