Want to subscribe to topics you're interested in?
Become a Member

Centmin Mod 123.08stable updated to default to PHP 5.5.38

Discussion in 'Centmin Mod News' started by eva2000, Jul 22, 2016.

Thread Status:
Not open for further replies.
  1. eva2000

    eva2000 Administrator Staff Member

    29,022
    6,586
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,776
    Local Time:
    6:17 PM
    Nginx 1.13.x
    MariaDB 5.5

    PHP 5.5.38 Default for 123.08stable



    Centmin Mod 123.08stable has been updated to default to PHP 5.5.38 instead of PHP 5.4.45 in light of HTTPoxy security vulnerability. PHP 5.5.38 has native fix for HTTPoxy as does PHP 5.6.24+ and PHP 7.0.9+. Details of HTTPoxy security vulnerability here.

    As to why PHP 5.5.38 and not 5.6.24 ? Out of box trying to have the widest PHP web app compatibility as possible based on PHP version usage statistics. If you need PHP 5.6.24+ or PHP 7.0.9+, you can run centmin.sh menu option 5 to update to a specified PHP version.

    To update your Centmin Mod builds follow instructions at centminmod.com/upgrade.html and respective version threads below:
    Once updated, run centmin.sh once to allow auto syncing of the changes to your existing server configuration. Then run centmin.sh menu option 5 to upgrade PHP versions if you are still on PHP 5.4.45 or PHP versions below PHP 5.5.38 or below PHP 7.0.9.
     
    Last edited: Jul 22, 2016
    • Like Like x 1
Thread Status:
Not open for further replies.