Join the community today
Become a Member

Upgrade Centmin Error

Discussion in 'Install & Upgrades or Pre-Install Questions' started by Itworx4me, Jan 28, 2019.

  1. Itworx4me

    Itworx4me Premium Member Premium Member

    168
    17
    18
    Mar 14, 2017
    Ratings:
    +22
    Local Time:
    11:42 AM
    Nginx 1.15.X
    MariaDB 10.3.X
    Please fill in any relevant information that applies to you:
    • CentOS Version: CentOS 7 64bit ?
    • Centmin Mod Version Installed: 123.09beta01
    • Nginx Version Installed: 1.15.8
    • PHP Version Installed: 7.2.13
    • MariaDB MySQL Version Installed: i.e. 10.0.x or 10.1.xx or 10.2.xx
    • When was last time updated Centmin Mod code base ? : Every 6 hours
    • Persistent Config: Do you have any persistent config file options set in /etc/centminmod/custom_config.inc ? You can check via this command:
      Code (Text):
      cat /etc/centminmod/custom_config.inc
      

      Post output in CODE tags.
      Code (Text):
      PHP_PGO='y'
      LETSENCRYPT_DETECT='y'
      


    Today when I signed onto centmin from the user prompt it went through this wget update. After the update was finished I get this error now when signing onto centmin: postconf: fatal: parameter inet_interfaces: no local interface found for: IP ADDRESS

    How do I fix this?

    Thanks,
    Itworx4me
     
  2. JoeDer

    JoeDer Premium Member Premium Member

    45
    11
    8
    Feb 22, 2015
    Ratings:
    +31
    Local Time:
    9:42 PM
    Nginx 1.15.x
    MariaDB 10.3.x
    I have the same issue
    Untitled.png
     
  3. eva2000

    eva2000 Administrator Staff Member

    39,800
    8,775
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,508
    Local Time:
    4:42 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    for both of you, who's your web host and web host plan ? linode ?

    Run these command to run centmin.sh in debug mode and saved contents to /root/centminlogs/centmin-debug.txt. wait until you return to command prompt for completion of debug mode
    Code (Text):
    cmupdate
    cd /usr/local/src/centminmod
    echo 24 | bash -x centmin.sh 2>&1 | sed -e "s|$(hostname -f)|hostname|g" -e "s|$(hostname -s)|hostname|g" | tee /root/centminlogs/centmin-debug.txt
    

    then post the contents of /root/centminlogs/centmin-debug.txt to pastebin.com or gist.github.com and share the link here or private message me with the link
     
  4. eva2000

    eva2000 Administrator Staff Member

    39,800
    8,775
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,508
    Local Time:
    4:42 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    also what is output for these commands
    Code (Text):
    cat /proc/sys/net/ipv6/conf/all/disable_ipv6
    

    Code (Text):
    postconf -n inet_protocols
    

    Code (Text):
    ping6 -c4 google.com
    

    for posting code or output from commands to keep the formatting, you might want to use CODE tags for code How to use forum BBCODE code tags :)

    it could be your IPv6 connectivity to your server is messed up - could be something at your web host end too

    you can try rebooting the server to see if IPv6 connectivity is re-established if you had IPv6 working previously.
     
  5. eva2000

    eva2000 Administrator Staff Member

    39,800
    8,775
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,508
    Local Time:
    4:42 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    also Sysadmin - Error when opening CMM menu - postfix ipv6

    you can disable IPv6 support completely if you don't use it

    To disable ipv6 plenty of centos guides http://lmgtfy.com/?q=how+tp+disable+ipv6+on+centos :)

    like
    Or better yet to deal with postfix and system IPv6 set in persistent config file /etc/centminmod/custom_config.inc
    Code (Text):
    DISABLE_IPVSIX='y'
    

    then run centmin.sh menu once and then exit centmin.sh menu
     
  6. Itworx4me

    Itworx4me Premium Member Premium Member

    168
    17
    18
    Mar 14, 2017
    Ratings:
    +22
    Local Time:
    11:42 AM
    Nginx 1.15.X
    MariaDB 10.3.X
     
  7. eva2000

    eva2000 Administrator Staff Member

    39,800
    8,775
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,508
    Local Time:
    4:42 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    @Itworx4me for your error it seems to be IPv4 address related and not IPv6 from debug info you provided via private message it was
    Code (Text):
    postconf: fatal: parameter inet_interfaces: no local interface found for XXX.XXX.XXX.XXX
    

    where XXX.XXX.XXX.XXX is your IPv4 address. network connectivity to your server is an issue. I'd try a simple reboot of server in hopes of network is re-established.
     
  8. eva2000

    eva2000 Administrator Staff Member

    39,800
    8,775
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,508
    Local Time:
    4:42 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    @Itworx4me that IPv4 reported by postconf error = 209.99.64.53 doesn't seem to be registered to your server with hivelocity so probably ok to post publicly
    Code (Text):
    curl -s https://ipinfo.io/209.99.64.53
    {
      "ip": "209.99.64.53",
      "hostname": "209-99-64-53.fwd.datafoundry.com",
      "city": "Austin",
      "region": "Texas",
      "country": "US",
      "loc": "30.3437,-97.7316",
      "postal": "78757",
      "org": "AS40034 Confluence Networks Inc"
    }
    

    but shows up in abuse reports 209.99.64.53 | Confluence Networks Inc. | AbuseIPDB

    so I'd contact your web host and see if they have any ideas why postfix is picking up that IP on your server
     
  9. eva2000

    eva2000 Administrator Staff Member

    39,800
    8,775
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,508
    Local Time:
    4:42 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    @Itworx4me i see the problem i think the subdomain listed in your /etc/hosts points to one of those invalid IPs in it's DNS records
     
  10. eva2000

    eva2000 Administrator Staff Member

    39,800
    8,775
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,508
    Local Time:
    4:42 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    @Itworx4me Seems your problem then if the subdomain in /etc/hosts is same as the main hostname from getting started guide step 1 as main hostname IP is what postfix looks for. The main hostname you setup for getting started guide step 1 should be a hostname/subdomain that isn't currently being used elsewhere and doesn't have a working DNS elsewhere.

    So easiest thing is to change your hostname to something else as outlined in getting started guide step 1 again. Then you may keep that /etc/hosts entry but referencing the updated/changed main hostname/subdomain for your Centmin Mod server.
     
  11. JoeDer

    JoeDer Premium Member Premium Member

    45
    11
    8
    Feb 22, 2015
    Ratings:
    +31
    Local Time:
    9:42 PM
    Nginx 1.15.x
    MariaDB 10.3.x
    Hetzner Cloud CX11
    https://pastebin.com/raw/YvqJAFPC

    Code (Text):
    Input: cat /proc/sys/net/ipv6/conf/all/disable_ipv6
    Output: 1
    

    Code (Text):
    Input: postconf -n inet_protocols
    Output: postconf: fatal: parameter inet_interfaces: no local interface found for ::1
    

    Code (Text):
    Input: ping6 -c4 google.com
    Output: connect: Network is unreachable
    

    Added DISABLE_IPVSIX='y' in /etc/centminmod/custom_config.inc then I run centmin.sh menu and exit centmin.sh menu and I reboot the server but nothing changed.
     
  12. eva2000

    eva2000 Administrator Staff Member

    39,800
    8,775
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,508
    Local Time:
    4:42 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    i'd contact web host to check if IPv6 connectivity is working

    output for
    Code (Text):
    cat /etc/hosts
    
     
  13. JoeDer

    JoeDer Premium Member Premium Member

    45
    11
    8
    Feb 22, 2015
    Ratings:
    +31
    Local Time:
    9:42 PM
    Nginx 1.15.x
    MariaDB 10.3.x
    Ok, I'll do
    Code (Text):
    # Your system has configured 'manage_etc_hosts' as True.
    # As a result, if you wish for changes to this file to persist
    # then you will need to either
    # a.) make changes to the master file in /etc/cloud/templates/hosts.redhat.tmpl
    # b.) change or remove the value of 'manage_etc_hosts' in
    #     /etc/cloud/cloud.cfg or cloud-config from user-data
    #
    # The following lines are desirable for IPv4 capable hosts
    127.0.0.1 my.host.name my
    127.0.0.1 localhost.localdomain localhost
    127.0.0.1 localhost4.localdomain4 localhost4
    
    # The following lines are desirable for IPv6 capable hosts
    ::1 my.host.name my
    ::1 localhost.localdomain localhost
    ::1 localhost6.localdomain6 localhost6
    
     
  14. eva2000

    eva2000 Administrator Staff Member

    39,800
    8,775
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,508
    Local Time:
    4:42 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    Code:
    ::1 my.host.name my
    Remove this entry does it have valid DNS AAAA ipv6 address record? You have similar problem as @Itworx4me both have set /etc/hosts abd the main hostname to same subdomain but probably have incorrect DNS records not pointing to centmin mod server's ip address
     
    • Like Like x 1
  15. eva2000

    eva2000 Administrator Staff Member

    39,800
    8,775
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,508
    Local Time:
    4:42 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    Seems for @Itworx4me it's that his main hostname is behind cloudflare IPs but the IP whois check doesn't say Cloudflare IPs ???

    So fix is almost the same, just remove entry main hostname entry from /etc/hosts.

    Though proper fix is that main hostname Cloudflare DNS entry needs orange cloudflare cloud turned off so it bypasses cloudflare as emails sent from server via Postfix are sent via main hostname domain i.e. @main.hostname.com and as such receiving mail servers need to be able to lookup the PTR reverse of your sending server IP to see if it matches @main.hostname.com as per instructions at Email - Steps to ensure your site/server email doesn't end up in spam inboxes
     
    • Like Like x 1
  16. eva2000

    eva2000 Administrator Staff Member

    39,800
    8,775
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,508
    Local Time:
    4:42 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    FYI @Itworx4me eventual fix was related to related to /etc/hosts setting
    Code (Text):
    127.0.0.1     localhost.localdomain
    

    got him to change to below which is what all my CentOS 7 servers default to.
    Code (Text):
    127.0.0.1   localhost localhost.localdomain localhost4 localhost4.localdomain4
    
     
..