Want more timely Centmin Mod News Updates?
Become a Member

PHP-FPM Can't upgrade PHP?

Discussion in 'Nginx, PHP-FPM & MariaDB MySQL' started by Andrew K, Mar 11, 2016.

  1. Andrew K

    Andrew K New Member

    6
    1
    3
    Feb 28, 2016
    Ratings:
    +2
    Local Time:
    12:45 PM
    Hi, I'm trying to upgrade my PHP to 5.6.19, and I can't seem to get it to upgrade. Please respond ASAP!

    This is a CLEAN INSTALL of Centmin Mod on CentOS 7 x64.

    Thanks.

    LOG:


    Edit: Installed CCACHE fixed it all!
     
    Last edited: Mar 11, 2016
  2. eva2000

    eva2000 Administrator Staff Member

    34,590
    7,653
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +11,770
    Local Time:
    3:45 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    strange ccache should be installed by default during centmin mod install routine !

    what version of centmin mod ? how did you install centmin mod ?
     
  3. Andrew K

    Andrew K New Member

    6
    1
    3
    Feb 28, 2016
    Ratings:
    +2
    Local Time:
    12:45 PM
    I installed Centmin Mod using the one liner curl method. It was the latest stable version (123.08stable) and I thought that it was the problem, so I installed the 123.09LE4 beta version. I planned on using Let'sEncrypt anyways, so that's less work for me :D.
     
    • Informative Informative x 1
  4. eva2000

    eva2000 Administrator Staff Member

    34,590
    7,653
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +11,770
    Local Time:
    3:45 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    i see .. 123.09beta01le4 is a bit dated as alot of 123.09beta01 updates haven't been sync'd there so could of broken things.
     
  5. Andrew K

    Andrew K New Member

    6
    1
    3
    Feb 28, 2016
    Ratings:
    +2
    Local Time:
    12:45 PM
    Ahh, does 123.09beta01 have Let'sEncrypt built in?
     
  6. eva2000

    eva2000 Administrator Staff Member

    34,590
    7,653
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +11,770
    Local Time:
    3:45 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    no it doesn't not yet

    123.09beta01le4 is solely for letsencrypt integration work in progress ignoring any and all 123.09beta01 updated fixes etc right now

    i'll probably do a new 123.09beta01le5 letsencrypt branch to sync 123.09beta01 latest fixes in a few weeks once i sort out all the new changes that arose due to nginx 1.9.11+ dynamic modules changes.
     
  7. Andrew K

    Andrew K New Member

    6
    1
    3
    Feb 28, 2016
    Ratings:
    +2
    Local Time:
    12:45 PM
    Sweet, I'll be upgrading to that ASAP once it comes out!
     
..