Join the community today
Become a Member

Cannot install Nodejs 4.x or higher after centmin installed

Discussion in 'Add Ons' started by Manhhailua, Jul 10, 2016.

  1. eva2000

    eva2000 Administrator Staff Member

    40,276
    8,926
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,746
    Local Time:
    10:29 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    ah nice work (y)
     
  2. pamamolf

    pamamolf Premium Member Premium Member

    3,304
    318
    83
    May 31, 2014
    Ratings:
    +588
    Local Time:
    3:29 PM
    Nginx-1.13.x
    MariaDB 10.1.x
    Does nodejs.sh set nodejs to autostart after server reboot?
     
  3. eva2000

    eva2000 Administrator Staff Member

    40,276
    8,926
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,746
    Local Time:
    10:29 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    no you do that yourself for your nodejs apps
     
  4. pamamolf

    pamamolf Premium Member Premium Member

    3,304
    318
    83
    May 31, 2014
    Ratings:
    +588
    Local Time:
    3:29 PM
    Nginx-1.13.x
    MariaDB 10.1.x
    Yes for the apps i know that i have to do that by myself but node itself doesn't need a startup or it starts when i start my .js script like:

    Code:
    node /path/file.js
    ?
     
  5. eva2000

    eva2000 Administrator Staff Member

    40,276
    8,926
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,746
    Local Time:
    10:29 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    nodejs isn't a daemon or service so there is no startup like nginx/php-fpm services
     
    • Informative Informative x 1
  6. pamamolf

    pamamolf Premium Member Premium Member

    3,304
    318
    83
    May 31, 2014
    Ratings:
    +588
    Local Time:
    3:29 PM
    Nginx-1.13.x
    MariaDB 10.1.x
    How do i update it to a newer version or is it automated using yum update?
     
  7. eva2000

    eva2000 Administrator Staff Member

    40,276
    8,926
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,746
    Local Time:
    10:29 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    normal yum update for the nodejs package
     
  8. Kuro

    Kuro Member

    67
    8
    8
    Feb 8, 2018
    Ratings:
    +12
    Local Time:
    7:29 PM
    1.15.10
    10.3
  9. eva2000

    eva2000 Administrator Staff Member

    40,276
    8,926
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,746
    Local Time:
    10:29 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    backwards compatibility i guess some web apps were specifying specific nodejs version requirements when i created addons/nodejs.sh i.e. Ghost
     
..