Discover Centmin Mod today
Register Now

Cache will not purge on fresh install

Discussion in 'Install & Upgrades or Pre-Install Questions' started by mdwyer6, Sep 16, 2023.

  1. mdwyer6

    mdwyer6 New Member

    3
    1
    3
    Sep 15, 2023
    Ratings:
    +1
    Local Time:
    8:18 AM
    Hi folks, I've just set up a fresh centminmod install with wordpress and SSL. Everything about the install went smoothly but changes made in the wordpress admin panel do not show when signed out of wordpress.

    Things I have tried:
    • Turned on cache purge in nginx helper plugin and set to automatically purge on post updates. I then updated a post to trigger the purge
    • Clicked "Purge Entire Cache" button
    • Restarted nginx from the command line with `nprestart`
    After doing all of the above and waiting 24 hours I still do not see my changes reflected. If I navigate to the specific url of a new page, the page shows as expected but the homepage shows without any of the new posts or theme changes.

    Requesting the home page returns with a 200 status and these relevant headers:
    Code:
    X-Cache:HIT
    X-Cache-2:BYPASS
    
    I'm not sure what else I can do to get the cache to purge? Is there some other caching layer separate from nginx because I think I've exhausted trick to purge it.




    • CentOS Version: CentOS 7 64bit ?
    • Centmin Mod Version Installed: i.e. 123.08stable
    • Nginx Version Installed: 1.24.0
    • PHP Version Installed: 8.1.23
    • MariaDB MySQL Version Installed: 10.3.39-MariaDB
    • When was last time updated Centmin Mod code base ? :past week
    • Persistent Config:
    • Code (Text):
      MARCH_TARGETNATIVE='n'
      
      LETSENCRYPT_DETECT='y'
      
     
  2. eva2000

    eva2000 Administrator Staff Member

    51,705
    11,941
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +18,433
    Local Time:
    10:18 PM
    Nginx 1.25.x
    MariaDB 10.x
    In context of Wordpress caching for centmin.sh menu option 22 wordpress auto installer for Centmin Mod, you have 3 offered wordpress caching options:
    1. Redis Nginx Level Caching - centmin.sh menu option 22 will auto install redis if not detected if you choose this in centmin.sh menu option 22 setup. Otherwise, need to install redis yourself. Best combined with Autoptimize WP plugin + Autoptimize Gzip companion plugin
    2. KeyCDN Cache Enabler for full page static html caching (safest choice for balance of performance and reliability). Best combined with Autoptimize WP plugin + Autoptimize Gzip companion plugin
    3. WP Super Cache for full page static html caching. Best combined with Autoptimize WP plugin + Autoptimize Gzip companion plugin
    4. PHP-FPM Fastcgi_cache full page static HTML guest cache in private development as of writing so not available yet. Best combined with Autoptimize WP plugin + Autoptimize Gzip companion plugin
    Which method did you choose to install/configure?

    Are you really using 123.08stable or 124.00stable or 130.00beta01 version of Centmin Mod?

    Looks from cache status headers to be Redis Nginx level caching? Did you configure nginx-helper for Redis caching?

    Are you using Cloudflare or a CDN in front of Centmin Mod Nginx server?
     
  3. mdwyer6

    mdwyer6 New Member

    3
    1
    3
    Sep 15, 2023
    Ratings:
    +1
    Local Time:
    8:18 AM
    I chose Redis Nginx caching.

    124.00stable.s86

    No looks like I might have done this part wrong

    No.

    Thanks for the help so far. I think from what you've said it sounds like my nginx-helper config is incorrect. Trying to change that now and will report back.
     
    Last edited: Sep 19, 2023