Learn about Centmin Mod LEMP Stack today
Register Now

Xenforo Bug Xenforo prefix with pagespeed?

Discussion in 'Forum software usage' started by Silv3er, Feb 7, 2018.

  1. Silv3er

    Silv3er New Member

    6
    1
    3
    Feb 7, 2018
    Ratings:
    +7
    Local Time:
    4:51 AM
    Nginx 1.13.x
    MariaDB 10.x
    Hello, I recently install pagespeed on my xenforo, and once in 4 when I want to edit a prefix, the prefix puts it behind the edit popup, this problem I had not before the installation of pagespeed.

    [​IMG]

    And when I'm lucky the selector is normal

    [​IMG]

    I tried to add,

    Code:
    pagespeed Disallow *edit*;
    but that does not change anything:cautious:

    Ps: and the config pagespeed I used this one: Nginx PageSpeed - This forum's pagespeed.conf

    @eva2000 ?:oops:


    Thanks
     
  2. eva2000

    eva2000 Administrator Staff Member

    33,733
    7,466
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +11,479
    Local Time:
    6:51 PM
    Nginx 1.13.x
    MariaDB 5.5
    You'd have to troubleshoot and tweak it yourself following these guides and info outlined below
    Use chrome devtools network tab to see what is loaded when you are on edit page and look at js and css files as possible candidates for exclusion (disallow) from ngx_pagespeed
     
    • Informative Informative x 1
  3. Silv3er

    Silv3er New Member

    6
    1
    3
    Feb 7, 2018
    Ratings:
    +7
    Local Time:
    4:51 AM
    Nginx 1.13.x
    MariaDB 10.x
    Thank you very much I managed to solve(y)
     
  4. eva2000

    eva2000 Administrator Staff Member

    33,733
    7,466
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +11,479
    Local Time:
    6:51 PM
    Nginx 1.13.x
    MariaDB 5.5
    which was the culprit ?
     
  5. Silv3er

    Silv3er New Member

    6
    1
    3
    Feb 7, 2018
    Ratings:
    +7
    Local Time:
    4:51 AM
    Nginx 1.13.x
    MariaDB 10.x
    I saw in the query that css.php?css=title_prefix_edit was called when I click on edit via the thread tools

    So I added
    Code:
    pagespeed Disallow */css.php?css=title_prefix_edit*;
     
    • Informative Informative x 2
..