Want to subscribe to topics you're interested in?
Become a Member

Linode Boot Failure on Linode

Discussion in 'Virtual Private Server (VPS) hosting' started by BoostN, Dec 3, 2017.

  1. BoostN

    BoostN Member

    93
    18
    8
    Aug 19, 2014
    Ratings:
    +22
    Local Time:
    3:12 AM
    1.11.1
    10.0.28
    Looks like my disk has crashed. Currently trying to restore to a backup:

    UDF-fs: warning (device sda): udf_fill_super: No partition found (2)^M
    gfs2: gfs2 mount does not exist^M
    List of all partitions:^M
    0100 4096 ram0 (driver?)^M
    0101 4096 ram1 (driver?)^M
    0102 4096 ram2 (driver?)^M
    0103 4096 ram3 (driver?)^M
    0104 4096 ram4 (driver?)^M
    0105 4096 ram5 (driver?)^M
    0106 4096 ram6 (driver?)^M
    0107 4096 ram7 (driver?)^M
    0108 4096 ram8 (driver?)^M
    0109 4096 ram9 (driver?)^M
    010a 4096 ram10 (driver?)^M
    010b 4096 ram11 (driver?)^M
    010c 4096 ram12 (driver?)^M
    010d 4096 ram13 (driver?)^M
    010e 4096 ram14 (driver?)^M
    010f 4096 ram15 (driver?)^M
    0810 528384 sdb driver: sd^M
    0800 49811456 sda driver: sd^M
    No filesystem could mount root, tried: reiserfs^M
    ext3 ext4^M
    ext2 cramfs^M
    squashfs vfat^M
    iso9660 romfs^M
    fuseblk udf^M
    jfs xfs^M
    gfs2 gfs2meta^M
    btrfs^M
    Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(8,0)^M
    CPU: 0 PID: 1 Comm: swapper/0 Not tainted 4.9.50-x86_64-linode86 #1^M
    Hardware name: QEMU Standard PC (i440FX + PIIX, 1996), BIOS rel-1.9.1-0-gb3ef39f-prebuilt.qemu-project.org 04/01/2014^M
    0000000000000000 ffffffff816b57f5 ffffffffffffff00 ffffc9000062fe80^M
    ffffffff811bf1dc 0000000000000010 ffffc9000062fe90 ffffc9000062fe28^M
    ffffc9000062fe80 ffffc9000062fe98 0000000000000012 0000000000000001^M
    Call Trace:^M
    [<ffffffff816b57f5>] ? dump_stack+0x5c/0x77^M
    [<ffffffff811bf1dc>] ? panic+0xd9/0x21d^M
    [<ffffffff8239c3ce>] ? mount_block_root+0x208/0x238^M
    [<ffffffff8239c620>] ? mount_root+0xff/0x108^M
    [<ffffffff8239d231>] ? initrd_load+0x2de/0x2e5^M
    [<ffffffff8239c791>] ? prepare_namespace+0x168/0x19e^M
    [<ffffffff8239c0b2>] ? kernel_init_freeable+0x204/0x212^M
    [<ffffffff81baf8e0>] ? rest_init+0x80/0x80^M
    [<ffffffff81baf8ea>] ? kernel_init+0xa/0x100^M
    [<ffffffff81bb5e85>] ? ret_from_fork+0x25/0x30^M

    Anyone seen this? Been running for 80 ~ days since a mandatory reboot from the migration (I believe that was it)
     
  2. eva2000

    eva2000 Administrator Staff Member

    30,960
    6,918
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,419
    Local Time:
    7:12 PM
    Nginx 1.13.x
    MariaDB 5.5
    looks like a kernel panic ? what was Linode specs and OS ? CentOS 6 or 7 ? What does Linode tech support say ?
     
  3. BoostN

    BoostN Member

    93
    18
    8
    Aug 19, 2014
    Ratings:
    +22
    Local Time:
    3:12 AM
    1.11.1
    10.0.28
    The output is from them.

    His quote:
    I did that, and it failed from what I remember late last night. So, I resized it larger and restored a 6 day old backup because the automatic one was 2 twice the size oddly enough.

    upload_2017-12-3_10-21-10.png

    And it looks like the backup that was taken this morning is also a lot larger than the backups before the failure.

    This was on a CentOS 6.5, running Centminmod on a Linode 4096 plan.. This server/site has been going for a long time without issues.

    I'm actually building out a new CMM install on a CentOS 7.0 right now to get away from this one. I think I'm going to have more problems if I don't.
     
    Last edited: Dec 4, 2017
  4. BoostN

    BoostN Member

    93
    18
    8
    Aug 19, 2014
    Ratings:
    +22
    Local Time:
    3:12 AM
    1.11.1
    10.0.28
    Also, I push my backups to S3.. and thank goodness. I was able to restore the Linode to the "6 day old" backup, and then just update my media folder and database to the latest and not lose much/if any data.
     
  5. BoostN

    BoostN Member

    93
    18
    8
    Aug 19, 2014
    Ratings:
    +22
    Local Time:
    3:12 AM
    1.11.1
    10.0.28
    I think they might have something wrong with the backup service. I got this message today for a different account I manage for a Magento install.

    Oddly enough, my site when down when the backup job ran and then it failed.
     
  6. eva2000

    eva2000 Administrator Staff Member

    30,960
    6,918
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,419
    Local Time:
    7:12 PM
    Nginx 1.13.x
    MariaDB 5.5
    yeah linode status page mentioned something about backup issues as well

    have you asked linode why that might be the case ?