Learn about Centmin Mod LEMP Stack today
Become a Member

-bash: centmin: command not found

Discussion in 'Bug Reports' started by Kuro, Mar 15, 2019 at 10:53 PM.

  1. Kuro

    Kuro Member

    31
    3
    8
    Feb 8, 2018
    Ratings:
    +4
    Local Time:
    2:10 AM
    1.13.9
    10.x
    I have just installed CENTMINMOD for a new VPS
    Command:
    Code:
    yum -y update; curl -O https://centminmod.com/betainstaller73.sh && chmod 0700 betainstaller73.sh && bash betainstaller73.sh
    But i can't acesss to bash "-bash: centmin.sh: command not found"

    My previous VPS was suddenly like that last week and it caused my site to get 503 error. I fixed it with this article: [Solved] - Centmin Errors But this new VPS is not possible.

    upload_2019-3-15_19-47-2.png
    • CentOS Version: CentOS 7 64bit
    • Centmin Mod Version Installed: 123.09beta01
    • Nginx Version Installed: 1.15.9
    • And I'm using Cloudflare and Digital Ocean VPS

    • PHP Version Installed: 7.3.3
    • MariaDB MySQL Version Installed: i.e. 10.0.x or 10.1.xx or 10.2.xx

     
  2. eva2000

    eva2000 Administrator Staff Member

    38,511
    8,487
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,050
    Local Time:
    5:10 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    To troubleshoot initial installation, you need to check the initial install log at /root/centminlogs and instructions under Sharing logs and errors heading for using Pastebin.com or Gists to share a sanitised version of the contents of the initial install log. You can see full details at How to troubleshoot Centmin Mod initial install issues

    Example for 123.09beta01 and newer list /root/centminlogs files in date ascending order and grep for installer_*
    Code (Text):
    ls -lahrt /root/centminlogs | grep installer_*
    

    example output returns install log at /root/centminlogs both a the full log and minimal log (smaller in size with some stuff filtered out)
    Code (Text):
    ls -lahrt /root/centminlogs | grep installer_*
    -rw-r--r-- 1 root root 4.3M Jul 12 09:06 installer_120718-083445.log
    -rw-r--r-- 1 root root 826K Jul 12 10:20 installer_120718-083445_minimal.log
    


    Example for 123.08stable list /root/centminlogs files in date ascending order and grep for install.log
    Code (Text):
    ls -lahrt /root/centminlogs | grep install.log
    

    example output returns install log at /root/centminlogs/centminmod_1.2.3-eva2000.09.001_111016-112321_install.log
    Code (Text):
    ls -lahrt /root/centminlogs | grep install.log
    -rw-r--r--  1 root root 2.2M Oct 11 01:40 centminmod_1.2.3-eva2000.09.001_111016-112321_install.log
    

    in SSH use cat to ouput contents of /root/centminlogs/centminmod_1.2.3-eva2000.09.001_111016-112321_install.log. Clear your SSH client window/buffer so only output is the contents of the file

    for 123.08stable
    Code (Text):
    cat /root/centminlogs/centminmod_1.2.3-eva2000.09.001_111016-112321_install.log
    

    for 123.09beta01 and newer
    Code (Text):
    cat /root/centminlogs/installer_120718-083445_minimal.log
    


    Then copy and paste into Pastebin.com or Gists entry. If your SSH window scroll buffer isn't that large to get the whole contents of the install log, you can download file manually and copy and paste contents. But makes sure it's sanitised version of the contents of the initial install log as outlined at How to troubleshoot Centmin Mod initial install issues
     
  3. Kuro

    Kuro Member

    31
    3
    8
    Feb 8, 2018
    Ratings:
    +4
    Local Time:
    2:10 AM
    1.13.9
    10.x
  4. eva2000

    eva2000 Administrator Staff Member

    38,511
    8,487
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,050
    Local Time:
    5:10 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    seems only part of the install log was uploaded. You can try compressing the log for upload

    Code (Text):
    cd /root/centminlogs
    pigz -9k installer_150319-104330.txt
    

    then upload the compressed version installer_150319-104330.txt.gz
     
    • Like Like x 1
  5. Kuro

    Kuro Member

    31
    3
    8
    Feb 8, 2018
    Ratings:
    +4
    Local Time:
    2:10 AM
    1.13.9
    10.x
    But it is over. I will try it again.
     
  6. Kuro

    Kuro Member

    31
    3
    8
    Feb 8, 2018
    Ratings:
    +4
    Local Time:
    2:10 AM
    1.13.9
    10.x
    yes, it seems my vps suddenly lost its connection when installing.

    upload_2019-3-15_20-47-33.png
     
  7. eva2000

    eva2000 Administrator Staff Member

    38,511
    8,487
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,050
    Local Time:
    5:10 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    Sounds like your droplet vps server network connectivity issues.. so would explain your problems. Are you just reloading fresh CentOS 7 OS on same droplet or creating a new droplet ? Could be issues specific to your droplet seeing as it is using older Intel E5-2630Lv2 IvyBridge cpus. Maybe try launching a droplet in a different datacenter / region ?

    I'd check with digitalocean support to see if there's any know issues or outages - which DO region / datacenter you're in ? Check DigitalOcean Status ?

    I have been doing 100s of centmin mod installs on DigitalOcean nyc3 and sfo2 past few days without issues for DO Marketplace testing/prep.
     
..