Join the community today
Become a Member

autoreconf not found

Discussion in 'Install & Upgrades or Pre-Install Questions' started by GASTAN, Jun 4, 2018.

  1. GASTAN

    GASTAN New Member

    8
    2
    3
    Jun 28, 2017
    Ratings:
    +2
    Local Time:
    6:40 PM
    I got following error on fresh 123.09beta01 install on CentOS 7 64bit (XenServer)

    Code:
    Download axel-2.14.1.tar.gz ...
    Axel 2.14.1 Archive found, skipping download...
    axel-2.14.1.tar.gz valid file.
    
    ./autogen.sh: line 51: autoreconf: command not found
    We have a problem...
    betainstaller.sh: line 1068: ./configure: No such file or directory
    
     
  2. eva2000

    eva2000 Administrator Staff Member

    34,632
    7,655
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +11,773
    Local Time:
    2:40 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    You'll need to post on the forums with the following info
    • Server or VPS details ? XEN, KVM, OpenVZ, VMWare or dedicated server ? OS ? CentOS 6.9 or 7.4 ? 32bit or 64bit ?
    • What version of Centmin Mod ? .07 stable or 08 stable or .09 beta01 or another branch version ?
    • Was it fresh install or upgrade ?
    • Method of install ? Via centmin.sh menu option 1, Git install or curl one liner install as outlined at centminmod.com/download.html ?
    • How long ago did you install Centmin Mod ?
    • There's numerous code changes, bug fixes over time, so ensure you have latest Centmin Mod code installed by upgrading your Centmin Mod code as instructed below.

    Troubleshooting Initial Install



    To troubleshoot initial installation, you need to check the initial install log at /root/centminlogs and instructions under Sharing logs and errors heading for using Pastebin.com or Gists to share a sanitised version of the contents of the initial install log. You can see full details at How to troubleshoot Centmin Mod initial install issues

    Example list /root/centminlogs files in date ascending order and grep for install.log
    Code (Text):
    ls -lahrt /root/centminlogs | grep install.log
    

    example output returns install log at /root/centminlogs/centminmod_1.2.3-eva2000.09.001_111016-112321_install.log
    Code (Text):
    ls -lahrt /root/centminlogs | grep install.log
    -rw-r--r--  1 root root 2.2M Oct 11 01:40 centminmod_1.2.3-eva2000.09.001_111016-112321_install.log
    

    in SSH use cat to ouput contents of /root/centminlogs/centminmod_1.2.3-eva2000.09.001_111016-112321_install.log. Clear your SSH client window/buffer so only output is the contents of the file
    Code (Text):
    cat /root/centminlogs/centminmod_1.2.3-eva2000.09.001_111016-112321_install.log
    

    Then copy and paste into Pastebin.com or Gists entry. If your SSH window scroll buffer isn't that large to get the whole contents of the install log, you can download file manually and copy and paste contents. But makes sure it's sanitised version of the contents of the initial install log as outlined at How to troubleshoot Centmin Mod initial install issues
     
  3. GASTAN

    GASTAN New Member

    8
    2
    3
    Jun 28, 2017
    Ratings:
    +2
    Local Time:
    6:40 PM
    I made new VM and did fresh oneliner 123.09beta01 install on CentOS 7 64bit (XenServer) today. It finished seemingly well, but I cannot start nginx.
    I found suggestion here, on forums to recompile nginx and php (4,5) but it did not help.
    error is still the same, without change:

    Code:
    systemctl status nginx.service
    ‚óŹ nginx.service - SYSV: Nginx is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3 proxy server
       Loaded: loaded (/etc/rc.d/init.d/nginx; bad; vendor preset: disabled)
       Active: failed (Result: exit-code) since Wed 2018-06-06 09:38:43 UTC; 8s ago
         Docs: man:systemd-sysv-generator(8)
      Process: 5376 ExecStart=/etc/rc.d/init.d/nginx start (code=exited, status=5)
    
    Jun 06 09:38:43 CentOS7 systemd[1]: Starting SYSV: Nginx is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3 proxy server...
    Jun 06 09:38:43 CentOS7 systemd[1]: nginx.service: control process exited, code=exited status=5
    Jun 06 09:38:43 CentOS7 systemd[1]: Failed to start SYSV: Nginx is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3 proxy server.
    Jun 06 09:38:43 CentOS7 systemd[1]: Unit nginx.service entered failed state.
    Jun 06 09:38:43 CentOS7 systemd[1]: nginx.service failed.
    
     
  4. eva2000

    eva2000 Administrator Staff Member

    34,632
    7,655
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +11,773
    Local Time:
    2:40 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    need the initial install log and info asked and outlined in 2nd post of this thread
     
..