Welcome to Centmin Mod Community
Register Now

Wordpress autoprotect is driving me crazy

Discussion in 'Blogs & CMS usage' started by EckyBrazzz, Apr 26, 2019.

  1. EckyBrazzz

    EckyBrazzz Active Member

    230
    40
    28
    Mar 28, 2018
    Brazil
    Ratings:
    +78
    Local Time:
    2:28 PM
    1.15.x
    10.3.x
    Hi,

    On several sites, I ran into trouble due to the autoprotect function.
    I want to use it, but I can't find a kind of manual on how to configure it.

    Is there a link available that I can't find? Already tried to search the forum, but couldn't find anything useful.
     
  2. eva2000

    eva2000 Administrator Staff Member

    39,758
    8,769
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,494
    Local Time:
    3:28 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    When you create centmin.sh menu option 2 or 22 nginx vhosts, the important info section at start of nginx creation will link show a link and info directly to autoprotect how to thread at https://community.centminmod.com/threads/11215/

    Code (Text):
    echo "403 Permission denied message handling"
    echo "if after vhost site setup you encounter 403 permission denied errors,"
    echo "check https://community.centminmod.com/threads/11215/ to see if your"
    echo "site needs tools/autoprotect.sh tweaking & whitelisting"
    


    If on Centmin Mod 123.09beta01, you may have ran into the new tools/autoprotect.sh cronjob feature outlined at Beta Branch - autoprotect.sh - apache .htaccess check & migration to nginx deny all | Centmin Mod Community You uploaded scripts may have .htaccess deny from all type files in their directories which may need bypassing autoprotect. It's a security feature that no other nginx based stack has as far as I know :)

    So instead, all .htaccess 'deny from all' detected directories now get auto generated Nginx equivalent location match and deny all setups except if you want to manually bypass the directory from auto protection via a .autoprotect-bypass file - details below here.

    You can read a few threads below on how autoprotect.sh may have caught some folks web apps falsely and the workarounds or improvements made to autoprotect.sh with the help of users feedback and troubleshooting.
    Check if your nginx vhost at either or both /usr/local/nginx/conf/conf.d/domain.com.conf and/or /usr/local/nginx/conf/conf.d/domain.com.ssl.conf has include file for autoprotect example
    Code (Text):
    include /usr/local/nginx/conf/autoprotect/domain.com/autoprotect-domain.com.conf;
    

    see if your directory for the script which has issues is caught in an autoprotect include entry in /usr/local/nginx/conf/autoprotect/domain.com/autoprotect-domain.com.conf which has a deny all entry
    Code (Text):
    cat /usr/local/nginx/conf/autoprotect/domain.com/autoprotect-domain.com.conf
    

    i.e.
    Code (Text):
    # /home/nginx/domains/domain.com/public/subdirectory/js
    location ~* ^/subdirectory/js/ { allow 127.0.0.1; deny all; }
    

    If caught you can whitelist it by autoprotect bypass .autoprotect-bypass file - details below here. So if problem js file is at domain.com/subdirectory/js/file.js then it is likely /subdirectory/js has a .htaccess with deny all in it - make sure that directory is meant to be publicly accessible by contacting author of script and if so, you can whitelist it and re-run autoprotect script to regenerate your /usr/local/nginx/conf/autoprotect/domain.com/autoprotect-domain.com.conf include file
    Code (Text):
    cd /home/nginx/domains/domain.com/public/subdirectory/js
    touch .autoprotect-bypass
    /usr/local/src/centminmod/tools/autoprotect.sh
    nprestart
    

    it maybe you need to also whitelist /subdirectory then it would be as follows creating bypass files at /home/nginx/domains/domain.com/public/subdirectory/.autoprotect-bypass and /home/nginx/domains/domain.com/public/subdirectory/js/.autoprotect-bypass
    Code (Text):
    cd /home/nginx/domains/domain.com/public/subdirectory/
    touch .autoprotect-bypass
    cd /home/nginx/domains/domain.com/public/subdirectory/js
    touch .autoprotect-bypass
    /usr/local/src/centminmod/tools/autoprotect.sh
    nprestart
    

    then double check to see if updated /usr/local/nginx/conf/autoprotect/domain.com/autoprotect-domain.com.conf include file now doesn't show an entry for /subdirectory/js
     
  3. EckyBrazzz

    EckyBrazzz Active Member

    230
    40
    28
    Mar 28, 2018
    Brazil
    Ratings:
    +78
    Local Time:
    2:28 PM
    1.15.x
    10.3.x
    Well, now I using a site and want to upload a image.

    Code (Text):
    { allow 127.0.0.1; deny all; }
    


    Code (Text):
    location ~* ^/wp-content/uploads/wpseo-redirects/ { allow 127.0.0.1; deny all; }


    Should I add my own IP to prevent this issue ? Because it give me trouble inside the wp-admin

    Code (Text):
    location ~* ^/wp-content/uploads/wpseo-redirects/ { allow 127.0.0.1; allow xxx.xxx.xxx.xxx; deny all; }

    should resolve it ?
     
  4. eva2000

    eva2000 Administrator Staff Member

    39,758
    8,769
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,494
    Local Time:
    3:28 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    what trouble specifically ?

    is that /wp-content/uploads/wpseo-redirects/ location listed in the generated
    /usr/local/nginx/conf/autoprotect/domain.com/autoprotect-domain.com.conf include file ? if not then it isn't autoprotect.sh related but for 403 wp plugin whitelist related Wordpress - Wordpress 403 Permission Denied Errors in related to your /usr/local/nginx/conf/wpincludes/${vhostname}/wpsecure_${vhostname}.conf include file
     
  5. EckyBrazzz

    EckyBrazzz Active Member

    230
    40
    28
    Mar 28, 2018
    Brazil
    Ratings:
    +78
    Local Time:
    2:28 PM
    1.15.x
    10.3.x
    It does not accept uploads

    Well, the plugin is the WPML Multilingual CMS for developers and agencies with lifetime updates and unlimited domains. They don't sell it anymore in this form and when I bought it was very expensive.

    It has nothing to do with the autoprotect as far as I can see. I even disabled it to be sure about it. It creates an upload dir called flags and has 755. I want to upload the beautiful flag Flag_of_Australia_.png but it simply won't allow me to do so. I also manually uploaded all the flags that I need but the result keeps the same.

    After pressing SAVE the page does not load completely but hangs at 50%. On my other hosting panel it does not give any problem and saves all the flags that I need. As example you can see it here that it works normaly fine. Screenshot_6.png

    Don't take it badly, but many times when posting your answer in the post that has several links, and these links have new links to other solutions and so on. Well, at the end I have many pages open and can't find the correct answer. It's a kind of confusing. But again, don't take it bad.

    I just want to resolve this issue. Already had so many issues, my theme does not allow to use the wp-cli because it wipes all theme settings and I realy like Centmin Mod, hee, I'm still here :)
     
  6. EckyBrazzz

    EckyBrazzz Active Member

    230
    40
    28
    Mar 28, 2018
    Brazil
    Ratings:
    +78
    Local Time:
    2:28 PM
    1.15.x
    10.3.x
    @eva2000 Sorry about my comments about the links. I know that they are useful, but it's my mistake or better said my failure because of the hours I spent on my different work projects. I work 24/7 and sometimes, at least when my mind allows it I work 36 hours non-stop. My wife tells me that my average is around 21/7 a week so again, my excuse if I offended you. Sometimes I really need some rest but I simply ignore the signals that my body gives that it's time to stop working.

    Well, gonna calm down a bit and try to resolve case per case. I am involved in many projects at the same time.

    Anyhow, I gonna fix the time you spend with your great work as a donation when I'm done setting up this new part of my business. We all work to make a living.

    Final conclusion: It was not Wordpress autoprotect is driving me crazy but my stupid mind. Case closed, learned a lesson. Never to old to learn something new.
     
    • Informative Informative x 1
  7. Jimmy

    Jimmy Premium Member Premium Member

    1,528
    316
    83
    Oct 24, 2015
    East Coast USA
    Ratings:
    +779
    Local Time:
    1:28 PM
    1.15.x
    MariaDB 10.3.x
     
    • Funny Funny x 2
  8. eva2000

    eva2000 Administrator Staff Member

    39,758
    8,769
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,494
    Local Time:
    3:28 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    Much appreciated. Yeah we're all juggling many things - just be careful especially on SSH command line :)
     
  9. EckyBrazzz

    EckyBrazzz Active Member

    230
    40
    28
    Mar 28, 2018
    Brazil
    Ratings:
    +78
    Local Time:
    2:28 PM
    1.15.x
    10.3.x
    Well, this issue is still not resolved. I know it's not the autoprotect but I have set WordPress to into debugging

    Any Ideas ?
     
  10. eva2000

    eva2000 Administrator Staff Member

    39,758
    8,769
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,494
    Local Time:
    3:28 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    simple question are file and directory permissions correct at
    • /home/nginx/domains/domain.com/public/wp-content/plugins/sitepress-multilingual-cms/res/flags/
    • /home/nginx/domains/domain.com/public/wp-content/plugins/sitepress-multilingual-cms/res/
    • /home/nginx/domains/domain.com/public/wp-content/plugins/sitepress-multilingual-cms/
    they would need to be owned by nginx user/group and if you're uploading flags to same directories they would need write permissions too

    you can check their permissions via
    Code (Text):
    ls -alh /home/nginx/domains/domain.com/public/wp-content/plugins/sitepress-multilingual-cms/res/flags/
    ls -alh /home/nginx/domains/domain.com/public/wp-content/plugins/sitepress-multilingual-cms/res/
    ls -alh /home/nginx/domains/domain.com/public/wp-content/plugins/sitepress-multilingual-cms/
    


    if there's .php php extension file in those directories that needs to be executed then it falls under wordpress plugin whitelist 403 protection outlined at https://community.centminmod.com/threads/wordpress-403-permission-denied-errors.11215/ so need to modify your /usr/local/nginx/conf/wpincludes/${vhostname}/wpsecure_${vhostname}.conf where ${vhostname} is your domain name and add a new nginx rule to whitelist the wp plugin (giving you finer grain control over what wp plugins with php scripts in the wp plugin directory can be run on your server)

    example
    Code (Text):
      location ~ ^/wp-content/plugins/sitepress-multilingual-cms/(.+/)?(.+)\.(css|js)$ { allow all; }
      location ~ ^/wp-content/plugins/sitepress-multilingual-cms/(.+/)?(.+)\.(png|gif)$ { allow all; }
      location ~* /wp-content/plugins/sitepress-multilingual-cms/.*\.php$ {
        include /usr/local/nginx/conf/php.conf;
        allow 127.0.0.1;
        deny all;
      }
    
     
  11. EckyBrazzz

    EckyBrazzz Active Member

    230
    40
    28
    Mar 28, 2018
    Brazil
    Ratings:
    +78
    Local Time:
    2:28 PM
    1.15.x
    10.3.x
    Well, permission are correct and the suggestion to add

    Code (Text):
      location ~ ^/wp-content/plugins/sitepress-multilingual-cms/(.+/)?(.+)\.(css|js)$ { allow all; }
      location ~ ^/wp-content/plugins/sitepress-multilingual-cms/(.+/)?(.+)\.(png|gif)$ { allow all; }
      location ~* /wp-content/plugins/sitepress-multilingual-cms/.*\.php$ {
       include /usr/local/nginx/conf/php.conf;
       allow 127.0.0.1;
       deny all;
      }
    


    Did not resolve it. Struggling several week with this and until now I couldn't resolve it.

    To bad, because on other servers I don't have this problem, see images below NL-FLAGS.png

    And the other sites that are not on CMM

    PT_Flags.png
     
  12. eva2000

    eva2000 Administrator Staff Member

    39,758
    8,769
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,494
    Local Time:
    3:28 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    you can verify if it's related to /usr/local/nginx/conf/wpincludes/${vhostname}/wpsecure_${vhostname}.conf include file security restrictions by temporarily disabling /usr/local/nginx/conf/wpincludes/${vhostname}/wpsecure_${vhostname}.conf include file by commenting it out with hash in your nginx vhost and restarting nginx/php-fpm
     
  13. eva2000

    eva2000 Administrator Staff Member

    39,758
    8,769
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,494
    Local Time:
    3:28 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    also order of placement of the suggested code in /usr/local/nginx/conf/wpincludes/${vhostname}/wpsecure_${vhostname}.conf matters too, so probably best to post the contents of your /usr/local/nginx/conf/wpincludes/${vhostname}/wpsecure_${vhostname}.conf in CODE tags here too
     
  14. EckyBrazzz

    EckyBrazzz Active Member

    230
    40
    28
    Mar 28, 2018
    Brazil
    Ratings:
    +78
    Local Time:
    2:28 PM
    1.15.x
    10.3.x
    Well, placed it as the last one after all the defaults, and already disabled the autoprotect for testing as mentioned in an earlier post.

    Just a tail of the file to see where I placed the exception.
    Code:
    # Whitelist Exception for https://wordpress.org/plugins/better-wp-security/
    location ~ ^/wp-content/plugins/better-wp-security/ {
      include /usr/local/nginx/conf/php.conf;
      include /usr/local/nginx/conf/staticfiles.conf;
      # below include file needs to be manually created at that path and to be uncommented
      # by removing the hash # in front of below line to take effect. This wpwhitelist_common.conf
      # allows you to add commonly shared settings to all wp plugin location matches which
      # whitelist php processing access at /usr/local/nginx/conf/wpincludes/${vhostname}/wpsecure_${vhostname}.conf
      #include /usr/local/nginx/conf/wpincludes/${vhostname}/wpwhitelist_common.conf;
    }
    
    # Whitelist Exception for http://wlmsocial.com/
    location ~ ^/wp-content/plugins/wlm-social/ {
      include /usr/local/nginx/conf/php.conf;
      include /usr/local/nginx/conf/staticfiles.conf;
      # below include file needs to be manually created at that path and to be uncommented
      # by removing the hash # in front of below line to take effect. This wpwhitelist_common.conf
      # allows you to add commonly shared settings to all wp plugin location matches which
      # whitelist php processing access at /usr/local/nginx/conf/wpincludes/${vhostname}/wpsecure_${vhostname}.conf
      #include /usr/local/nginx/conf/wpincludes/${vhostname}/wpwhitelist_common.conf;
    }
    
    # Whitelist Exception for mediagrid timthumb
    location ~ ^/wp-content/plugins/media-grid/classes/ {
      include /usr/local/nginx/conf/php.conf;
      include /usr/local/nginx/conf/staticfiles.conf;
      # below include file needs to be manually created at that path and to be uncommented
      # by removing the hash # in front of below line to take effect. This wpwhitelist_common.conf
      # allows you to add commonly shared settings to all wp plugin location matches which
      # whitelist php processing access at /usr/local/nginx/conf/wpincludes/${vhostname}/wpsecure_${vhostname}.conf
      #include /usr/local/nginx/conf/wpincludes/${vhostname}/wpwhitelist_common.conf;
    }
    
    # Whitelist Exception for sitepress-multilingual-cms
      location ~ ^/wp-content/plugins/sitepress-multilingual-cms/(.+/)?(.+)\.(css|js)$ { allow all; }
      location ~ ^/wp-content/plugins/sitepress-multilingual-cms/(.+/)?(.+)\.(png|gif)$ { allow all; }
      location ~* /wp-content/plugins/sitepress-multilingual-cms/menu/.*\.php$ {
        include /usr/local/nginx/conf/php.conf;
        allow 127.0.0.1;
        deny all;
      }
    
    # Block PHP files in content directory.
    location ~* /wp-content/.*\.php$ {
      deny all;
    }
    
    # Block PHP files in includes directory.
    location ~* /wp-includes/.*\.php$ {
      deny all;
    }
    
    # Block PHP files in uploads, content, and includes directory.
    location ~* /(?:uploads|files|wp-content|wp-includes)/.*\.php$ {
      deny all;
    }
    
    # Make sure files with the following extensions do not get loaded by nginx because nginx would display the source code, and these files can contain PASSWORDS!
    location ~* \.(engine|inc|info|install|make|module|profile|test|po|sh|.*sql|theme|tpl(\.php)?|xtmpl)$|^(\..*|Entries.*|Repository|Root|Tag|Template)$|\.php_
    {
    return 444;
    }
    
    location ~* \.(tpl)$
    {
      deny all;
    }
    
    #nocgi
    location ~* \.(pl|cgi|py|sh|lua)$ {
    return 444;
    }
    
    #disallow
    location ~* (w00tw00t) {
    return 444;
    }
    
    location ~* /(\.|wp-config\.php|wp-config\.txt|changelog\.txt|readme\.txt|readme\.html|license\.txt) { deny all; }
    location ~* /(wp-content)/(.*?)\.(zip|gz|tar|bzip2|7z|txt)$ { deny all; }
     
  15. eva2000

    eva2000 Administrator Staff Member

    39,758
    8,769
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,494
    Local Time:
    3:28 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    what if you remove
    Code (Text):
       allow 127.0.0.1;
       deny all;
    
     
  16. EckyBrazzz

    EckyBrazzz Active Member

    230
    40
    28
    Mar 28, 2018
    Brazil
    Ratings:
    +78
    Local Time:
    2:28 PM
    1.15.x
    10.3.x
    Code (Text):
    # Whitelist Exception for sitepress-multilingual-cms
      location ~ ^/wp-content/plugins/sitepress-multilingual-cms/(.+/)?(.+)\.(css|js)$ { allow all; }
      location ~ ^/wp-content/plugins/sitepress-multilingual-cms/(.+/)?(.+)\.(png|gif)$ { allow all; }
      location ~* /wp-content/plugins/sitepress-multilingual-cms/menu/.*\.php$ {
        include /usr/local/nginx/conf/php.conf;
    #    allow 127.0.0.1;
    #    deny all;
      }
    


    Did not resolve the issue.

    Still got this error:
     
  17. eva2000

    eva2000 Administrator Staff Member

    39,758
    8,769
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,494
    Local Time:
    3:28 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    what code are lines 400-401 of edit-languages.php referencing ?

    though this thread consider it a file/directory permissions issue
    https://wpml.org/forums/topic/i-jus...get-a-few-php-errors-and-flags-are-not-shown/

    but this one mentions php fileinfo extension missing https://wpml.org/forums/topic/cant-upload-custom-flag-for-new-languages/ and Centmin Mod doesn't install php fileinfo extension by default on lower memory systems due to compile time and memory requirements (>1.8GB of memory) for source compiles, you can check if it's loaded via ssh command
    Code (Text):
    php --ri fileinfo

    if not installed/loaded
    Code (Text):
    php --ri fileinfo
    Extension 'fileinfo' not present.
    

    if loaded/installed
    Code (Text):
    php --ri fileinfo
    
    fileinfo
    
    fileinfo support => enabled
    libmagic => 533
    

    how much memory does your server have, see via command
    Code (Text):
    free -ml

    If you have less than 1GB memory, Centmin Mod usually tries to add a swap file on disk if you have less than 512MB allocated to current swap disk and create a 1GB swap file so you can compile php fileinfo extension. You can try setting PHPFINFO='y' by setting in persistent config file /etc/centminmod/custom_config.inc the following
    Code (Text):
    PHPFINFO='y'

    or by forcing PHP Fileinfo extension install by setting in persistent config file /etc/centminmod/custom_config.inc the following which will force PHPFINFO='y' if you have less than 1GB of memory but have greater than 1GB swap disk - basically forcing PHP Fileinfo to compile and hit swap disk for the required memory which is greater than memory installed/available.
    Code (Text):
    PHPFINFO_STANDALONE='y'

    then run centmin.sh menu option 5 to recompile PHP

    though they mention also database issue too
    that ain't permissions issue, that is issue with your plugin's PHP code - maybe compatibility with version of PHP you're using

    though I see /tmp being used - /tmp has noexec permissions set in Centmin Mod so you can't execute code or scripts from /tmp directory.

    So looks like you need to change defined /tmp location for wordpress https://cometcache.com/kb-article/how-do-i-define-a-wordpress-temp-directory/
    Code (Text):
    mkdir -p /home/nginx/domains/yourdomain.com/temp
    chown nginx:nginx /home/nginx/domains/yourdomain.com/temp
    chmod 777 /home/nginx/domains/yourdomain.com/temp
    

    set in your wordpress wp-config.php file
    Code (Text):
    define('WP_TEMP_DIR','/home/nginx/domains/yourdomain.com/temp');
     
  18. EckyBrazzz

    EckyBrazzz Active Member

    230
    40
    28
    Mar 28, 2018
    Brazil
    Ratings:
    +78
    Local Time:
    2:28 PM
    1.15.x
    10.3.x
    Code (Text):
    php --ri fileinfo
    Extension 'fileinfo' not present.
    

    Strange, I started this Droplet with a 4GB when using the installer for CMM. (ref: https://community.centminmod.com/th...01-install-time-stats.8866/page-15#post-72213 )
    Normally when things go bad, I start a new Droplet from a snapshot and select the smallest one to save on SSD space, just to keep it flexible to go back when upgrading to more memory or different CPU. But that can't be a reason that it was missing the extension

    But resolved it by adding
    Code (Text):
    PHPFINFO='y'                    # Force to install phpinfo on systems with <1GB memory

    in the /etc/centminmod/custom_config.inc and recompile PHP. Was already confused why it took so long before this due to the compile time :). Now it the compile time dropped a lot and yeah, fileinfo works
    Code (Text):
    php --ri fileinfo                   
    fileinfo
    fileinfo support => enabled
    libmagic => 533
    

    Memory
    Code (Text):
    free -ml
                  total        used        free      shared  buff/cache   available
    Mem:           7821        1719        3014          43        3087        5683
    Low:           7821        4806        3014
    High:             0           0           0
    Swap:          1023           0        1023
    

    But the system is just up and running for 1 hour so the High won't show up.

    So A little work to do @eva2000 FIX: check/add for fileinfo on recompile PHP if memory changed.

    Well, the recompile of PHP with fileinfo fixed the issue with the flags.

    Screenshot_12.png
    But still got a some of errors. Did not make the change to the tmp dir, the fatal error disappeared.
    Code:
    Notice: Trying to get property 'flag' of non-object in /home/nginx/domains/${vhostname}/public/wp-content/plugins/sitepress-multilingual-cms/menu/edit-languages.php on line 400
    
    Notice: Trying to get property 'from_template' of non-object in /home/nginx/domains/${vhostname}/public/wp-content/plugins/sitepress-multilingual-cms/menu/edit-languages.php on line 401
    The contect of line 400 and 401 are
    PHP:
            function get_active_languages() {
                    global 
    $sitepress$wpdb;
                    
    $this->active_languages $sitepress->get_active_languages(true);       

                    foreach (
    $this->active_languages as $lang) {
                            foreach (
    $this->active_languages as $lang_translation) {
                                    
    $this->active_languages[$lang['code']]['translation'][$lang_translation['id']] = $sitepress->get_display_language_name($lang['code'], $lang_translation['code']);
                            }
                            
    $flag $sitepress->get_flag($lang['code']);
                            
    $this->active_languages[$lang['code']]['flag'] = $flag->flag;
                            
    $this->active_languages[$lang['code']]['from_template'] = $flag->from_template;
                            
    $this->active_languages[$lang['code']]['default_locale'] = $wpdb->get_var$wpdb->prepare"SELECT default_locale FROM {$wpdb->prefix}icl_languages WHERE code=%s"$lan$
                
    $this->active_languages[$lang['code']]['encode_url'] = $lang['encode_url'];
                
    $this->active_languages[$lang['code']]['tag'] = $lang['tag'];
                    }


            }
    And the lines 400 and 401 are
    PHP:
                            $this->active_languages[$lang['code']]['flag'] = $flag->flag;
                            
    $this->active_languages[$lang['code']]['from_template'] = $flag->from_template;
     
    Last edited: May 4, 2019
  19. eva2000

    eva2000 Administrator Staff Member

    39,758
    8,769
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,494
    Local Time:
    3:28 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    That is probably the benefits of ccache compiler caching you're seeing as it speeds up subsequent recompiles of same versions by up to 80% faster - and what you're seeing with disk space increase due to ccache caching in /home/.ccache outlined at https://community.centminmod.com/threads/some-files-eating-up-my-ssd-space-in-home.17419/#post-73524 :) Initial centmin mod installs disable ccache compile cache too for first runs as ccache for first runs add a bit of compile time, so ccache is re-enabled for subsequent recompiles via centmin.sh menu to speed things up.

    Yeah that is a possibility.

    At least your plugin is working but probably need to ask plugin dev if the errors are php related.
     
  20. EckyBrazzz

    EckyBrazzz Active Member

    230
    40
    28
    Mar 28, 2018
    Brazil
    Ratings:
    +78
    Local Time:
    2:28 PM
    1.15.x
    10.3.x
..