Want to subscribe to topics you're interested in?
Become a Member

Anyone else getting 504 gateway timeout errors ?

Discussion in 'Forum Feedback & Suggestions' started by eva2000, Oct 19, 2016.

  1. eva2000

    eva2000 Administrator Staff Member

    28,957
    6,574
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,756
    Local Time:
    8:10 AM
    Nginx 1.13.x
    MariaDB 5.5
    Any other members getting 504 timeout errors more frequently after the forum's PHP 7 upgrade ? Specifically 504 not 502 (code list).

    I seem to get it more on my VPN connection to the forums. If i turn off VPN and access forums direct using ISP connection, i don't get 504 timeouts. Not sure if it's just me ?

    @RoldanLT @pamamolf @dorobo @SeaTea @Sunka
     
    Last edited: Oct 19, 2016
  2. pamamolf

    pamamolf Well-Known Member

    2,491
    229
    63
    May 31, 2014
    Ratings:
    +390
    Local Time:
    1:10 AM
    Nginx-1.13.x
    MariaDB 10.1.x
    That's the exact issue that i had on another topic with php 5.6.x :(
     
  3. eva2000

    eva2000 Administrator Staff Member

    28,957
    6,574
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,756
    Local Time:
    8:10 AM
    Nginx 1.13.x
    MariaDB 5.5
    you mean VPN related ? or 504 ?
     
  4. pamamolf

    pamamolf Well-Known Member

    2,491
    229
    63
    May 31, 2014
    Ratings:
    +390
    Local Time:
    1:10 AM
    Nginx-1.13.x
    MariaDB 10.1.x
  5. eva2000

    eva2000 Administrator Staff Member

    28,957
    6,574
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,756
    Local Time:
    8:10 AM
    Nginx 1.13.x
    MariaDB 5.5
    that's 502 not 504 How To Troubleshoot Common HTTP Error Codes | DigitalOcean

    nginx is the proxy to php-fpm backends.

    Only hitting 504 on my VPN connection not direct ISP connection. So probably something wrong with VPN. But was wondering any other members getting 504 on these forums themselves ? :)
     
  6. pamamolf

    pamamolf Well-Known Member

    2,491
    229
    63
    May 31, 2014
    Ratings:
    +390
    Local Time:
    1:10 AM
    Nginx-1.13.x
    MariaDB 10.1.x
    Yes maybe not related with yours but i had a vpn related issue ...

    When i used a vpn it was ok but i got an error when i used ISP it was ok....

    Don't have any other info that may help :-(

    At centminmod forum i didn't get any errors at the moment...
     
    • Informative Informative x 1
  7. eva2000

    eva2000 Administrator Staff Member

    28,957
    6,574
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,756
    Local Time:
    8:10 AM
    Nginx 1.13.x
    MariaDB 5.5
    on this forum right ?
     
  8. pamamolf

    pamamolf Well-Known Member

    2,491
    229
    63
    May 31, 2014
    Ratings:
    +390
    Local Time:
    1:10 AM
    Nginx-1.13.x
    MariaDB 10.1.x
    No on my friend's forum...

    At the moment i don't have any issue here.
     
  9. eva2000

    eva2000 Administrator Staff Member

    28,957
    6,574
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,756
    Local Time:
    8:10 AM
    Nginx 1.13.x
    MariaDB 5.5
    I see. For me the VPN 504 issue to this forum only started happening in last 24-48hrs.
     
  10. pamamolf

    pamamolf Well-Known Member

    2,491
    229
    63
    May 31, 2014
    Ratings:
    +390
    Local Time:
    1:10 AM
    Nginx-1.13.x
    MariaDB 10.1.x
    I was not very active the last hours on the forum but i will in a few hours and i will let you know if i got any errors....
     
    • Like Like x 1
  11. dorobo

    dorobo Active Member

    420
    104
    43
    Jun 6, 2014
    Ratings:
    +161
    Local Time:
    6:10 AM
    latest
    latest
    Using VPN now. I haven't seen the error yet.
     
    • Like Like x 1
  12. RoldanLT

    RoldanLT Well-Known Member

    3,828
    929
    113
    May 25, 2014
    Phillipines
    Ratings:
    +1,258
    Local Time:
    6:10 AM
    1.11
    10.2
    I don't have any errors on this Forum Eva.
     
    • Like Like x 1
  13. pamamolf

    pamamolf Well-Known Member

    2,491
    229
    63
    May 31, 2014
    Ratings:
    +390
    Local Time:
    1:10 AM
    Nginx-1.13.x
    MariaDB 10.1.x
    No errors for me also...
     
    • Like Like x 1
  14. eva2000

    eva2000 Administrator Staff Member

    28,957
    6,574
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,756
    Local Time:
    8:10 AM
    Nginx 1.13.x
    MariaDB 5.5
    Guess it must be specific to one of my VPNs L2TP IPSEC based. Tried my other VPNs OpenVPN based and they're fine.

    Didn't really know that a buggy VPN could cause 504 Gateway timeouts as i thought that is usually between the nginx proxy and php-fpm backend timeouts.
     
  15. dorobo

    dorobo Active Member

    420
    104
    43
    Jun 6, 2014
    Ratings:
    +161
    Local Time:
    6:10 AM
    latest
    latest
    ah yes I'm also using OpenVPN.
     
    • Like Like x 1
  16. eva2000

    eva2000 Administrator Staff Member

    28,957
    6,574
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,756
    Local Time:
    8:10 AM
    Nginx 1.13.x
    MariaDB 5.5
    seems the L2TP IPSEC VPN is fine today connecting to my forums - no 504 gateway timeouts. Really weird :)

    Guess need to research into how VPNs can possibly cause 504 gateway timeout errors :)
     
    Last edited: Oct 19, 2016
  17. pamamolf

    pamamolf Well-Known Member

    2,491
    229
    63
    May 31, 2014
    Ratings:
    +390
    Local Time:
    1:10 AM
    Nginx-1.13.x
    MariaDB 10.1.x
    I would love to see that as it may help to find a software bug as it seems to not be a normal behaviour :)
     
  18. deltahf

    deltahf Active Member

    203
    99
    28
    Jun 8, 2014
    Ratings:
    +149
    Local Time:
    6:10 PM
    I turned on my VPN to check this and I haven't noticed any problems yet.

    I use the small plan from Cloak. It is very affordable at $2.99 per month and (on a Mac) you can choose any location for their VPN servers for easy testing from other locations.
     
    • Like Like x 1
  19. eva2000

    eva2000 Administrator Staff Member

    28,957
    6,574
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,756
    Local Time:
    8:10 AM
    Nginx 1.13.x
    MariaDB 5.5
    thanks for checking :)

    haven't seen the problem since for me :)
     
  20. deltahf

    deltahf Active Member

    203
    99
    28
    Jun 8, 2014
    Ratings:
    +149
    Local Time:
    6:10 PM
    Well, hang on, I may have spoken too soon! :p

    I actually just had a 405 Not Allowed error pop up when I tried to "dislike" your post in the Epic VPN Comparison Chart thread. I closed the XenForo error box and tried again, then it worked. o_O I'm still running through the VPN.