Join the community today
Register Now

Xenforo [alert] 29123#0: *119322 zero size buf in output t:0 r:0 f:1

Discussion in 'Forum software usage' started by rdan, Jun 30, 2014.

Tags:
  1. rdan

    rdan Well-Known Member

    4,549
    1,090
    113
    May 25, 2014
    Ratings:
    +1,591
    Local Time:
    5:42 PM
    Mainline
    10.2
    I have a lot of this error:



    How to fix this?


     
  2. rdan

    rdan Well-Known Member

    4,549
    1,090
    113
    May 25, 2014
    Ratings:
    +1,591
    Local Time:
    5:42 PM
    Mainline
    10.2
    Something to do with LiveUpdate addon?
     
  3. eva2000

    eva2000 Administrator Staff Member

    40,656
    9,032
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,905
    Local Time:
    7:42 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    never seen that error before although live update addon was hanging up my php-fpm unix socket connections with updates frequency being too fast <20 seconds
     
    style="display:inline-block;min-width:400px;max-width:970px;width:95%;height:90px" data-ad-client="ca-pub-6669518204467592" data-ad-slot="4024536743" data-ad-format="auto">
  4. rdan

    rdan Well-Known Member

    4,549
    1,090
    113
    May 25, 2014
    Ratings:
    +1,591
    Local Time:
    5:42 PM
    Mainline
    10.2
    So did you disable LiveUpdate addon here?
    Mine is set to update every 60 seconds on admin option.
     
  5. rdan

    rdan Well-Known Member

    4,549
    1,090
    113
    May 25, 2014
    Ratings:
    +1,591
    Local Time:
    5:42 PM
    Mainline
    10.2
    That error is on my /domain.com/log/error.log
     
  6. eva2000

    eva2000 Administrator Staff Member

    40,656
    9,032
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,905
    Local Time:
    7:42 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    i raised the frequency of checks from original 10 seconds to 20 seconds but switching from php-fpm pool unix sockets back to TCP fixed my hanging issue but never experienced your error

    from http://mailman.nginx.org/pipermail/nginx-devel/2014-January/004740.html suggests that error is harmless and occurs when request has an empty response (
    Content-Length: 0)

    You using default Centmin Mod TCP php-fpm single instance or started playing with load balanced upstreams ?
     
  7. rdan

    rdan Well-Known Member

    4,549
    1,090
    113
    May 25, 2014
    Ratings:
    +1,591
    Local Time:
    5:42 PM
    Mainline
    10.2
    Nah I don't know how to configure correctly load balance upstream :D
    Just default settings of CentMinMod.

    Applying multiple instances of php-fpm would be better?
     
  8. eva2000

    eva2000 Administrator Staff Member

    40,656
    9,032
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +13,905
    Local Time:
    7:42 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    if you have a PHP intensive site/load then yeah but only as far as you having enough cpu threads to service the php-fpm workers. If you don't have enough cpu threads, having more php-fpm workers than cpu threads tends to do the opposite and slow things down
     
  9. rdan

    rdan Well-Known Member

    4,549
    1,090
    113
    May 25, 2014
    Ratings:
    +1,591
    Local Time:
    5:42 PM
    Mainline
    10.2
    I have 4 cores and 4 threads.