Want to subscribe to topics you're interested in?
Become a Member

Nginx After changed the hostname on the server the vhosts stopped responding

Discussion in 'Nginx, PHP-FPM & MariaDB MySQL' started by happyhacking, Jan 7, 2022.

  1. happyhacking

    happyhacking Member

    38
    9
    8
    Apr 23, 2021
    Ratings:
    +21
    Local Time:
    3:56 PM
    1.19.10
    MariadDB 10.4.18
    Hi eva2000, today I changed the default hostname on 9 vps production servers the following way:


    First changed the hostname with hostnamectl set-hostname new domain
    Second i edited the default vhost config file with new domain
    Third i did updated the hosts file with the new domain
    Then i did a reboot and surprisingly the single ss vhost configured stopped working, i did disabled csf but the vhost remained unconnectable, what could be wrong about changing system hostname ? I cant even connect inside the server with lynx to the https hostname.


    SOLVED: I did a mistake on ssl-vhost config file replacing 443 for [::]:443 instead on adding it, to support both IPv4 and IPv6, please delete this post if possible ;)
     
    Last edited: Jan 7, 2022
  2. eva2000

    eva2000 Administrator Staff Member

    48,487
    11,113
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +17,303
    Local Time:
    6:56 AM
    Nginx 1.21.x
    MariaDB 10.x
    No need to delete, useful for other folks to search and find the solution if they do the same mistake :)