Learn about Centmin Mod LEMP Stack today
Register Now

Install addon python27_install

Discussion in 'Add Ons' started by apidevlab, May 8, 2016.

  1. apidevlab

    apidevlab Member

    88
    30
    18
    Mar 22, 2016
    /dev/null
    Ratings:
    +54
    Local Time:
    11:16 PM
    1.11.1
    5.2.14-122
    I have tried to install the addon and am running into an issue:

    Code (Text):
    ================================================================================
     Package  Arch  Version  Repository
      Size
    ================================================================================
    Installing:
     python27  x86_64  2.7.11-1.ius.centos6  ius  80 k
     python27-devel  x86_64  2.7.11-1.ius.centos6  ius  387 k
     python27-pip  noarch  8.1.0-1.ius.centos6  ius  1.6 M
     python27-setuptools  noarch  19.7-1.ius.centos6  ius  445 k
     python27-tools  x86_64  2.7.11-1.ius.centos6  ius  444 k
     python27-virtualenv  noarch  15.0.1-1.ius.centos6  ius  1.7 M
    Installing for dependencies:
     python27-libs  x86_64  2.7.11-1.ius.centos6  ius  5.6 M
     tkinter27  x86_64  2.7.11-1.ius.centos6  ius  376 k
    
    Transaction Summary
    ================================================================================
    
    Transaction Check Error:
      file /usr/bin/2to3 from install of python27-tools-2.7.11-1.ius.centos6.x86_64 conflicts with file from package python-tools-2.6.6-64.el6.x86_64
    


    So what are my options here? Everything is from ius repo / centos 6.7 / beta09
     
    • Informative Informative x 1
  2. eva2000

    eva2000 Administrator Staff Member

    30,156
    6,785
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,136
    Local Time:
    8:16 AM
    Nginx 1.13.x
    MariaDB 5.5
    I thought i fixed that in latest 123.09beta01

    just remove python-tools first before running addon
    Code (Text):
    yum -y remove python-tools
     
  3. apidevlab

    apidevlab Member

    88
    30
    18
    Mar 22, 2016
    /dev/null
    Ratings:
    +54
    Local Time:
    11:16 PM
    1.11.1
    5.2.14-122
    Cool many thanks, it was working AFAIK I only tried this yesterday after a git option 23 update :)
    Code (Text):
    Complete!
    /usr/bin/pydoc27
    /usr/bin/python2.7
    /usr/bin/python2.7-config
    /usr/share/doc/python27-devel-2.7.11/gdbinit
    /usr/bin/pip2.7
    /usr/bin/easy_install-2.7
    /usr/bin/virtualenv-2.7
    /usr/bin/2to3
    /usr/bin/idle27
    /usr/bin/msgfmt27.py
    /usr/bin/pygettext27.py
    /usr/bin/pynche27
    /usr/bin/smtpd27.py
    /usr/lib64/python2.7/Demo/tkinter/matt/bind-w-mult-calls-p-type.py
    /usr/lib64/python2.7/Tools/scripts/combinerefs.py
    
     
  4. apidevlab

    apidevlab Member

    88
    30
    18
    Mar 22, 2016
    /dev/null
    Ratings:
    +54
    Local Time:
    11:16 PM
    1.11.1
    5.2.14-122
    Just a heads up, as it's related to Letsencrypt (which I am currently experimenting with)

    Code (Text):
    [root@server letsencrypt]# sed -i "s|--python python2|--python python2.7|" letsencrypt-auto
    [root@server letsencrypt]# ./letsencrypt-auto --verbose
    


    Throwing the python-tools error again

    Code (Text):
    Package python-2.6.6-64.el6.x86_64 already installed and latest version
    Package python-devel-2.6.6-64.el6.x86_64 already installed and latest version
    Package python-virtualenv-1.10.1-1.el6.noarch already installed and latest version
    Package python-pip-7.1.0-1.el6.noarch already installed and latest version
    Resolving Dependencies
    --> Running transaction check
    ---> Package python-tools.x86_64 0:2.6.6-64.el6 will be installed
    --> Finished Dependency Resolution
    ......
    Transaction Check Error:
      file /usr/bin/2to3 from install of python-tools-2.6.6-64.el6.x86_64 conflicts with file from package python27-tools-2.7.11-1.ius.centos6.x86_64
    


    Essentially the exact reverse of the original error above.

     
    • Informative Informative x 1
  5. eva2000

    eva2000 Administrator Staff Member

    30,156
    6,785
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,136
    Local Time:
    8:16 AM
    Nginx 1.13.x
    MariaDB 5.5
    the letsencrypt manual method is a bit dated now as 123.09beta01le5 is where letsencrypt branch testing is and even that is dated and not up to speed with 123.09beta01 latest updates

    currently don't have the time to develop the letsencrypt branch/testing as caring for my mother after her heart surgery.

    but thanks for heads up.. just skip python-tools install in the instructions
     
  6. apidevlab

    apidevlab Member

    88
    30
    18
    Mar 22, 2016
    /dev/null
    Ratings:
    +54
    Local Time:
    11:16 PM
    1.11.1
    5.2.14-122
    Thanks for taking the time to respond, I have already found the 123.09beta01le5.

    I am really sorry to hear regarding your mum, I hope everything goes well :)
     
    • Like Like x 1
  7. eva2000

    eva2000 Administrator Staff Member

    30,156
    6,785
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +10,136
    Local Time:
    8:16 AM
    Nginx 1.13.x
    MariaDB 5.5