Want more timely Centmin Mod News Updates?
Become a Member

[Solved] Add Wordpress Nginx vhost + WP Super Cache with PHP suhosin Issue

Discussion in 'Bug Reports' started by Drilon, Sep 26, 2015.

  1. Drilon

    Drilon New Member

    4
    1
    3
    Sep 21, 2015
    New Jersey
    Ratings:
    +2
    Local Time:
    9:21 AM
    I wanted to install new WordPress with PHP Suhosin active but was not working what ever command you try to use as "wp" was not allowed by php,

    Solution if somebody will face with same issue:

    add this line at the end of php.ini file

    Code:
    suhosin.executor.include.whitelist = phar
    restart php

    Thanks.
     
    • Informative Informative x 1
  2. eva2000

    eva2000 Administrator Staff Member

    28,942
    6,570
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,751
    Local Time:
    9:21 AM
    Nginx 1.13.x
    MariaDB 5.5
    sweet thanks for that fix and heads up (y)
     
  3. eva2000

    eva2000 Administrator Staff Member

    28,942
    6,570
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,751
    Local Time:
    9:21 AM
    Nginx 1.13.x
    MariaDB 5.5
    FYI to set custom php settings might want to use a persistent .ini instead of php.ini for edits see PHP-FPM - CentminMod.com LEMP Nginx web stack for CentOS

    did you install suhosin via centmin.sh menu option 18 ? i might update that for your fix automatically in the generated suhosin.ini file :)
     
  4. Drilon

    Drilon New Member

    4
    1
    3
    Sep 21, 2015
    New Jersey
    Ratings:
    +2
    Local Time:
    9:21 AM
    Yes that will be better idea so if something get updated line will be there still.

    Thanks.
     
  5. eva2000

    eva2000 Administrator Staff Member

    28,942
    6,570
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +9,751
    Local Time:
    9:21 AM
    Nginx 1.13.x
    MariaDB 5.5