Welcome to Centmin Mod Community
Register Now

Beta Branch add NGINX_IOURING_PATCH variable support in 123.09beta01

Discussion in 'Centmin Mod Github Commits' started by eva2000, Aug 6, 2019.

  1. BamaStangGuy

    BamaStangGuy Active Member

    665
    191
    43
    May 25, 2014
    Ratings:
    +271
    Local Time:
    4:56 AM
    I am seeing the same.

    Code:
    2019/09/02 13:50:06 [crit] 20515#20515: *59091 aio read "/home/nginx/domains/bamapolitics.com/public/wp-content/uploads/2019/01/Prichard-AL-150x150.jpg" failed (14: Bad address) while sending response to client, client: 68.35.162.46, server: www.bamapolitics.com, request: "GET /wp-content/uploads/2019/01/Prichard-AL-150x150.jpg HTTP/1.1", host: "www.bamapolitics.com", referrer: "https://www.bamapolitics.com/alabama/counties/mobile-county/"
    


     
  2. eva2000

    eva2000 Administrator Staff Member

    49,563
    11,375
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +17,678
    Local Time:
    8:56 PM
    Nginx 1.21.x
    MariaDB 10.x
    yeah seems patch isn't 100% ready yet then, hence why it's disabled by default. So for now just disable it again and recompile nginx via centmin.sh menu option 4

    @BamaStangGuy @upgrade81 what's output for this command on your servers
    Code (Text):
    ulimit -l

    and
    Code (Text):
    ps -ef | awk '/nginx: worker/' | grep -v awk | awk '{print $2}' | while read p; do echo; prlimit --pid $p -l; done
     
  3. eva2000

    eva2000 Administrator Staff Member

    49,563
    11,375
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +17,678
    Local Time:
    8:56 PM
    Nginx 1.21.x
    MariaDB 10.x
    FYI, typo variable is not NGINX_IORURING_PATCH='y' but NGINX_IOURING_PATCH='y'

    eventually will do that when I get the time, hence why it's disabled by default for now

    @BamaStangGuy @upgrade81 I just updated 123.09beta01 with possible workaround Beta Branch - update NGINX_IOURING_PATCH routine in 123.09beta01 for non-openvz servers.
     
  4. steph40

    steph40 Member

    80
    15
    8
    Jan 28, 2019
    Ratings:
    +32
    Local Time:
    5:56 AM
    1.1.5
    mariadb 10
    Yep noticed that after a while, should have check my spelling first.
     
  5. eva2000

    eva2000 Administrator Staff Member

    49,563
    11,375
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +17,678
    Local Time:
    8:56 PM
    Nginx 1.21.x
    MariaDB 10.x
    yeah i think at one point i did post that typo'd version but corrected it in a post. Maybe you copy and pasted that :)
     
  6. upgrade81

    upgrade81 Member

    285
    17
    18
    Sep 5, 2016
    CH
    Ratings:
    +29
    Local Time:
    11:56 AM
    1.17
    10.3
    ulimit = 23789568

    and

    Code (Text):
    RESOURCE DESCRIPTION                         SOFT  HARD UNITS
    MEMLOCK  max locked-in-memory address space 65536 65536 bytes
    
    RESOURCE DESCRIPTION                         SOFT  HARD UNITS
    MEMLOCK  max locked-in-memory address space 65536 65536 bytes
    
    RESOURCE DESCRIPTION                         SOFT  HARD UNITS
    MEMLOCK  max locked-in-memory address space 65536 65536 bytes
    
    RESOURCE DESCRIPTION                         SOFT  HARD UNITS
    MEMLOCK  max locked-in-memory address space 65536 65536 byte
     
  7. Trung

    Trung New Member

    4
    0
    1
    Dec 2, 2019
    Ratings:
    +0
    Local Time:
    5:56 PM
    1.7.16
    MariaDB 10
    Hi,


    I'm following the guide on boosting LEMP stack here and trying to both 2 tips "Leverage Nginx Thread Pooling" and "Leverage Linux kernel 5.1+ and Nginx io_uring patch for better Async I/O". So I have two aio directive definitions in Nginx configuration file:

    Code:
    aio threads
    aio on
    Now I cannot start Nginx. If I run Nginx -t, it prompts me the start failed because I have duplicate aio directives declared. I have also checked the Nginx document about the directive, but not sure what value I need to use if I want to have both options. I guess if I use just "aio threads", it also means aio turned on, but not sure.

    And btw, should I use thread pool feature if my VPS just has 1 core CPU and 1024 MB memory? If I can, what is the pool size should I consider configuring?

    Thanks!
     
  8. eva2000

    eva2000 Administrator Staff Member

    49,563
    11,375
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +17,678
    Local Time:
    8:56 PM
    Nginx 1.21.x
    MariaDB 10.x
    from linked article at https://www.nginx.com/blog/thread-pools-boost-performance-9x/

    no benefit if you have only 1 cpu thread :)
     
  9. Dnyan

    Dnyan Member

    106
    24
    18
    Sep 16, 2017
    Ratings:
    +36
    Local Time:
    4:26 PM
    1.17.8
    10.3.22
    Updated to latest kernel 5.7+

    using NGINX_IOURING_PATCH='y' in variable

    do not see anything in nginx compilation log nor nginx -V showing --with-file-aio

    On KVM VPS
     
  10. adzkii

    adzkii Member

    38
    1
    8
    Apr 15, 2020
    Ratings:
    +3
    Local Time:
    10:56 AM
    try
    Code (Text):
    NGINX_IOURING_PATCH_BETA='y'
    
     
  11. Dnyan

    Dnyan Member

    106
    24
    18
    Sep 16, 2017
    Ratings:
    +36
    Local Time:
    4:26 PM
    1.17.8
    10.3.22
    Ok Will try that, thank you for update
     
  12. rdan

    rdan Premium Member Premium Member

    5,369
    1,353
    113
    May 25, 2014
    Ratings:
    +2,111
    Local Time:
    6:56 PM
    Mainline
    10.2
    Using ELRepo 5.4.x Kernel, I got this:
     
  13. eva2000

    eva2000 Administrator Staff Member

    49,563
    11,375
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +17,678
    Local Time:
    8:56 PM
    Nginx 1.21.x
    MariaDB 10.x
    when NGINX_IOURING_PATCH_BETA='y' is set, the nginx aio directive should automatically be adjusted in nginx.conf to be enabled = aio on.

    what output to you get for command
    Code (Text):
    grep -i aio /usr/local/nginx/conf/nginx.conf
     
  14. rdan

    rdan Premium Member Premium Member

    5,369
    1,353
    113
    May 25, 2014
    Ratings:
    +2,111
    Local Time:
    6:56 PM
    Mainline
    10.2
    Not present, even the --with-file-aio on Nginx -V isn't present, weird.
     
  15. rdan

    rdan Premium Member Premium Member

    5,369
    1,353
    113
    May 25, 2014
    Ratings:
    +2,111
    Local Time:
    6:56 PM
    Mainline
    10.2
    Oh I use a slightly different config:
    NGINX_IOURING_PATCH='y'
     
  16. rdan

    rdan Premium Member Premium Member

    5,369
    1,353
    113
    May 25, 2014
    Ratings:
    +2,111
    Local Time:
    6:56 PM
    Mainline
    10.2
  17. eva2000

    eva2000 Administrator Staff Member

    49,563
    11,375
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +17,678
    Local Time:
    8:56 PM
    Nginx 1.21.x
    MariaDB 10.x
    I disabled that flag for NGINX_IOURING_PATCH_BETA to prevent folks using Nginx IOURING as it was buggy heh