Welcome to Centmin Mod Community
Become a Member

Letsencrypt SSL acmetool.sh not renewing certificate for one site

Discussion in 'Add Ons' started by CarpCharacin, Aug 7, 2017.

  1. CarpCharacin

    CarpCharacin Member

    265
    21
    18
    Oct 13, 2016
    Salt Lake City
    Ratings:
    +34
    Local Time:
    7:31 PM
    1.15.x
    MariaDB 10.1
    I made those edits and it is no longer redirecting but it just says error certificate date invalid. I tried renewing the certificate by running
    ./acmetool.sh renewall and it looked like it worked, but it said the certificate authority was invalid, so I ran the 3 commands you posted earlier and it worked. The only problem is that it says ERR_SPDY_PROTOCOL_ERROR in the chrome developer tools.

    Also, does it mater how many spaces are before the listen directives in the configuration file? In the utahfishkeepers.us config file, there are 4 spaces below server {, before the listen directives under server, but in your post, you have 3 spaces before the listen directives.
     
  2. eva2000

    eva2000 Administrator Staff Member

    45,728
    10,382
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,112
    Local Time:
    12:31 PM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    doesn't matter how many spaces are to the left of a nginx directive

    as to SPDY error, is your web browser's pc behind a VPN or http proxy ? including antivirus software which does man in the middle HTTPS connections.

    anti-virus scanner ? Avast ? or virus scanner with HTTPS scanning or a web browser shield of some form ? https://productforums.google.com/forum/#!topic/chrome/sfAqeo4hDy8

    try using internet explorer, firefox or edge web browsers too
     
  3. CarpCharacin

    CarpCharacin Member

    265
    21
    18
    Oct 13, 2016
    Salt Lake City
    Ratings:
    +34
    Local Time:
    7:31 PM
    1.15.x
    MariaDB 10.1
    The error appeared in Chrome OS 60, but it doesn't appear in chrome 61 on windows 10. My computer isn't behind a proxy or VPN, and I don't have a web browser shield. I just have windows defender on my desktop computer that runs windows 10. Also, I deleted my xf2.utahfishkeepers.us vhost and directory since I no longer needed it, but now it's just redirecting to carpcharacin.rocks. Shouldn't it be displaying the centmin mod test page instead, since I haven't removed the DNS records yet?
     
    Last edited: Sep 19, 2017