Welcome to Centmin Mod Community
Become a Member

Nginx accept range requests is not working.

Discussion in 'Nginx, PHP-FPM & MariaDB MySQL' started by Stephen Dennis, Feb 25, 2021.

  1. Stephen Dennis

    Stephen Dennis New Member

    6
    2
    3
    Feb 21, 2018
    Ratings:
    +2
    Local Time:
    2:24 PM
    1.13.8
    10.1.30
    Uptime Monitor Settings

    Webpage is too large for keyword monitoring and partial content downloading is disabled! To allow keyword monitoring please either:
    1) enable partial content downloading on your webpage... more info

    I added to conf file:


    server {
    listen 443 ssl http2 reuseport;

    add_header Accept-Ranges bytes;
    proxy_force_ranges on;

    still doesnt work
    curl -I response

    HTTP/1.1 200 OK
    Date: Thu, 25 Feb 2021 10:34:36 GMT
    Content-Type: text/html; charset=UTF-8
    Connection: keep-alive
    Vary: Accept-Encoding
    Last-Modified: Tue, 23 Feb 2021 22:37:42 GMT
    Server: nginx centminmod
    X-Powered-By: centminmod
    Accept-Ranges: bytes
    X-Xss-Protection: 1; mode=block
    X-Content-Type-Options: nosniff
     
  2. eva2000

    eva2000 Administrator Staff Member

    47,535
    10,787
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,772
    Local Time:
    6:24 AM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    Are you running Centmin Mod Nginx server as a reverse proxy in front of another site ?
     
  3. Stephen Dennis

    Stephen Dennis New Member

    6
    2
    3
    Feb 21, 2018
    Ratings:
    +2
    Local Time:
    2:24 PM
    1.13.8
    10.1.30
    Hi George, first, thank you for Centminmod. No, not running it as reverse proxy this time. I'm just running it as a web server. I am setting an uptime monitor that checks for a keyword and getting this message, so i was trying to enable partial content downloading as per below:

    Webpage is too large for keyword monitoring and partial content downloading is disabled! To allow keyword monitoring please either:
    1) enable partial content downloading on your webpage... more info
    2) or, reduce the webpage text size to below 50kB... more info
     
  4. eva2000

    eva2000 Administrator Staff Member

    47,535
    10,787
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +16,772
    Local Time:
    6:24 AM
    Nginx 1.19.x
    MariaDB 5.5/10.x
    If the service allows, you can add a header to the request/check just add 'Accept-Encoding: gzip'header to uptime service side so uptime check process will download the compressed version of the page which would be smaller. But if you're only checking if the site/web server is up, you can just create a smaller version of the same page to check from - this will also save you bandwidth if your uptime check is very frequent i.e. every 1 second as that would mean 86,400 seconds per day x 50KB = 4.12GB per day
     
  5. Stephen Dennis

    Stephen Dennis New Member

    6
    2
    3
    Feb 21, 2018
    Ratings:
    +2
    Local Time:
    2:24 PM
    1.13.8
    10.1.30
    Thanks for the work around, without centminmod set up as a reverse proxy.