Want to subscribe to topics you're interested in?
Become a Member

Bug A small bug on the conf file when adding WordPress site with Redis

Discussion in 'AlmaLinux 8 & Rocky Linux 8 Beta Testing' started by minodd, Mar 5, 2023.

  1. minodd

    minodd Member

    31
    4
    8
    Nov 29, 2018
    Ratings:
    +12
    Local Time:
    11:08 AM
    Nginx 1.15.6
    MariaDB 10
    1. Your web host and VPS/dedicated server plan?
    Netcup RS 2000 G9.5, 6 x AMD EPYC 7702P, Rocky Linux 8.7, 16G RAM, PHP 8.1

    2. Centmin Mod installed version info via command below:
    130.00beta01


    Problem:
    When I created a WordPress site with Redis, nginx can't restart. I checked the conf file, and found that a "#" is missing before the "try_files" line under fastcgi_cache. I've attached a screenshot below. I tried twice, and this problem remained. Would you please take a look at this?

    Screenshot
     
  2. eva2000

    eva2000 Administrator Staff Member

    52,186
    11,998
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +18,501
    Local Time:
    1:08 PM
    Nginx 1.25.x
    MariaDB 10.x
    Thanks for the bug report. Did this happen on CentOS 7 too or just Rocky Linux 8.7 specific?
     
  3. minodd

    minodd Member

    31
    4
    8
    Nov 29, 2018
    Ratings:
    +12
    Local Time:
    11:08 AM
    Nginx 1.15.6
    MariaDB 10
    Hey, I guess I've found out the reason. I've done a few tests on different VMs with different OS and settings, then I realized that, the VM which has this problem has a line "WP_FASTCGI_CACHE='y'" in the custom_config.inc. So with this setting, each time when I choose Redis, the problem happens.
     
  4. eva2000

    eva2000 Administrator Staff Member

    52,186
    11,998
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +18,501
    Local Time:
    1:08 PM
    Nginx 1.25.x
    MariaDB 10.x
    Ah that explains it as WP_FASTCGI_CACHE='y' triggers a separate set of templates for centmin.sh menu option 22 compared to without WP_FASTCGI_CACHE='y'. There must be a discrepancy when WP_FASTCGI_CACHE='y' is set! Will see I can find it :)

    For now, if you intend to use Redis nginx level cache, just comment out WP_FASTCGI_CACHE='y' in your persistent config file /etc/centminmod/custom_config.inc BEFORE you run centmin.sh menu option 22.
     
  5. minodd

    minodd Member

    31
    4
    8
    Nov 29, 2018
    Ratings:
    +12
    Local Time:
    11:08 AM
    Nginx 1.15.6
    MariaDB 10
    Thank you buddy! Already put an "#" in front of it:D
     
  6. eva2000

    eva2000 Administrator Staff Member

    52,186
    11,998
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +18,501
    Local Time:
    1:08 PM
    Nginx 1.25.x
    MariaDB 10.x
  7. minodd

    minodd Member

    31
    4
    8
    Nov 29, 2018
    Ratings:
    +12
    Local Time:
    11:08 AM
    Nginx 1.15.6
    MariaDB 10