Want to subscribe to topics you're interested in?
Become a Member

Xenforo 404 pages do not display XenForo error pages, instead just showing the nginx error

Discussion in 'Forum software usage' started by rdan, Jun 3, 2014.

  1. Derek

    Derek Member

    47
    9
    8
    Aug 5, 2016
    Ratings:
    +22
    Local Time:
    11:34 PM
    That's certainly motivation to better understand the change you made! I'm glad I posted my summary above because I recently moved my server and needed to make the same changes again.


    Roldan, can you give a bit more information on what you've changed?
     
  2. rdan

    rdan Well-Known Member

    5,426
    1,389
    113
    May 25, 2014
    Ratings:
    +2,172
    Local Time:
    12:34 PM
    Mainline
    10.2
    Only improve how 404 pages should look like.
    I pointed all 404 request to xenforo generated page.
     
  3. Jon Snow

    Jon Snow Active Member

    727
    150
    43
    Jun 30, 2017
    Ratings:
    +215
    Local Time:
    12:34 AM
    Nginx 1.13.9
    MariaDB 10.1.31
    Traffic stats increasing should be normal I guess since it goes to one of your XF pages with your traffic script.
     
  4. eva2000

    eva2000 Administrator Staff Member

    50,870
    11,786
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +18,240
    Local Time:
    2:34 PM
    Nginx 1.25.x
    MariaDB 10.x
    Nice about SEO but ads like Google Adsense prohibit ads on pages without useful content IIRC?
     
  5. rdan

    rdan Well-Known Member

    5,426
    1,389
    113
    May 25, 2014
    Ratings:
    +2,172
    Local Time:
    12:34 PM
    Mainline
    10.2
    I never display ads on those pages.
     
  6. rdan

    rdan Well-Known Member

    5,426
    1,389
    113
    May 25, 2014
    Ratings:
    +2,172
    Local Time:
    12:34 PM
    Mainline
    10.2
  7. eva2000

    eva2000 Administrator Staff Member

    50,870
    11,786
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +18,240
    Local Time:
    2:34 PM
    Nginx 1.25.x
    MariaDB 10.x
    Yeah it's only setup for non-XF pages :)
     
  8. rdan

    rdan Well-Known Member

    5,426
    1,389
    113
    May 25, 2014
    Ratings:
    +2,172
    Local Time:
    12:34 PM
    Mainline
    10.2
    It's missing now, no idea why :{.
     
  9. eva2000

    eva2000 Administrator Staff Member

    50,870
    11,786
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +18,240
    Local Time:
    2:34 PM
    Nginx 1.25.x
    MariaDB 10.x
    yeah IIRC google stopped that feature :(
     
  10. rdan

    rdan Well-Known Member

    5,426
    1,389
    113
    May 25, 2014
    Ratings:
    +2,172
    Local Time:
    12:34 PM
    Mainline
    10.2
  11. eva2000

    eva2000 Administrator Staff Member

    50,870
    11,786
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +18,240
    Local Time:
    2:34 PM
    Nginx 1.25.x
    MariaDB 10.x
    yeah error_page 404 /404.html; in nginx vhost itself :)
     
  12. rdan

    rdan Well-Known Member

    5,426
    1,389
    113
    May 25, 2014
    Ratings:
    +2,172
    Local Time:
    12:34 PM
    Mainline
    10.2
    On what specific location? :D
    Some 404 page are serve by xenforo.
     
  13. eva2000

    eva2000 Administrator Staff Member

    50,870
    11,786
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +18,240
    Local Time:
    2:34 PM
    Nginx 1.25.x
    MariaDB 10.x
    outside of web root / location so within server{} context.
     
  14. rdan

    rdan Well-Known Member

    5,426
    1,389
    113
    May 25, 2014
    Ratings:
    +2,172
    Local Time:
    12:34 PM
    Mainline
    10.2
    Got it Thanks!