Join the community today
Become a Member

Xenforo 404 not found

Discussion in 'Forum software usage' started by Afterward, Sep 20, 2014.

  1. Afterward

    Afterward Member

    94
    29
    18
    Jul 20, 2014
    Ratings:
    +29
    Local Time:
    1:39 PM
    1.7.5
    5.5
    Since i fixed the issue of accessing the forum i was releved but now another issue poped of nowhere :/
    I use xenforo and resource manager and the problem is the following:
    Code:
    https://www.domain.com/resources/resource name.11/rate
    This will take you to the page to rate the resource right but when i try to rate any resource i get this:
    Failed to load resource: the server responded with a status of 404 (OK) https://www.domain.com/resources/resource name.11/rate
    I'm so lost guys.
     
  2. rdan

    rdan Premium Member Premium Member

    4,219
    1,027
    113
    May 25, 2014
    Ratings:
    +1,466
    Local Time:
    8:39 PM
    Mainline
    10.2
  3. Afterward

    Afterward Member

    94
    29
    18
    Jul 20, 2014
    Ratings:
    +29
    Local Time:
    1:39 PM
    1.7.5
    5.5
    Yes i did have seo friendly url enabled, maybe you got me wrong but its the rate function wich is not working.
     
  4. eva2000

    eva2000 Administrator Staff Member

    35,038
    7,734
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +11,928
    Local Time:
    10:39 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
  5. rdan

    rdan Premium Member Premium Member

    4,219
    1,027
    113
    May 25, 2014
    Ratings:
    +1,466
    Local Time:
    8:39 PM
    Mainline
    10.2
    rate is also working fine on mine.
     
  6. Afterward

    Afterward Member

    94
    29
    18
    Jul 20, 2014
    Ratings:
    +29
    Local Time:
    1:39 PM
    1.7.5
    5.5
    Checked nginx error log, nothing related to my issue, same for php-fm check even nginx upgrade log and no errors on it, could it be because of nginx_pagespeed?
     
  7. rdan

    rdan Premium Member Premium Member

    4,219
    1,027
    113
    May 25, 2014
    Ratings:
    +1,466
    Local Time:
    8:39 PM
    Mainline
    10.2
    No, but maybe you enable block.conf ?
     
  8. Afterward

    Afterward Member

    94
    29
    18
    Jul 20, 2014
    Ratings:
    +29
    Local Time:
    1:39 PM
    1.7.5
    5.5
    Not at all.
     
  9. Afterward

    Afterward Member

    94
    29
    18
    Jul 20, 2014
    Ratings:
    +29
    Local Time:
    1:39 PM
    1.7.5
    5.5
    Update: i fixed it by uncommenting
    Code:
    #include /usr/local/nginx/conf/errorpage.conf;
    Thanks to @eva2000 and @RoldanLT , without you guys i wouldn't notice what i was doing wrong.
     
    • Like Like x 2
  10. eva2000

    eva2000 Administrator Staff Member

    35,038
    7,734
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +11,928
    Local Time:
    10:39 PM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    Glad you fixed it.. could be by removing those custom html error pages from public directory and enabling the errorpage.conf config caused problems as it could no longer find those custom html error pages you removed
     
    • Like Like x 1
..