Get the most out of your Centmin Mod LEMP stack
Become a Member

2 Machines Locked Up

Discussion in 'Bug Reports' started by Jimmy, May 23, 2019.

  1. Jimmy

    Jimmy Well-Known Member

    1,569
    321
    83
    Oct 24, 2015
    East Coast USA
    Ratings:
    +810
    Local Time:
    2:47 PM
    1.15.x
    MariaDB 10.3.x
    Centos 7. 09 beta. Both with running systems.

    I changed my custom_config to the below and then did cmdir -> centmin -> cursor locked. The server locks trying to get into the centmin menu. Now I can't even login to the server. Total locked out (connection timed out).

    This happened on 2 servers.

    Any ideas what is causing this in the custom config? It's the only thing I changed. The second server doesn't even have a site on it, just a stock centmin mod install. Both were working fine before I changed the custom_config.

    Code:
    LETSENCRYPT_DETECT='n'
    NGINX_UPDATEMAINTENANCE='y'
    PHP_UPDATEMAINTENANCE='y'
    MARIADB_UPDATEMAINTENANCE='y'
    CUSTOM_CURLRPM='y'
    AUTOTUNE_CLIENTMAXBODY='y'
    NSD_INSTALL='n'
    NGINX_DYNAMICTLS='y'
    NGXDYNAMIC_GEOIPTWOLITE='y'
    NGXDYNAMIC_NGXPAGESPEED='n'
    NGINX_HPACK='y'
    NGINX_GEOIPTWOLITE='y'
    NGINX_LIBBROTLI='y'
    NGINX_BROTLIDEP_UPDATE='y'
    NGINX_DYNAMICTLS='n'
    NGINX_IPV='y'
    NGINX_VIDEO='y'
    NGINXBACKUP='n'
    NGINXPATCH='y'
    MARIADB_INSTALLTENTWO='n'
    MARIADB_INSTALLTENTHREE='y'
    MARIADB_INSTALLTENFOUR='n'
    ENABLE_MARIADBTENTWOUPGRADE='y'
    ENABLE_MARIADBTENTHREEUPGRADE='y'
    PHP_PGO='y'
    PHP_TUNING='y'
    PHP_OVERWRITECONF='n'
    PHP_MEMCACHE='n'
    PHP_MEMCACHED='n'
    PHP_TUNING='y'
    PHP_BROTLI='y'
    PHP_LZFOUR='y'
    PHP_LZF='y'
    PHP_ZSTD='y'
    PHP_CUSTOMSSL='y'
    PHP_ARGON='y'
    AUTODETECPHP_OVERRIDE='y'
    PHPREDIS='y'
    DISABLE_TLSONEZERO_PROTOCOL='y'
    NOSOURCEOPENSSL='n'
    LIBRESSL_SWITCH='n'
    OPENSSLECDSA_PATCH='y'
    OPENSSLECDHX_PATCH='y'
    OPENSSLEQUALCIPHER_PATCH='y'
    VHOSTCTRL_CLOUDFLAREINC='y'
    VHOSTCTRL_AUTOPROTECTINC='n'
    CLOUDFLARE_PATCHSSL='y'
    CLOUDFLARE_ZLIB='y'
    CLOUDFLARE_ZLIBPHP='y'
    CLOUDFLARE_ZLIB_OPENSSL='y'

     
    Last edited: May 23, 2019
  2. Jimmy

    Jimmy Well-Known Member

    1,569
    321
    83
    Oct 24, 2015
    East Coast USA
    Ratings:
    +810
    Local Time:
    2:47 PM
    1.15.x
    MariaDB 10.3.x
    I can't even get the VPS to reboot from ssdnodes control panel. It give me a "server error, contact support." on both servers. Thank god I didn't do this on my busy VPS!
     
  3. Jimmy

    Jimmy Well-Known Member

    1,569
    321
    83
    Oct 24, 2015
    East Coast USA
    Ratings:
    +810
    Local Time:
    2:47 PM
    1.15.x
    MariaDB 10.3.x
    Here is my org custom_config - I replaced the below with was is above.

    Code:
    LETSENCRYPT_DETECT='n'
    NGINX_UPDATEMAINTENANCE='y'
    PHP_UPDATEMAINTENANCE='y'
    MARIADB_UPDATEMAINTENANCE='y'
    NGINXBACKUP='n'
    NGINX_IPV='y'
    NSD_INSTALL='n'
    NGINX_VIDEO='y' 
    NGINX_LIBBROTLI='y'
    NGXDYNAMIC_BROTLI='y'
    NGINX_BROTLIDEP_UPDATE='y'
    NGINX_DYNAMICTLS='y'
    NGINXPATCH='y'
    NGINX_GEOIPTWOLITE='y'
    NGXDYNAMIC_GEOIPTWOLITE='y'
    LIBRESSL_SWITCH='n'
    OPENSSLECDSA_PATCH='y'
    OPENSSLECDHX_PATCH='y'
    OPENSSLEQUALCIPHER_PATCH='y'
    CUSTOM_CURLRPM='y'
    PHP_PGO='y'
    PHP_TUNING='y'
    PHP_OVERWRITECONF='n'
    AUTOTUNE_CLIENTMAXBODY='y'
    NGINX_ALLOWOVERRIDE='y'
    VHOSTCTRL_CLOUDFLAREINC='y'
    VHOSTCTRL_AUTOPROTECTINC='n'
    CLOUDFLARE_PATCHSSL='y'
    CLOUDFLARE_ZLIB='y'
    CLOUDFLARE_ZLIBPHP='y'
    CLOUDFLARE_ZLIB_OPENSSL='y'
    DISABLE_IPVSIX='y'
     
  4. Jimmy

    Jimmy Well-Known Member

    1,569
    321
    83
    Oct 24, 2015
    East Coast USA
    Ratings:
    +810
    Local Time:
    2:47 PM
    1.15.x
    MariaDB 10.3.x
    Had to have the support restart the server. When I logged in I deleted the current custom_config and reverted back to the old one. When I went cmdir -> centmin I got the error below.

    Code:
    postconf: fatal: parameter inet_interfaces: no local interface found for ::1
    I guess it's the disable_ipvsix which I didn't add to the new custom_config?

    Not sure how to get rid of the above error, it keeps showing up everytime I log into the centmin mod menu.
     
  5. eva2000

    eva2000 Administrator Staff Member

    41,080
    9,189
    113
    May 24, 2014
    Brisbane, Australia
    Ratings:
    +14,098
    Local Time:
    4:47 AM
    Nginx 1.15.x
    MariaDB 5.5/10.x
    did server have working IPv6 in the first place before you added the persistent config /etc/centminmod/custom_config.inc settings and ran centmin.sh ?

    what's output for these commands
    Code (Text):
    postconf -d inet_protocols
    postconf -n inet_protocols
    

    you can force postfix to use IPv4 via
    Code (Text):
    postconf -e 'inet_protocols = ipv4'
    service postfix restart

    probbably specific to ssdnodes seeing as they use OpenVZ7

    might need to troubleshoot which persistent config /etc/centminmod/custom_config.inc settings variable (one at a time) is causing the lock ups.
     
    • Like Like x 1
  6. Jimmy

    Jimmy Well-Known Member

    1,569
    321
    83
    Oct 24, 2015
    East Coast USA
    Ratings:
    +810
    Local Time:
    2:47 PM
    1.15.x
    MariaDB 10.3.x
    No. It never had IPv6 - ssdnodes doesn't have IPv6. I forgot to add it to the custom_config when I updated the file with some additional settings.
    Code:
    # postconf -d inet_protocols
    inet_protocols = all
    # postconf -n inet_protocols
    postconf: fatal: parameter inet_interfaces: no local interface found for ::1
    Once ssdnodes support restarted my machine, I was able to access the custom_config again before I called centmin menu.

    I'm not seeing anything in my custom_config which would lock the machine up when calling the menu. Of course, I could be wrong.
    Code:
    postconf -e 'inet_protocols = ipv4'
    service postfix restart
    The above remove the error when entering the centmin mod menu.

    Kind of weird that not having that in the custom_config would lock up access.